Annoying errors while booting up 12.1

Hello there:) I am using SuSE 12.1 i586 on my laptop (HP g60). Unfortunately it was working hot and cpu was always under high load so I decided to update the kernel using SAKC to the latest stable version (3.4.7). Laptop now is cool, quiet and cpu is not heavy loaded however during system boot some errors are being shown. They delay 3-4 seconds to load the system but are also very annoying. Any ideas much appreciated. I would like to ask for simple&easy explanation of how to as I am not much experienced with Linux. Thanks a lot.](](

Looking at the second screen, you can eliminate most of these errors, caused by the HP Printer program hplib by going to the folder /etc/udev/rules.d/ and removing the files called 86-hpmud-*.rules except for the one file that has your printer name in it. For instance, in my folder I found 12 files like the one I mention, but only one file has my actual printer name in it. As a root user, you can remove all but the one named for your printer. Use the command in KDE **Alt-F2: kdesu dolphin /etc/udev/rules.d/ **then manually select the text files not needed and delete them.

I can’t hardly read the first screen, but it is indicating the resume device is not working. This is in the grub kernel load line. Here is my copy of that line from Grub:

kernel /boot/vmlinuz-3.5.0-1.4-desktop root=/dev/disk/by-id/ata-Corsair_Performance3_SSD_1117810101000341020B-part3 resume=**/dev/disk/by-id/ata-Corsair_Performance3_SSD_1117810101000341020B-part2** splash=silent quiet nomodeset showopts vga=0x345

In my case the resume device is show above and must exist as named. Why not look at your grub line entry and post a copy here. You can edit this grub menu using my fastboot utility you can get here:

FastBoot for Grub 2 or Grub Legacy Menu using Kexec - Version 2.13 - Blogs - openSUSE Forums

Thank You,

options: splash=silent quiet showopts vga=0x317

It takes few seconds to execute lines 9.400002 ata2.00 ACPI… and 14.900090 ata2.00 ACPI… And also wondering what “Toshiba” entries are doing there if my laptop is HP…

I’m going to reboot now to see whether tips for second issue worked :slight_smile: And it worked:) Top tip :slight_smile: Thank you :slight_smile:

By the way… how can I check what Kernel is loading and remove unecessary modules?

The hard drive is made by Toshiba.

This line “resume=/dev/disk/by-id/ata-TOSHIBA_MK2552GSX_X8EBC3MQT-part6” indicates Logical Partition 6 is a SWAP partition. Is that correct? Can you see it in YaST / System / Partitioner? You could open up a terminal session, run this command and give us the output in code # tags using the advanced message editor:

sudo /sbin/fdisk -l

Thank You,

You’re right, sda6 is a swap partiton…

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xcc50cc50

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63   269956259   134978098+  83  Linux
/dev/sda2       468766720   488390655     9811968   83  Linux
/dev/sda3   *   269956260   468760634    99402187+   f  W95 Ext'd (LBA)
/dev/sda5       269956323   415296376    72670027   83  Linux
/dev/sda6       415296378   417384764     1044193+  82  Linux swap / Solaris
/dev/sda7       417386496   448839679    15726592   83  Linux

Partition table entries are not in disk order

Vista was originally installed on this laptop however it finally gave up so decided to convert these partitions into ext3 and use them as a extra home ones.

So first off, I am not really sure what might be slowing you down, but the kernel says it can’t find the resume (swap) partition. Second, the partition order in the partition table does not match the physical partition order. If this was me, I would back up my /home folder, remove all Logical partitions and the extended partition. I am not sure what you are doing with /sda1 or sda2, but you have elected to load grub into the Extended Partition Table. This works, but never run Windows fdisk on it as it will blow it up. I prefer on an all Linux system to place the Grub boot loader into the MBR or load Grub into the root / folder, but putting it into the Extended Partition as you have done would be my last choice. Imagine that you could create an /sda3 as root /, sda4 as Extended, then place swap as sda5 and /home as sda6 and that assumes you are not using sda1 or sda2 for openSUSE. In the end, it may just be a slightly unconventional partition setup that the kernel is protesting about, but I just could not zoom in on that image and read all of the kernel output to know for sure.

Thank You,

When I have time I will try sort partitions out. sda1 and sda2 were originally ntfs partitions that were used by vista and vista recovery. As I removed Vista completely I converted them into ext3. With regards to Grub boot loader I didn’t do anything, I just installed SuSE alongside vista. I google how to move Grub boot loader into MBR or ask here if I approach some problems:) Thank you for your help, it explained a lot.

So normally for Grub, you just got to reinstall it to have it somewhere else. Its not hard to reinstall grub to match your old setup, should it be corrupted, but normally to change it, I just reinstall openSUSE making sure to setup a different booting setup. If the worst you have is a few added seconds on startup, one could live with that and don’t forget about my FastBoot utility that can trim more than a few second off. Also, making a backup of your import data and starting over is not all that bad if you have another hard drive or external drive. I never recommend using the same hard drive as I am doing an install on for backup data. Here is some very basic partition setup info:

Here is that FastBoot Utility again:

FastBoot for Grub 2 or Grub Legacy Menu using Kexec - Version 2.13 - Blogs - openSUSE Forums

Thank You,

On 2012-08-01 23:46, jdmcdaniel3 wrote:

> So first off, I am not really sure what might be slowing you down, but
> the kernel says it can’t find the resume (swap) partition.

I don’t see that in the photo (there would be more text and easier to read in the logs). The
kernel is attempting a restore from swap, which is correct, no problem there.

> Second, the
> partition order in the partition table does not match the physical
> partition order.

That’s not an issue, it is just cosmetical. It is perhaps a nuisance for the human that has to
maintain that, but otherwise the computer has no problem with it.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)