Annoyance Alert: .Xmodmap and KDE3.5 on i586


I’m having a very acute annoyance here. My KDE3 just won’t load .Xmodmap upon starting.

I’ve used 11.1 x86-64 for a few months now, and find the compose key marvellous (use it as Windows right key) and even better than windows alt codes! I had to, if I recollect correctly, to create .Xmodmap in ~, which was

keycode 116 = Multi_key

and that’s it.
And it worked in both Gnome and KDE3.

Now, using another computer, with freshly installed 11.1 i586 (+ latest updates). The multi key does work in Gnome (gives a prompt upon starting it to load .Xmodmap), but not at all in KDE3… So this rules out any keyboard incompatibility, since it works in one place.

I saw here the suggestion to create, in /home/pbl/.kde/Autostart, (pbl is me) which is

/usr/bin/xmodmap $HOME/.Xmodmap

It works, but only if I run the script manually by clicking on it… Perhaps it has to be different in openSUSE?

File details are:

-rwxr-xr-x 1 pbl users 24 2009-09-10 11:03 .Xmodmap

-rwxr-xr-x 1 pbl users 41 2009-09-10 11:38

Could you tell me how to make that run automatically when starting KDE3?

By the way, can I also extend the use of my .Xmodmap to the terminal consoles (ttys) ? (I guess not since it starts with X… but perhaps some substitute is around?) Well I tried to run the .Xmodmap in tty, but it says ‘unable to open display’. In fact all I would like in tty is to have multi key added.

Thank you.

I find using env vars in scripts can cause unexpected behavior have you tried the whole path where you used $HOME?

I have the following lines in my ~.xinitrc that do the trick

if  -x /usr/bin/xmodmap ]; then
  /usr/bin/xmodmap ~/.Xmodmap