Analogue sound chip is not seen by anything but yast2

Hello! I come to you all today with an interesting problem. I actually just finished dealing with another problem, and I’m not sure if this one is related or not. The last problem, just in case it matters, was resolved by reinstalling Opensuse without touching my home partition.

Anyway, they’re probably not related, so on to the current problem.
I have two sound chips in my machine: One on my video card (hooked up to my monitors) that I won’t be using, and one on my motherboard that I will. Originally, both chips were seen just fine. I did not get sound quite right though, so I went into Amarok and messed around with settings there. It turned out that if I did Configure Amarok>ConfigurePhonon>Audio Hardware Setup I could specify “built-in audio” and hear the test sound just fine. But I still could not hear Amarok’s playback sound. So I restarted amarok and restarted Configure Phonon, and the settings had reverted. So I went into systemsettings5 and pavucontrol, and tried various settings there. I honestly don’t remember exactly what I did in there, but it didn’t work. So I went to yast2, then found that both of my sound chips were “unconfigured.” set them both up to the default configuration, labeled the onboard audio as default. Also removed power-saving. Then I went back to pavucontrol and phonon and systemsettings (whose sound settings are phonon’s settings, it turns out.) and saw that in there were no device listed, and pavucontrol was streaming to a “dummy output.”

I have also installed the packman and libdvdcss repositories and installed packages suggested by the multimedia guide to Leap 42.2. Some of them could not be installed, those were related to VLC, which I do not use. All of the audio ones I allowed it to switch over to the packman repository.

I have just removed the configurations from yast, and have not seen a difference in things like pavucontrol. I also feel it’s worth mentioning that alsa-info.sh is not on my machine, but alsamixer and such are.
It’s conceivable that I have a bad installation of ALSA, and it’s conceivable that I messed something up with Yast. It’s even conceivable (at least to my inexperienced linux mind) that some config in the home directory has messed it up from my previous install.

I just removed my pulse audio configs and restarted my machine in case the YAST settings needed that. My machine again sees my GPU’s sound chip, but that’s useless to me unless I can somehow pipe that through to an analogue port. I’m going to keep researching things and keep plugging away at this, but if anyone has ideas or suggestions, I’d be grateful.
Thanks!
–Henry Wilson
P.S. I’m sorry not to include readouts from audio debug scripts, but I don’t know which ones to use. Ask for one and I will provide it!

Hm. I can’t run

rcalsasound restart

as any user. Command not found. CNF doesn’t give me any ideas what I might be missing.

Well, I got my analogue audio working by following the advice in https://en.opensuse.org/SDB:Intel-HDA_sound_problems and restarting my computer instead of using rcalsasound. Now I have to go get Amarok working, and I’ll be golden. Ideas are still welcome, but I’m close to patching this up acceptably well.

Use the systemd command…

sudo systemctl restart alsasound.service

Thanks again, Deano. This works, and will be very useful, as I have just lost my analogue audio again after a restart. I never did figure out the amarok issue either.

Glad to have been of help.

I never did figure out the amarok issue either.

When you play a sound file (eg some music), open pavucontrol and observe the playback tab. Amarok should then show as a playback stream, and the sound level meter should be active. Anything unintentionally muted?

While you have media playing, you can examine the PulseAudio stream from a terminal with

pactl list sink-inputs

For example, while playing some sample music with Amarok I get…

dean@linux-kgxs:~> pactl list sink-inputs
Sink Input #40
        Driver: protocol-native.c
        Owner Module: 12
        Client: 54
        Sink: 0
        Sample Specification: float32le 2ch 44100Hz
        Channel Map: front-left,front-right
        Format: pcm, format.sample_format = "\"float32le\""  format.channels = "2"  format.rate = "44100"  format.channel_map = "\"front-left,front-right\""
        Corked: no
        Mute: no
        Volume: front-left: 52428 /  80% / -5.81 dB,   front-right: 52428 /  80% / -5.81 dB
                balance 0.00
        Buffer Latency: 109954 usec
        Sink Latency: 100172 usec
        Resample method: speex-float-1
        Properties:
                phonon.streamid = "{d6219859-1d76-4277-8326-24563a25c4e3}"
                media.role = "music"
                media.name = "'Art Of Nations (Amarok Theme)' by 'allMeadow & Rob Costlow'"
                application.name = "Amarok"
                native-protocol.peer = "UNIX socket client"
                native-protocol.version = "31"
                application.version = "2.8.0"
                application.icon_name = "amarok"
                application.process.id = "24767"
                application.process.user = "dean"
                application.process.host = "linux-kgxs"
                application.process.binary = "amarok"
                application.language = "en_GB.UTF-8"
                window.x11.display = ":0"
                application.process.machine_id = "a0848146a8854c519ce698d28901e824"
                application.process.session_id = "1"
                module-stream-restore.id = "sink-input-by-media-role:music"
                media.title = "Art Of Nations (Amarok Theme)"
                media.artist = "allMeadow & Rob Costlow"

Well, I’ve got my analogue chip working. Amarok, however, does not show up as an audio stream in pulse.

pactl list sink-inputs

will show things like youtube in chrome, but amarok does not appear in its list. I can hear youtube, cannot hear Amarok. This led me to believe there was something very wrong with my installation of Amarok, so I reinstalled it. However, once I launched it again, it threw an error telling me to go to the source directory, uninstall it, and recompile it with different flags. I installed it with Zypper, mind. I’m a little worried by this, but at the same time, you’ve helped me get closer to the problem. Thanks again, Deano! I’ll see what I can figure out and get back to the thread.

Yes, I agree the problem is with the application itself. I’ve got to ask why are you trying to compile it from source? Install it from the openSUSE OSS repo with

zypper in amarok

It should then just work (as it does for me).

I’m sorry, I wasn’t very clear.

zypper in amarok

is precisely what I did, and when I start it, it throws that error. Which is what I find odd.
Except after I wrote that last sentence, I tried it again, and it did launch, but still does not appear as an audio stream. And, when I say “configure phonon” it does not see the now-otherwise-working “built-in audio.”
I have installed Audacious, and it works, but it seems much less useful. Plus I’m curious what’s going on with Amarok. Could it be that there is a bad config file in my home partition that could be deleted?

Could it be that there is a bad config file in my home partition that could be deleted?

The Amarok config files are located in the ~/.kde4/share/apps/amarok/ and ~/kde4/share/config/ directories. You could delete these with

rm -rf ~/.kde4/share/apps/amarok/
rm -f ~/kde4/share/config/amarokrc

They will get recreated the next time Amarok is started.

And, when I say “configure phonon” it does not see the now-otherwise-working “built-in audio.”

That is strange. When you configure Phonon via Amaraok, check that the GStreamer backend is selected, and that under the ‘Audio Hardware Setup’ the ’ Hardware’ and ‘Device Configuration’ is configured appropriately.

And this is getting weirder all the time. I removed the config files the way you said, and it certainly worked, as it got rid of various config options (like what directories are and aren’t my “collection”), but in ‘Audio Hardware Setup’, the hardware dropdown only lists my video card, the audio portion of which I have disabled through systemsettings5. Due to my having disabled it, the ‘device config’ dropdown is unavailable. Under the ‘Backend’ tab, there is only one option listed – GStreamer. There does not seem to be any way of enabling or disabling it. I just did a google search with the keywords “amarok,” “built-in audio,” and something equating to “problem,” and unfortunately the first two results are unrelated, and the third is this very page. It would appear that this is not a common issue, making me think that (We’re entering the land of guesswork by a relatively inexperience user now) perhaps my recent reinstall of the root partition and not the home partition broke something that Amarok is relying on, perhaps in low-level sound settings on the user side. (exit guesswork land) I really don’t know enough to guess at what that might be. By the way, I’m glad to hear you find this strange, because I certainly do.

  1. Is this because you are trying to route sound through your video card?

Due to my having disabled it, the ‘device config’ dropdown is unavailable.

Ok, but I expect that given what you said above.

Under the ‘Backend’ tab, there is only one option listed – GStreamer. There does not seem to be any way of enabling or disabling it.

Ok, that is also as expected.

  1. Just to clarify that sound is still working with other apps?

  2. A good idea to run the also-info.sh diagnostic script as explained here
    SDB:Audio troubleshooting - openSUSE Wiki

It will upload the lengthy output to an online server and generate a URL for you to post here so that others can review it.

I am not trying to route sound through my video card. My sound is still working in other apps, but for some reason it takes about a minute after login for my onboard sound card to be listed in pavucontrol. As for alsa-info, I had to download it. Here is the link it generated: http://www.alsa-project.org/db/?f=9be526b7de5e9cc65930e3ab43a2dd669f836f52
Thank you for all of this time and help, Deano. I am at this point quite lost in the technicalities of all this sound architecture.

So I installed Clementine because it’s based on Amarok, just to see what it would do, and it went ahead and printed this when I tried to play media:


GStreamer could not create the element: audioresample. Please make sure that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)

Perhaps this could give insight to the problem?

Thanks for the generating the diagnostic info. I could find no obvious issues there but I am still trying to get a handle on this comment

but in ‘Audio Hardware Setup’, the hardware dropdown only lists my video card, the audio portion of which I have disabled through systemsettings5.

Amarok is still a KDE 4 app (built with Qt4) so systemsettings5 > Multimedia settings are not relevant here AFAIU.

The Phonon configuration from the app can launched using

kcmshell4 kcm_phonon

Right, that code brings up exactly the same graphical settings menu as Amarok’s “Configure Phonon” does. They both have the same behavior, but for some reason now *do *list the onboard audio, but when I set it, apply, leave the menu, and return, the setting has not “stuck.” (remained? taken effect? how do I word this? The setting has changed back to HDA NVidia.)

Additionally, when I test the PulseAudio Sound Server in the Device Preference tab of kcm_phonon, no sound is generated and the console it runs out of prints:

WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).

As far as my previous statement,

but in ‘Audio Hardware Setup’, the hardware dropdown only lists my video card, the audio portion of which I have disabled through systemsettings5.
I meant that amarok’s phonon settings did not list “built-in audio” as a device where it did list “HDA NVidia,” but it has now (for no reason I can discern) begun listing both devices, and allowing me to select whichever I would like. Apparently it switches back to HDA NVidia once I close the menu, or never switches to built-in audio in the first place.

Did you follow these steps in the Multimedia Guide?
https://forums.opensuse.org/forumdisplay.php/670-Multimedia

That’s because it is the same configuration utility

They both have the same behavior, but for some reason now *do *list the onboard audio, but when I set it, apply, leave the menu, and return, the setting has not “stuck.” (remained? taken effect? how do I word this? The setting has changed back to HDA NVidia.)

Additionally, when I test the PulseAudio Sound Server in the Device Preference tab of kcm_phonon, no sound is generated and the console it runs out of prints:

WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).

Hmmm… I don’t know the underlying cause of this might be? What phonon packages are listed via the following?

rpm -qa|grep phonon

As far as my previous statement, I meant that amarok’s phonon settings did not list “built-in audio” as a device where it did list “HDA NVidia,” but it has now (for no reason I can discern) begun listing both devices, and allowing me to select whichever I would like. Apparently it switches back to HDA NVidia once I close the menu, or never switches to built-in audio in the first place.

Can you set the desired configuration with pavucontrol?

Right.


wilson@linux:~> rpm -qa|grep phonon
libphonon4-4.8.1-3.5.x86_64
phonon4qt5-backend-gstreamer-4.9.0-1.2.x86_64
libphonon4qt5-4.9.0-2.6.x86_64
phonon-backend-gstreamer-4.8.2-4.1.x86_64

As for the multimedia guide, I followed the instructions as closely as I could. There were problems with some of the packages. Some of them could not be installed, and some of them I switched over to packman like it suggested. Let me get a list of the packages that could not be installed.

I just ran the install command again, and here is the output:


Problem: ffmpeg-3.2-3.2.20170210.d4b731e271-1.2.x86_64 conflicts with ffmpeg < 3.2.20170210.d4b731e271-1.2 provided by ffmpeg-3.2.4-6.5.1.x86_64
 Solution 1: Following actions will be done:
  deinstallation of ffmpeg-3.2-3.2.20170210.d4b731e271-1.2.x86_64
  downgrade of libavutil55-3.2.20170210.d4b731e271-1.2.x86_64 to libavutil55-3.2.4-6.5.1.x86_64
  downgrade of libpostproc54-3.2.20170210.d4b731e271-1.2.x86_64 to libpostproc54-3.2.4-6.5.1.x86_64
  downgrade of libavcodec57-3.2.20170210.d4b731e271-1.2.x86_64 to libavcodec57-3.2.4-6.5.1.x86_64
  downgrade of libswresample2-3.2.20170210.d4b731e271-1.2.x86_64 to libswresample2-3.2.4-6.5.1.x86_64
  downgrade of libswscale4-3.2.20170210.d4b731e271-1.2.x86_64 to libswscale4-3.2.4-6.5.1.x86_64
  downgrade of libavfilter6-3.2.20170210.d4b731e271-1.2.x86_64 to libavfilter6-3.2.4-6.5.1.x86_64
  downgrade of libavresample3-3.2.20170210.d4b731e271-1.2.x86_64 to libavresample3-3.2.4-6.5.1.x86_64
  downgrade of libavdevice57-3.2.20170210.d4b731e271-1.2.x86_64 to libavdevice57-3.2.4-6.5.1.x86_64
  downgrade of libavformat57-3.2.20170210.d4b731e271-1.2.x86_64 to libavformat57-3.2.4-6.5.1.x86_64
 Solution 2: do not install ffmpeg-3.2.4-6.5.1.x86_64


Choose from above solutions by number or cancel [1/2/c] (c): 1
Resolving dependencies...
Resolving package dependencies...


The following 13 NEW packages are going to be installed:
  ffmpeg libcrystalhd3 libdvbpsi10 libfreerdp2 libopencv-qt56_3 libSDL_image-1_2-0 libvlc6 libvlccore9 libvncclient0
  vlc-beta vlc-beta-codecs vlc-beta-noX vlc-beta-qt


The following package is going to be REMOVED:
  ffmpeg-3.2


The following 9 packages are going to be downgraded:
  libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libpostproc54 libswresample2
  libswscale4


9 packages to downgrade, 13 new, 1 to remove.
Overall download size: 17.5 MiB. Already cached: 0 B. After the operation, additional 34.6 MiB will be used.

Should I continue with this? It appears to be an MPEG library. The first time I ran the install command there were about five packages (if I parsed their names correctly they were video codecs and such) that could not be installed. I’m not sure what’s changed since then, the only new repositories I’ve added have been for specific pieces of software I use, and contain AFAIU (thanks for teaching me that!) only those specific pieces of software.

As for the multimedia guide, I followed the instructions as closely as I could. There were problems with some of the packages. Some of them could not be installed, and some of them I switched over to packman like it suggested. Let me get a list of the packages that could not be installed.

I just ran the install command again, and here is the output:

Problem: ffmpeg-3.2-3.2.20170210.d4b731e271-1.2.x86_64 conflicts with ffmpeg < 3.2.20170210.d4b731e271-1.2 provided by ffmpeg-3.2.4-6.5.1.x86_64
Solution 1: Following actions will be done:
deinstallation of ffmpeg-3.2-3.2.20170210.d4b731e271-1.2.x86_64
downgrade of libavutil55-3.2.20170210.d4b731e271-1.2.x86_64 to libavutil55-3.2.4-6.5.1.x86_64
downgrade of libpostproc54-3.2.20170210.d4b731e271-1.2.x86_64 to libpostproc54-3.2.4-6.5.1.x86_64
downgrade of libavcodec57-3.2.20170210.d4b731e271-1.2.x86_64 to libavcodec57-3.2.4-6.5.1.x86_64
downgrade of libswresample2-3.2.20170210.d4b731e271-1.2.x86_64 to libswresample2-3.2.4-6.5.1.x86_64
downgrade of libswscale4-3.2.20170210.d4b731e271-1.2.x86_64 to libswscale4-3.2.4-6.5.1.x86_64
downgrade of libavfilter6-3.2.20170210.d4b731e271-1.2.x86_64 to libavfilter6-3.2.4-6.5.1.x86_64
downgrade of libavresample3-3.2.20170210.d4b731e271-1.2.x86_64 to libavresample3-3.2.4-6.5.1.x86_64
downgrade of libavdevice57-3.2.20170210.d4b731e271-1.2.x86_64 to libavdevice57-3.2.4-6.5.1.x86_64
downgrade of libavformat57-3.2.20170210.d4b731e271-1.2.x86_64 to libavformat57-3.2.4-6.5.1.x86_64
Solution 2: do not install ffmpeg-3.2.4-6.5.1.x86_64

Choose from above solutions by number or cancel [1/2/c] (c): 1
Resolving dependencies…
Resolving package dependencies…

The following 13 NEW packages are going to be installed:
ffmpeg libcrystalhd3 libdvbpsi10 libfreerdp2 libopencv-qt56_3 libSDL_image-1_2-0 libvlc6 libvlccore9 libvncclient0
vlc-beta vlc-beta-codecs vlc-beta-noX vlc-beta-qt

The following package is going to be REMOVED:
ffmpeg-3.2

The following 9 packages are going to be downgraded:
libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libpostproc54 libswresample2
libswscale4

9 packages to downgrade, 13 new, 1 to remove.
Overall download size: 17.5 MiB. Already cached: 0 B. After the operation, additional 34.6 MiB will be used.

Should I continue with this?

Yes, I would.