Analog Video recording application

Greetings All,

Recently, I came across a couple of VHS tapes in my Mother’s house.
These are family recording that I would like to preserve for future generations.
Having also come across a VHS deck to go with these, I figure it should be
an easy task to capture the tapes to a .avi or .mp4. Alas, this was NOT the case.

I have an Analog Video/Audio to USB adapter with the Syntek STK1160 chipset.
The device is recognized and connected to /dev/video0. pavucontrol shows
the device in “Input Devices”.

I looked at a number of different Video Apps (OpenShot, Pitivi, Kino), but
they don’t appear to have the ability to capture from this device.

VLC does provide the ability to capture the video output. However,
I have been unable to figure out how to get the audio recorded along with it.
I can get a decent video capture from VLC, but no sound is ever included.

Can anyone make a suggestion for decent application for capturing a VHS recording,
or for some magic to implement to get VLC to record the sound?

Running SUSE level 42.2 on an AMD 8 core cpu, and ASUS motherboard.

Thanx in advance.

Richard Rosa

I’ve never tried this. So anything I say will be speculative. If some one with real experience chimes in, then please give their views precedence over mine.

With vlc, are you using pulse audio ?

If so, it should be possible with pulse audio, to redirect any audio that vlc can output to speakers, instead to a recording device. If it were me I would focus my efforts on using this feature of pulse audio.

I recall some years back I recorded output from Skype (see the 07-Jan-2012 20:45 post, and following one on this thread) ;

I would think it possible to direct pulse to record the audio, if not embedded in the video you are recording, then possibly as a separate .wav or .mp3. Once you have a separate audio track, there are many ways to then insert the audio into the video track.

I appear to be using P.A. with VLC for playback only. When running VLC, pavucontrol shows VLC as a PLAYBACK device, but there is no selection in the RECORDING panel.
It looks like VLC wants ALSA input only. I can select hw:0,0 (which fails to connect) hw:0,2 (which I believe is my MB audio) and hw:0,3 which SHOULD be the
USB adapter’s audio. None of these selections result in any sound in the recording.

I get a bit confused with these sound systems, and have no idea how to translate PA <->ALSA so VLC can get some audio input.

Yes, I CAN make a video only with VLC, and a separate audio recording elsewhere, but the thought of spending a lot of time trying to sync up
video with audio isn’t thrilling. There has GOT to be an easier way…


I’m interested to read this thread, as I have a similar need to capture some old analog video. I haven’t yet purchased a capture device though. I would have assumed that pavucontrol could be used to set the default input source, and that VLC would use that to record from, but I don’t have direct experience to draw from. Anyway, if you decide that you want to disable PulseAudio for any reason, the easiest way to do that with openSUSE is to run

sudo setup-pulseaudio --disable

It can be re-enabled again using

sudo setup-pulseaudio --enable

A VLC “How To” for others who may come searching…

This can be at times incredibly easy to do , or in other cases difficult. It all (IMHO) depends on whether the video and audio are at the same rate. If at different rates it is painful to have to change the ‘frequency’ for them to start/stop at same location.

If one knows the right commands, its (IMHO) not so difficult to change the start time, such that the audio starts at the right place in the video. However as noted, if the ‘rate’ is different, and if the end is out of sync, even thou the beginning is in sync, then that creates far to much work to try and fix.

The link suggested by deano_ferrari suggests one can specify the hardware device name (hw:0,0 for example) and audio should be recorded with the video in vlc. Do you need help determining how to refer to your hardware device name? (ie hw:0,0, or hw:1,0 … or other) ?

That was the magic! Removing pulsaudio allowed VLC to access the sound input. I now have the video & sound from these tapes safely ensconced in the computer.

Thank you very much!


Nice to read of your success with this. Don’t forget to re-enable PA for functioning desktop sound again.

Its good to read of the solution. Possibly worth a ‘how-to’ or ‘blog’ on the experience.

I’m curious to hear about how the “analog Video/Audio to USB adapter with the Syntek STK1160 chipset” works now that audio/video can be recorded with VLC. I noted this Easycap entry under the LinuxTVWiki: where according to that link such a device is sold in different varieties (models) and even under different names like: EzCap, LogiLink, Mumbi, Weltbild, and some more.

… oh, I do agree with this.

I have already bookmarked this link for future reference, as I have many tapes and a device that is supposed to connect the tape player to the PC for just that purpose.

… if and when I ever get the time.:stuck_out_tongue: