An application is replicating itself in mate desktop

Sir recently I have bought Toshiba satellite laptop and I have installed opensuse 13.1 on it.

When I launch the mate desktop I am getting message as “starting caja” in status bar continuously.

I have installed the same OS on another system ie., desktop and found none of the above.

kindly analyze the issue and suggest the solution.

First of all: How exactly did you install MATE?
It is not included in openSUSE 13.1.

Caja is the file manager. It is starting at login (for the desktop funtionality I suppose), but seems to crash and therefore restarts continuously.
I have seen the same when I tried out MATE some months ago, but do not remember what I did to solve it or if I ever solved it at all.

Uninstalling the package “caja” should help in any case, but then you won’t have the file manager any more of course.

Here’s another workaround you could try: http://forums.opensuse.org/showthread.php/497962-How-to-Install-MATE-1-8-complete-desktop-environment-in-OpenSUSE-13-1?p=2643129#post2643129 (and the following one)
I.e. edit the file /usr/share/applications/caja.desktop and change the “Exec=” line to:

Exec=caja --sync

Deleting the directories ~/.config and ~/.cache might be necessary as well.

I haven’t tried this myself though.

The issue has been resolved by removing amd catalyst software and installing ati driver package from http://en.opensuse.org/SDB:AMD_fglrx after that editing mate.desktop file as you specified.