Amorak does not work

Amorak does not work. The application opens properly, I am able to load the playlists, run the configuration etc etc. BUT clicking on the start button has no effect. The sound card is on the motherboard and Yast test of sound is OK. Pulse audio set up is also OK.

Tried uninstalling Amorak and then reinstalling but to no avail.

I have 42.1 and 42.2 also on the same PC and Amorak is working fine there.

Help is requested.

Find configuration files between hidden files in your / home and delete them.
But I get a doubt, you tried with another player to play them …, I would not want you only missing the codecs

As with all Multimedia problems (and why is this not in the Multimedia sub-forum, where you will find the sticky threads at the beginning that provide a lot of information), the first question is: “Did you do the vendor switch to Packman?”

I thought it is an installation error. The app was installed during installation of OS itself and did not work. I had later added the Packman repo before uninstalling and reinstalling Amorak. I will recheck re change to Packman and also the multimedia sub forum.


Adding the Packman repo (as with adding any repo) only makes it available for installing packages from it. There is no automagic installing of packages from an newly added repo.

To do the Vendor switch:
YaST > Software Management, then from the View menu choose Repositories. Then in the list of repos, select Packman. At right, above the list of Packages there is a line saying something like: Switch system packages to … Click on the underlined part and continue low-right.

FYI the program is called Amarok ( a howling wolf from native american myths/legends ), not Amorak. It should play mp3 files without Packman since the mp3 patents have ended and we have the Fluendo codec installed by default.

amarok uses phonon as a multimedia framework the default phonon config on LEAP 42.3 uses gstreamer as a backend and as mp3 patents have lapsed (even before opensuse provided mp3 support thru fluendo’s gstreamer mp3 codec) so amarok should play vorbis opus flac and mp3’s out of the box
packman is needed only for aac support (and few other patented audio formats like amr)
a full vendor change to packman is a must but you can also remove your gstreamer cache

rm -r ~/.cache/gstreamer-1.0

if you do a vendor change to packman and install vlc-codecs you can use libvlc for playback instad of gstreamer by installing phonon-backend-vlc and configuring it in plasma options

zypper in vlc-codecs phonon-backend-vlc

Thanks everyone. I checked out in multimedia sub-forum and the sticky post solved my problem.

I am really wondering why the “out of the box” Amarok (I have corrected the spelling) failed to run mp3 files. What does the application play as installed initially? If for legal reasons a working application cannot be distributed by opensuse why have it in the main set. A simple advisory to install separately from Packman repo should suffice.

Because Amarok can do moremthen just play MP3 (and other restricted) files.

well after initial install I add and do a full vendor change to packman but afaik amarok from OSS should support mp3’s (even when it was patented opensuse had a deal with fluendo for a licensed mp3 decoder)
the gstreamer-plugins-ugly package should contain the mp3 codec but gstreamer-fluendo-mp3 also houses a working mp3 codec it’s quite possible gstreamer-plugins-ugly was build without mp3 support and amarok (and other gstreamer based players are ignoring the fluendo codec)
taking a quick look at the package
there is a liba52 (ac3) patch there as it’s patent also ended last year but I see no mp3 patch maybe a bug report is needed

I’m thinking this is the cause of the issue

Wed Jun 21 13:28:01 UTC 2017 -

- Move mpg123 module from orig_addon to the main package, since we
  can now ship mpg123.


afaik was removed from gstreamer-plugins-ugly and it’s not in the main gstreamer package
or the gstreamer-plugins-base package (the one housing the patent free codecs like vorbis and opus)
packman still packages inside it’s gstreamer-plugins-ugly rpm I think this is a packaging error

It has been moved from gstreamer-plugins-ugly-orig-addons (only available in Packman) to gstreamer-plugins-ugly (available in the standard OSS repo).

But the problem is that gstreamer-plugins-ugly is not installed by default by mistake (except if you do a GNOME installation), and gstreamer-fluendo-mp3 (still available) is not installed by default either any more because gstreamer-plugins-ugly does come with mp3 support now.

Installing one or the other manually (or following one of the many "multimedia guides) should “fix” it.

That’s even mentioned in the release notes btw: it has only been noticed after the 42.3 freeze, see