amilo pi2550 acpi problem

Hallo,

I have just installed 11.3 on my laptop. With the default acpi=on the laptop falls asleep very fast, after approx 10 sec. When I touche any key or the mouse, the current program continues. This is very boring! Every other feature works quite fine. Booting with acpi=off and the effect disappears. As a drawback no powermanagement or shutdown is possible. The pm-utility gives the message: No battery present.

Is there any parameter acpi=??? between or a bugfix?

Many thanks in advance!

PS: I am merely a user and not a very clever LINUX specialist.

With the default acpi=on the laptop falls asleep very fast, after approx 10 sec.

When you say this, do you mean it pauses or does the screen blank? It makes a difference. I also suggest listing the desktop type and version and if you know the chipset for this laptop offhand.

Thank You,

Technical features:
Kernel: Linux 2.6.34.7-0.4-desktop x86_64
Distribution: openSUSE 11.3 (x86_64)
KDE: 4.4.4 (KDE 4.4.4) “release 3”
CPU: Intel(R) Core™2 Duo CPU T8300 @ 2.40GHz
Ram: 4 GiB
Motherboard Chipset Intel Crestline-PM PM965

Hello,
thanks for the reply.
The Laptop acts like this:

  • the greeting sound is in an endless loop, playing only 3 notes. The same effects with any other audio player. When I hit any key, the tune continues.
  • every program freezes until I hit a key. Then it goes on without failure.
  • any video player stops at a certain picture, the sound is in a loop and the dvd-player stops. Also this application resumes without any problems.
    Regards Artur

So I really don’t know anything about this laptop, but I normally would try one of two approaches. One might be to try a new kernel version, like version 2.6.35 (I would not go for 2.6.36 right now). You would need to run openSUSE with acpi=off, to make the install. You need to install the three patterns (View button top Left to Patterns) in YaST / Software Management for Base, Kernel & C/C++ development. Then load the new kernel you compiled with acpi=on, or just remove the command all together for the default.

S.A.K.C - SuSE Automated Kernel Compiler

If this does not work or you don’t feel like trying to compile a new kernel, I might consider dropping down to openSUSE 11.2. You can find the ISO for this version at the following link.

ftp://ftp.klid.dk/opensuse/distribution/11.2/iso/

For instance, I have found that my 1.5 year old Dell Laptop seems to work better using openSUSE 11.2. In any event, it is also worth a try.

Thank You,

As I know that laptop has problems with all tickless Kernels (> 2.6.18).

You should probably update BIOS ( Treiber & Downloads )
or use kernel boot options like:
nohz=off
nolapic_timer