America's army does not exit properly

I have iunstalled AA2.5 and found that after exiting it still resides in memory and blocks any sound in other applications until terminated via system monitor.

There was no such behavior under Ubuntu. So my question is how to make it exit normally?

Even after a reboot?

Yes. Reboot does not help.

Ansus wrote:
> Yes. Reboot does not help.

sounds like a trojan horse/root kit to me…

WAIT! aren’t you the user who insisted on “How to diasable filesystem
checks on boot?” and one day discovered “Pause and strange output when
entering administrator console”…

did you ever repair those problems? (or do a fresh install to clean
out the bones?)

having been rooted and/or uninstalled games remaining in memory over a
hardware boot is no surprise…

good luck…


palladium
wait: “America’s army does not exit properly” is this a political
commentary? (if so, you missed April Fools Day by eight!)

having been rooted and/or uninstalled games remaining in memory over a
hardware boot is no surprise…

What a stupid idea that a process can remain in memory after boot! Did you ever learn computer basics?

Ansus wrote:
> What a stupid idea that a process can remain in memory after boot! Did
> you ever learn computer basics?

you said it, not me:

post 1: “exiting it still resides in memory and blocks any sound”
post 2: “Even after a reboot?”
post 3: “Yes. Reboot does not help.”

so, like ALL good root kits it auto-loads itself into memory with
every boot!!

read up on root kits, and then you may ask with a sneer:
“Did you ever learn computer basics?”


palladium

you said it, not me:

I did not say that. Turn off your fantasy.

P.S. Need help from people who know how to help.

Come on, people, there’s no need for tone like this.

@Ansus: you answered the question ‘Even after reboot’ which referred to AA remaining in memory with “yes”. Let’s get back to the start, and try to solve the problem. I don’t know if it helps, but my son says he solved “something” with sound and AA by making himself member of the ‘audio’ group.
If you kill the app, does sound work again? If so, does sound still not work after a reboot? Which app is it exactly you’re killing?

Yes. After killing the app sound resumes.

Which app is it exactly you’re killing?

File armyops-bin which takes 300MB of memory and is in state futex_wait_queue_me as reported by system monitor.

If to run the game under root, it exits well…

Ansus wrote:
> If to run the game under root, it exits well…

which takes us back to the problems you described in
http://tinyurl.com/ya8p7u6 and http://tinyurl.com/y8smaqo which i
can’t see how any were completely resolved…

i can only guess that to repair those now will require a backup of all
data and then a fresh format (including /home) and a by-the-book install…

i’d guess then immediately after the install there would be none of
the current symptoms pointing to damaged permissions, and no more long
delays for disk checking on every 20 boots or so (unless there is a
hardware problem…which we never had the chance to investigate)

and then after restoring backed up data (data only–do not restore any
configuration or hidden files/directories) it would continue on
smoothly until incorrect admin procedures/actions (say, during
installing of software or ‘customizing’ the system) re-damaged the
system…

but, on the other hand you need “Need help from people who know how to
help.”


palladium

Please ignore this troll.

Apparently you can not see that “palladium” recognizes your system has the normal symptoms associated with damaged permissions. Which was also noted by hcvv in Pause and strange output when entering administrator console - Page 5 - openSUSE Forums

But, instead of listening to those trying to help you, you ignore or insult.

Good luck with finding a solution.

  • First, that was completely irrelated issue

  • Second, that issue has been already solved in that thread

  • Third I have alrerady reinstalled the system after that

  • Fourth not only me experience similar problems with America’s Army, for example here people explain just the same problem and anybody can verify my words by installyng this game themselves.

  • Fifth it seems palladium tries to marginalize any my question by linking it to some problem in the past and claiming my system is broken.

  • Sixth I never changed any permissions in my system.

To Ansus, DenverD/palladium. Please cool it. Exchange between you deleted, lets get harmonious.

Other people reporting the same problem:

Google Translate

Similar problems in Ubuntu with other applications:

[ubuntu] Opera process does not end - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1366424)

In my case armyops-bin also tagged with futex_wait_queue_me

https://bugs.launchpad.net/ubuntu/+bug/480497

Hi
I see you’ve left comments on numerous ubuntu bugs, have you thought
about raising it as a bug on bugzilla for openSUSE? I suggest you do
that via here; http://en.opensuse.org/Bugs


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
up 11 days 15:58, 4 users, load average: 1.58, 0.50, 0.33
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53