AMD vs OpenSuse Version - Need Proprietary drivers

Hi every one;

For some time, I’ve been seeing several posts about the incompatibility of AMD’s proprietary drivers with newer linux versions.
I really need to use proprietary drivers as I work with image editing and I’m abandoning the adobe platform.
What version can I install with support for my AMD Radeon R7 260 card using proprietary drivers?

Thank you for your help.

http://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver–Release-Notes.aspx

^ The R7 260 is on the AMDGPU / PRO driver compatibility list.

However installing and using that driver is not easy or straightforward yet

https://forums.opensuse.org/showthread.php/523503-Plasma-OpenGL-2-error-when-installing-RX-460-Propietary-driver

Hi.
The hardwork its not a problem, but, the new “pro” version of driver still having a lot of problems.

So, I need a stable version (old with fglx support).
What you recomend ?

Fglrx has been dropped no longer supported. No going back sorry. The AMDGPU default driver is supposedly fairly good. Does it do what you need I don’t know. I run NVIDIA cards.

Unfortunatelly you didn´t told, which version of Opensuse you have.
I´m on Leap 42.2 with Kernel 4.4.xx and the Amdgpupro 16.50-xx
is running well here with my RX 480.
What problems you mean with the driver?
I don´t use special programs like image editing.

Hi
Which is in the newer range, which seem to be better supported by the driver. A number of users have reported issues with the ‘supported cards’, but that’s something that needs to be taken up direct with the proprietary driver developers…

I have my Mullins (Sea Island GCN 1.1) card running with the amdgpu driver (needs later xf86-video-amdgpu and a kmp for 42.2) which is in the same group as the OP, it doesn’t work with amdgpu-pro (not on list). It works in tumbleweed though, since kernel/xf86-video amdgpu issues have been sorted out.

I wanted to point out 2 things.

  • In my case, the 16.60-xx driver is faulty. It looks like a script error in building dkms.
    So other users, trying different kernels, because they have problems with installation,
    simply uses the “wrong” driver instead of the 16.50-xx.
  • With Leap 42.2 and Kernel 4.4.x the 16.50-xx should work out of the box.

The problem with your Mullins maybe is, its not in the list of supported products.

Hi
Which is why you need to follow up direct with the driver developers, AMD/ATI…

Don’t get me wrong, I’m happy with the amdgpu driver (and later Xorg driver 1.2.x), it works fine (which is what is in the pro package anyway).

I tried because my card (but others in Sea Island group are listed), one could say that openSUSE is not in the list of supported operating systems…but it still works :wink:

I don’t like the idea of having to downgrade/install a whole bunch of rpms to run the driver, soon as it’s installed and you have graphics issues if you want to raise an openSUSE bug, you may need to uninstall the driver, duplicate the bug, then report…

…I’m happy with the amdgpu driver…

As I´m happy with the 16.50-xx amdgpupro driver. :wink: