AMD Vega 8 drivers issues

So ive got an AMD Ryzen 5 mobile with Vega 8 graphics. Thing is im having issues in different apps, but mainly I think my apu isnt recognized by the drivers. I tried to follow but, when I run

xrandr --listproviders

i get

Invalid MIT-MAGIC-COOKIE-1 keyProviders: number : 1
Provider 0: id: 0x55; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 4; outputs: 2; associated providers: 0; name: Unknown AMD Radeon GPU @ pci:0000:05:00.0
    output HDMI-A-0
    output eDP


Im guessing this affects programs like Radeon Profile, which doesnt show any kind of stats. I ran

sudo zypper install xf86-video-amdgpu kernel-firmware

for installing the AMDGPU drivers and all seemed up to date. Do I need to install any of the other drivers to get my gpu recognized, is this normal?

Can you install inxi and run;

inxi -SGxx

I get

evice-1: AMD Picasso vendor: Acer Incorporated ALI driver: amdgpu 
  v: kernel bus ID: 05:00.0 chip ID: 1002:15d8 
  Device-2: Quanta type: USB driver: uvcvideo bus ID: 1-1:2 
  chip ID: 0408:a061 
  Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz s-dpi: 96 
  renderer: AMD RAVEN (DRM 3.33.0 5.3.18-lp152.33-preempt LLVM 9.0.1) 
  v: 4.5 Mesa 19.3.4 direct render: Yes 

If you remove the xf86-video-ati package and lock so it doesn’t install, does that help.

Still getting same result after removing xf86ati

Can you post the new inxi output?

inxi -SGxx

Have you added any amdgpu options to boot, eg andgpu.ppfeaturemask? This needs to be set for the likes of Radeon Feature, can you also post the output from;

systool -vm amdgpu

Just the “Parameters” section.

Try to update X11 and Mesa 3D.

Perform search for X11-XOrg repo:

zypper lr

If you haven’t it then add it:

sudo zypper ar X11XOrg

Then perform full repository vendor change:

sudo zypper dup --from X11XOrg --allow-vendor-change