AMD RX550 - wich driver? Fan alwasy at 100%

So I’ve got myself a AMD Radeon RX550 made by PowerColor in order to get 4k@60Hz on my brand new TV wich I also use as my secondary display. I previously used and older FullHD tv and the onboard Radeon R7 integrated GPU was enough but not for 4K. I have a desktop with a AMD A10 7700K with Kaveri Radeon R7 GPU.

I installed the RX550, disabled the onboard iGPU and my Leap 15.1 booted just fine for the first time. After a reboot it crashed, had to do a cold reboot and for some reason it worked again. I checked and already had amdgpu installed but I tried the latest amdgpu_pro package directly from AMD’s website. I beliveve it’s installed but not in use or I’m missing something.

Here is my lspci -nnk |egrep -A3 “VGA|Display|3D”
linux-gnix:/home/roberto # lspci -nnk |egrep -A3 “VGA|Display|3D”

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 Graphics] [1002:1313]
        Subsystem: ASRock Incorporation Device [1849:1313]
        Kernel driver in use: radeon
        Kernel modules: radeon, amdgpu
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 550 640SP / RX 560/560X] [1002:67ff] (rev ff)
        Subsystem: Tul Corporation / PowerColor Device [148c:2390]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu
linux-gnix:/home/roberto # lspci -nnk |egrep -A3 "VGA|Display|3D"

I don’t think that’s ok. Should I have both the Radeon R7 iGPU abd the RX550 listed?

Is there any package that can provide some ways to control the GPU’s fan? It’s constantly at 100% and it drives me crazy.

Can you explicitly disable the Kaveri in the BIOS? Seeing the lspci output as you presented it makes me think it’s ready and waiting and confusing something. What does

inxi -Ga
xrandr --listproviders

in an Xterm or Konsole report?

I don’t think here is the best place to expect the right help when using the proprietary amdgpu driver. Last I remember it lost support several releases back, so you shouldn’t need it.


**linux-gnix:/home/roberto #** inxi -Ga
**Graphics:  Device-1:** Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics] **vendor:** ASRock **driver:** radeon **v:** kernel  
           **bus ID:** 00:01.0 **chip ID:** 1002:1313  
           **Device-2:** Advanced Micro Devices [AMD/ATI] Baffin [Radeon RX 550 640SP / RX 560/560X] **vendor:** Tul **driver:** amdgpu  
           **v:** kernel **bus ID:** 01:00.0 **chip ID:** 1002:67ff  
           **Display:** x11 **server:** X.Org 1.20.3 **compositor:** kwin_x11 **driver:** ati,radeon **unloaded:** amdgpu,fbdev,modesetting,vesa  
           **display ID:** :0 **screens:** 1  
           **Screen-1:** 0 **s-res:** 5760x2160 **s-dpi:** 96 **s-size:** 1520x570mm (59.8x22.4") **s-diag:** 1623mm (63.9")  
           **Monitor-1:** HDMI-A-1 **res:** 3840x2160 **dpi:** 68 **size:** 1440x810mm (56.7x31.9") **diag:** 1652mm (65")  
           **Monitor-2:** DVI-D-1 **res:** 1920x1080 **hz:** 60 **dpi:** 102 **size:** 477x268mm (18.8x10.6") **diag:** 547mm (21.5")  
           **OpenGL:****renderer:** Radeon RX 550 Series **v:** 4.5.14756 Core Profile Context **compat-v:** 4.6.14756 **direct render:** Yes 


linux-gnix:/home/roberto # xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x7e; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 5; outputs: 3; associated providers: 0; name: Radeon RX 550 Series @ pci:0000:01:00.0
    output DisplayPort-0
    output HDMI-A-1
    output DVI-D-1
Provider 1: id: 0x46; cap: 0x0 (); crtcs: 4; outputs: 3; associated providers: 0; name: KAVERI @ pci:0000:00:01.0
    output 0x43
    output 0x44
    output 0x45

I believe it uses both GPUs and or something is really broken. Today I went and resumed the desktop from sleep and all that was shown on the first display were artefacts, not usable. I had to do a forced reboot and initially it failed with “ACPI BIOS error… and 2 more ACPI Errors…Method parse/execution failed”, see the attached screenshot. I did another forced reboot and it started up just fine.
Should I do a clean install? Myabe remove amdgpu-pro and amdgpu then reinstall them or?


I suspect a fix wouldn’t be any easier by installing fresh than by just finding the problem. I suspect the presence of Kaveri among providers could be a problem, as well as a loaded radeon kernel driver. First thing I’d do is purge the proprietary software. Then, assuming you have both displays connected to the RX550, and assuming there’s nothing in the BIOS that enables to explicitly disable the Kaveri and has not already been selected, I’d try blacklisting radeon, and uninstalling xorg-x11-driver-video and xf86-video-ati, then seeing if any improvement results. If not, next would be to force use of the upstream default DDX driver, modesetting. To do that either uninstall xf86-video-amdgpu, or use /X11/xorg.con* to explicitly specify modesetting as the device.

What’s the model of your ASRock? I might have the same one here, with Kaveri, but with an A8-8650B.

You are trying to use Kaveri = GCN2 with open radeon driver and RX 550 = GCN4 with closed amdgpu-pro driver together.

Disable integrated video in BIOS.
Or force Linux kernel to use amdgpu driver for Kaveri.