AMD Drivers


I have a fresh install of openSUSE 12.1 with amd 11.12 drivers for my HD5650 graphics card.
The problem is that for some reason I cannot run the desktop effects and kwin crashes when I try to.

I have no idea what logs to post to make this more helpful but will post if requested.

Yeah me too i have a Sapphire Radeon HD3850 and the fglrx drivers dont seem to work.
I 've been working on it literally for two days full and i give up.

I have installed three times OpenSuse 12.1 and the result is the same. After the installation i get all
the desktop effects with extreme lags, so i try to install proprietary drivers using this guide SDB:ATI drivers - openSUSE but it fails and the PC starts without effects.

I 've tried the make rpm script or the atiupgrade tool but still no effect.

Even the radeonhd drivers don’t work. Please help someone, i really need to run this system,
i had no problems with 11.4 but 12.1 is killing me and i hate to switch to another distro cause opensuse
is the best for me.

I’m new to all this but this is how I got mine installed. I think it’s running OK anyway. Card is a HD5850. openSUSE 12.1 KDE.

At the bootscreen:


I use -nomodeset but have seen here to use nomodeset.

Once booted open a root terminal:


Then go to the website here. I used the one click install.

That was it. Don’t know if that is what you are after.

Are you using Gnome3? If so, fglrx doesn’t work. No matter how you install it.

The latest atipugrade should create the missing symlinks, that prevent hardware acceleration from working. But if you are under Gnome3, it’s not going to help. fglrx is unusable with Gnome3 in most cases.

I use KDE. Is there a more standard method for this to work? I have already used the mkinitrd beforehand as i have followed the instructions on that wiki site i posted before. Please i m in desperate need tomake this system work. Any help appreciated :slight_smile:

IMO, atiupgrade is the easiest.

Whoever told you to run mkinitrd should take a look at the postinstall script of the fglrx rpm package:

**# rpm -q --scripts fglrx64_xpic_SUSE114-8.920-1 | grep -C 3 mkinitrd**

if grep -q '^NO_KMS_IN_INITRD=\"no\"' /etc/sysconfig/kernel; then
    echo "Disable KMS to prevent driver issue:"
    sed -i 's/^NO_KMS_IN_INITRD.*/NO_KMS_IN_INITRD="yes"/g' /etc/sysconfig/kernel
if grep -q '^KMS_IN_INITRD=\"yes\"' /etc/sysconfig/kernel; then
    echo "Disable KMS to prevent driver issue:"
    sed -i 's/^KMS_IN_INITRD.*/KMS_IN_INITRD="no"/g' /etc/sysconfig/kernel
   ** mkinitrd**
AMDCONFIG_BIN="`which aticonfig 2>/dev/null`"
if  -n "${AMDCONFIG_BIN}" -a -x "${AMDCONFIG_BIN}" ]; then

It means that the installation takes care of that.

Ok then i wil reformat the PC because i messed up using the kernel from the j.eng repository and i will use the
atiupgrade script from the beginning. Thanks for the reply i will keep you posted!

I’ll check that out thanks.

Hi i run the atiupgrade script after i installed openSUSE and the fglrx drivers seem to work pretty good, thank you please_try_again!
However i get some kind of strange artifacts that slow down sometimes the desktop even if KDE runs quite smoothly, is there a way to fix that?

Using Hipster_Doofus’s method I got it all up and running. Thank you very much.

Gikoskos try running sudo aticonfig --initial once you have installed fglrx.

I am having a problem with my RAT 5 mouse though. I used to be able to (in 11.4) add:

Section “InputClass”
Identifier “Mouse Remap”
MatchProduct “Saitek Cyborg R.A.T.5 Mouse”
MatchDevicePath “/dev/input/event*”
Option “ButtonMapping” “1 2 3 4 5 6 7 2 9 10 11 12 0 0 0”

To the end of xorg.conf but now when I try, kwin crashes after a while.

I shall pick myself up off the floor. First piece of advice about any sort of linux for me & it worked. :):slight_smile: :smiley:

Kylup i ran aticonfig --initial and its a lot smoothier but some of the glitches (e.g. when i open a menu or when i right click) are still here.
I dont know what to do because on 11.4 it had the same effects without a problem. Anyways thanks:)

Hi i have another question, how can i limit the lags from the flash player.
I fullscreen and its like the PC froze. Please help:’(

The artifacts are normal … or more precisely they are NOT, but caused by a bug in the driver, not related with atiupgrade or another way to install the driver. This is neither your fault … nor mine. However I don’t know what’s behind this in KDE.

Don’t mix methods! If you used atiupgrade, you didn’t need aticonfig --initial!
Look at the last lines of the atiupgrade script (using the “tail” command for example):

**$  tail -4 /usr/bin/atiupgrade**

# otherwise generate a basic /etc/X11/xorg.conf
/usr/bin/aticonfig --initial    

You should enable - more exactly un-disable - compositing for full screen windows in KDE. See this post and my answer:

Sorry, didnt know about that

Thanks about that, oh and have a happy new yearrotfl!

Hello there,

I also have a problem with AMD drivers. I’m running Suse 12.1 x64 on a Radeon HD 6850.

First I installed Catalyst driver using the ‘1 click method (64 bit)’ as Hipster_Doofus said. Everything was ok during the install and I had Catalyst Control center, etc but I couldn’t use any desktop effects. Then I reinstalled the driver with atiupgrade, same result. I also ran aticonfig --initial after that just in case, didn’t help either.

Now whenever I try to use OpenGL in KWin it gives me errors saying ‘the following desktop effects cannot be activated: < long list >’ If I try to use one anyway, KWin crashes, saying it might be a driver problem. The only way I can get transparent taskbar and stuff is by using the X-Render option @ Desktop effects, but it’s slow and can’t use every effect with it. I have no experience with Suse (not much with other Linux systems either), I would be glad to get it working, installing Ati drivers has been a nightmare on every distro I’ve tried so far. Thx in advance!