amd driver installer not working on 12.3

I did a fresh install on a Gigabyte MB with an onboard ATI RS880 / Radeon HD4200
Downloaded, unzipped an ran it.

First it complained about a missing file:

After creating the dir ** /lib/modules/3.7.10-1.1-desktop/build/include/linux/**
and then creating the file version.h with

#define LINUX_VERSION_CODE 198410
#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))

The script ran through with the following error message generated in /usr/share/ati/fglrx-install.log

Check if system has the tools required for installation.
Uninstalling any previously installed drivers.
Unloading radeon module...
ERROR: Module radeon is in use
Unloading drm module...
ERROR: Module drm is in use by radeon,ttm,drm_kms_helper
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.7.10-1.1-desktop/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-3.7.10-1.1-obj/x86_64/desktop'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_MEM_AllocLinearAddrInterval’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2152:5: error: implicit declaration of function ‘do_mmap’ -Werror=implicit-function-declaration]
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2152:13: warning: cast to pointer from integer of different size -Wint-to-pointer-cast]
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_MEM_VM_MapRegion’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3700:39: error: ‘VM_RESERVED’ undeclared (first use in this function)
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3700:39: note: each undeclared identifier is reported only once for each function it appears in
cc1: some warnings being treated as errors
make[4]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[3]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-3.7.10-1.1-obj/x86_64/desktop'
make: *** [kmod_build] Error 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
[Reboot] Kernel Module : mkinitrd

Can anybody help with this?

It won’t work, you need to use the OSS radeon driver from now on. See this thread
Update your fglrx/fgrlx-legacy repositories

Thanks for the quick response!
I confirm it works now with the radeon driver. I could not set resolutions other than the defaults at first but that is solved now probably by rebooting.