AMD ATI Display Driver Installation Questions

I am building a new computer with AMD A6-3670 APU with Radeon™ HD Graphics Processor on a MSi A75Ma-P335 (Model MS-7697) Main Board. From the System information page, Display Info says ATI Technologies, 2D driver fbdev and 3D Driver swrast (no 3D acceleration) (7.11).

To install open SUSE 12.1, I had to use “nomodeset”. After installation, I have a poor (characters stretched out sideways - eg O is oval, not round), but readable, display on the Acer v193w monitor.

I think I found the proper driver and downloaded it.

**First Question - Is this the proper driver for this hardware and openSUSE 12.1?

**Here are the instructions for installing the driver from SUSE/openSUSE -


OpenSuSe 12.1 (Driver from AMD website) easy way–only way so far…

  • Download The Latest AMD Driver from ATI/AMD


  • Open software manager in YAST and install 5 packages by hand:

kernel-devel kernel-desktop-devel gcc gcc-c++ make
OR use the terminal and run:

sudo zypper in kernel-devel kernel-desktop-devel gcc gcc-c++ make

  • reboot
  • If radeon driver is active
    you must blacklist it, add this to boot paramaters (during grub startup menu):

radeon.modeset=0 blacklist=radeon 3

  • This will disable radeon driver and boot into runlevel 3. SU to get root, run mkinitrd to make sure radeon stays blacklisted.
  • (Comment) in case the above method does not help, you may try add to /etc/modprobe.d/50-blacklist.conf the following line

blacklist radeon

  • (Comment) Either way, when your linux booted, you should check whether the radeon kernel module is not loaded, run

lsmod | grep radeon if nothing comes up you are good to go

  • cd to directory where proprietary “amd-driver-installer” is,


sh amd-driver-installer-*.run

  • install default (do not generate distibution package)
  • verify /usr/share/ati fglrx-install.log, at the end of the file you should see "build succeeded with return value 0 duplicating results into driver repository…done.
  • in terminal type:

aticonfig --initial

  • then run:

/sbin/shutdown -r now

I Think I can follow these instructions but I do not understand the “blacklist radeon” part. Radeon is loaded and running on my system.

Question Two - Is Radeon supposed to be permanently disabled or just disabled during the ATI driver installation?

Question Three - Has anyone here actually installed this driver? If so, was it successful?

Question Four - Do any of the pros here have further advice or suggestions?


I installed fglrx “The Easy Way (GUI)” based on the instructions from: SDB:ATI drivers - openSUSE
I skipped the preamble, and it’s working fine for me (HD 6450).
I don’t necessarily recommend doing it the way I did though.

I would have a look at this message thread on the subject if you have not already done so.

Thank You,

The developer talk is several levels above my competence. I gave up before I got to the point in your link.Maybe someday I will have time to learn to write these scripts and be able to understand the scripts others have written.

The instructions from the unofficial AMD wiki are fairly explicit. I think I can follow them and see what happens. It is early in this OS/software build so I don’t have much to lose (unless smoke starts coming out of the case). I can just start over.

I keep fairly detailed notes whenever I build a computer. Do you think they might be useful to others? If so, where should I post them? I could put them on my personal website but only family and friends who are uninterested in computers would see them.


Just add the following repository (excluding the quotes) from please_try_again into YaST / Software / Software Repositories


Then, in YaST / Software / Software Management search on: atiupgrade and once found, install it. please_try_again keeps the latest version there. You just run the script as I understand it and it will fetch the latest driver for you. If you have any questions, just post them into that thread.

Thank You,

I added the repository, installed atiupgrade and ran it. There was no indication that anything was running, but I left it alone while I ate. When I came back, I couldn’t see any difference in the display so I tried to reboot. Evidently something did happen because it will not boot except in Emergency Mode (something I have never encountered before). I am not sure what I did wrong.

This early in the OS/software setup, I don’t want to do any work-around fixes to try to get it working. I will do a new installation and try again. I’ll be back when I get that done.


Normally, you must add in the kernel load option called nomodeset which you can type in in the grub OS selection menu before you press the enter key and which is in the emergency load called Failsafe. If this works, you can edit the /boot/grub/menu.lst file as root and add this to the openSUSE startup line as a permanent kernel loading option. Give it a try and let us know if it worked.

Thank You,

Reviewing this thread from the original post, I notice Questions 1 and 2 have not been discussed: Is this the proper driver? Is disabling Radeon permanent or temporary?

Also worth noting (and not explicitly stated in the original post) is that Radeon Graphics are built into the socket FM1 AMD quad-core processor. They are not built into the main board and this is not an add-on card in a slot.

The ATI drivers, specifically ATI HD6350, are needed but I don’t understand just how they fit into the scheme of things.

Busy day ahead with lots of outside-the-computer issues to deal with. I will check back in the PM.


I am happy to report that the procedures outlined in the first post of this thread do work with a new installation.

The only trick is that to do the installation (before the video driver is installed) you must type “nomodeset” on the boot loader page to see and respond to the installation process. Once openSUSE 12.1 is installed, you can follow the AMD/ATI instructions above.

This is the proper driver (fglrx) for this hardware and Radeon stays blacklisted.


jcmcdaniel3 -
This emergency mode is completely different from Failsafe. It puts you in terminal command line mode and shows a lot of information I don’t really understand.


So, can we assume you are up and runing properly with the correct video driver being loaded now? If you have any suggestions for the installation of the ATI driver, please let please_try_again know in his message thread on the subject.

Thank You,

Thank you for your help as always. I truly appreciate it.

Yes, It appears to be up and running properly as far as the video goes. I will reference this thread on the please_try_again thread. I am always reluctant to do that or report bugs because I really don’t know what I am talking about. Mostly, I just fool with it and ask questions until something works and then move on to the next thing.

Audio is next but it usually isn’t much problem.

Then a Cannon printer on a peer to peer Microsoft network with both wired and wireless router connections. The Linux box will be wired but the printer is wireless. That will mean some Samba questions maybe and Linux Cannon printer/scanner drivers. I haven’t even started thinking about all that.

I saved 150 gb of the 500gb hard drive for a windows dual boot later. I will need windows to read and convert a lot of very old files going back to the 80s. They are on old hard drives (which I will put into an external drive enclosure to read) and CDs. There are roughly 50 CDs of old pictures from my parents and grandparents albums that I scanned and put into PhotoRecall albums as very large TIFF images before returning the originals to various relatives. The problem is that PhotoRecall went out of business and getting the pictures and captions out of that database is a major problem. The PhotoRecall software is a modified Access database that I can get to run with Windows Vista. So I will be coming here with Dual-Boot (using the Linux boot loader) questions.

Also many of our old records, including deeds, probate records, birth and death certificates and other important permanent documents, are in .xif format. I found a reader/converter that will run under windows if Image Magic won’t do the job.

Then there is the software I want on this computer - KmyMoney for personal accounting, Inkscape and GIMP.

The purpose of this computer is to bring our records up to date in formats that are a widely used and as generic as possible. A word of advice - don’t use proprietary file types or software any more than absolutely necessary for long term records and heirloom family pictures. The same probably applies to audio and video files but I don’t have much of that to deal with.

I am afraid I will be a permanent newbie here.

Again, thank you for you always reliable help. I will buy you a steak dinner next time I am in Austin.


lol ! Join the club ! With me also being a big member of the newbie club, despite my many years on GNU/Linux. If were not for a few tidbits I know about sound (and even less on graphics), my posts would be more about asking for help, rather than giving. I mostly consider myself a newbie in a number of GNU/Linux areas and I’ve learned mostly by too many years of experience with my making silly mistakes. :smiley:

You are in good hands with jdmcdaniel3 and please_try_again.