Amazon Mp3 Downloader

not sure where to put this really. So if its in the wrong spot, have mercy.

I tried to download a full album from amazon, but you need to install their app for that.
Now i am running 64bit 11.3 OpenSuse KDE and so far, Amazon does not provide 64bit for linux.
How can i get the album the easiest way on my computer? I do not use Windows or Mac as an alternative.
I tried to do it with Wine (IE6) put it fails to install for some reason. Now i am thinking of doing it with a live-cd, but not sure if i can mount the harddrives then. Or maybe i just save it on a usb stick.
Anyway, what would be my best option?

What about virtual box running a XP VM?

Did you try installing the Amazon package? It should work I think, though I never used it myself.

Oh, thats the other one… :slight_smile: i totally forgot the VM. Have to check that.

No, the amazon package does not work with 64bit. You can install it, but it is missing dependencies and so it will not work. Amazon states that at the current time 64bit is not supported, though they are working on to have also a 64bit version out at one point.

Good thing is, i still have my XP flying somewhere around, so i will give it a try.

Virtual Box (Sun Version) Install HowTo

Why bother with XP since you can run a 32bit linux guest (running the Amazon Downloader) on a 64bit VBox host. :wink:

Gee, what a pain it is if you run 64 bit and the rest of the world thinks 32 bit is still cutting edge.
I tried Virtual Box but failed. First ‘make’ wasn’t included in my system which failed the first attempt.
Then the source to the kernel can not be found. Oh, forget it. I just want one silly cd from Amazon.

Ok, now i will try Oracle Virtual Baby. Will see how that runs.

I tried also Firefox with wine. Amazons MP3 killer app installs, but the download button is >nil.

Then i tried Ubuntu’s live cd, thought now i can see at least their linux. But it did not made it after the gfx check. Frooze. Mega Fail.

Now, like i said, i try VM. I keep my fingers crossed.

Oh, i am dummy. It was the same program.
My eyes getting already big.


kernel development Eg: kernel-default-devel

these are not in Software Management.

Ok, it worked fantastic.
The only problem i see, is the transfer. Since i only have a cd, i used my usb stick to transfer my files.


btw. if you are wondering what i downloaded, it was Mirrors Edge Soundtrack, on sale for $5. :slight_smile:
I am happy now :slight_smile:

Setup a shared folder between the Virtual Machine and the Linux Host. It’s all in the manual:

Try They’re usually as cheap as Amazon and you don’t need special software to download an album.

You can use clamz. Its free and it is licensed under GPL. So it is good software which works with Amazon Mp3 downloads on opensuse 11.3.

clamz - Project Hosting on Google Code

Hallo together!

  1. add repository at URL Index of /distribution/11.2/repo/oss/suse
    (the required libs are there)
  2. install amazonmp3.rpm (use the 32bit-versions of the required libs on 64bit systems)
  3. maybe: tell firefox to open *.amz files with /usr/bin/amazonmp3


If you happen to be in Britain…

In that case use clamz. It works perfectly.

I was able to compile the 32-bit version of libboost after install of the amazonmp3 player (despite the warnings). Version 1.36 was required. After this the downloader works like a charm! A pain to do, though, particularly since boost really is a tangled mess.

If anyone is interested, contact me

Fiddling around with Virtual Machines etc. isn’t necessary anymore. Banshee (a music player) now has an Amazon MP3 store plugin.

Simply add the Banshee repository for 11.3 (Index of /repositories/Banshee/openSUSE_11.3) so you can upgrade to the latest version which has the Amazon plugin. You can choose where it downloads to so it doesn’t force you to use Banshee as your music player if you just want to use it for the Amazon downloads.

Ditto to peteh100

clamz works fine with FireFox and Amazon mp3 downloads