Amazingly bad latency

I recently upgraded my system and made a completely fresh install of openSUSE 11.4 on the following hardware of interest (if there’s any other hardware of interest in this issue, please let me know):

AMD Phenom II X2 560
MSI 785GT-E63 motherboard with AMD785G chipset (the onboard audio registers as nVidia, though… no idea if that’s a false reading or not)
Sound Blaster Audigy

My intention was to use the Audigy for sound due to its hardware mixer and other features (I’m not really familiar with whatever the onboard HDMI audio is, I’m just going with what I’m comfortable).

Among the long list of things I wanted to do in order to get comfortable was to unpack a tar of the /usr/local/games directory from the old system I had made prior to rebuilding (the only things to survive from the old system was one IDE drive, a USB controller card and the Audigy). It contains a lot of older games that I no longer have the original media for, like some old Loki ports, a couple of Unreal Tournaments, Neverwinter Nights and Doom 3. Naturally, part of testing that everything was working right was playing some games. I did some of the more modern ones that I had gotten from repos (like Nexuiz), then the old ones. I don’t recall if it was Unreal Tournament 2004 or Doom 3 that had no sound and complained at the command line that it couldn’t find /dev/dsp, but making a symbolic link from /dev/dsp1 to /dev/dsp made it work.

Further messing around included setting up Wine, which is when I discovered that Wine doesn’t play well with that blasted pulseaudio. I found the thread with a link to serkbugs2’s builds and installed those, tested it with some random Windows game I looked up and it worked fine.

Something I’d put off previously and wanted to get to now that I had better hardware was trying the Quake 4 demo. So I did and it was working fine until some system sound happened. It stopped the audio. About a minute later, the audio started again… from the point where it left off. Exiting out of the game was strange because it got to the exit splash screen and wouldn’t do a **** thing until the audio had caught up. I shut it down and pulled up paprefs to turn on simultaneous output (and turn off the onboard sound, which I’d turned off in the BIOS and didn’t expect that would be ignored). It’s kind of odd to me, though, as it seems pulseaudio is completely bypassing the hardware mixer of the Audigy. I wouldn’t mind it doing that were it not for the fact that it did the same thing AGAIN when I tried to load the Quake 4 demo.

Long-winded story, I know, but I don’t know if there was anything I did in all of that which would cause this. I actually have YaST pulled up right now and was ready to uninstall pulseaudio before I wrote this, but figured I’d try first to see if there’s some simple thing I can do to get it working right.

Do you have an nVIDIA video card with a HDMI connection? Did you go to YaST / Hardware / Sound and make sure that the Audigy Sound card is designated as “0” or the primary sound card? I still have an orginal Audigy Sound card on one PC with the I/O expansion and a nVIDIA 460 video card. I must make the Audigy card “0” to get it to work properly in everything. By the way, in openSUSE 11.4 it is possible to disable Pulse Audio (In terminal: sudo setup-pulseaudio --disable) and to make xine the default sound server in KDE (menu / Personnel Settings / Multimedia / Backend), which puts you back to the way it used to be, but the Audigy sound card still needs to be “0”.

Thank You,

No, xine is not a “sound server”. It’s a playback engine supporting frontend multimedia players, and a Phonon backend in KDE. A sound server can mix different data streams from multiple sources (e.g application progs), a capability you loose by uninstalling PulseAudio. Examples of linux sound servers are JACK, PulseAudio, and ESD.

I have a similar problem. If two sounds happen at the same time they will glitch and kill or garble the sound until I make the system quiet. How the heck do I fix this? No other distro has done this. Its basically my final complaint.

If your hardware and/or software is different in any way, please start your own thread about your sound problem. Please provide basic information such as: Sound hardware (chip/card, speaker config) OpenSUSE release and DE type, default install or non-standard system software release, what audio player apps are involved in the problem, and any other relevant info required by reading the forum thread stickies listed at the beginning of this multimedia forum.

Otherwise we are all just guessing at possible solutions. Thank you. :slight_smile:

Thanks. I’m glad I don’t have to completely remove pulseaudio. To be honest, I can’t stand the **** thing, but I know I’d better just get used to it as it’s not going anywhere.

While redesignating the Audigy as card 0 didn’t solve the problem, I thank you for reminding me of that because it’s something I wanted to do in the past anyway, but didn’t think of this installation. You know, while I can see a certain logic behind marking the onboard as 0 by default (and perhaps there’s more of which I’m not aware), it would seem to me that if someone has onboard sound but puts a card in anyway, the greater logic would be to assume that the card should be 0. But maybe that’s just me.

Anyway, being a bit stubborn, I kept looking for something I’d missed previously. I found this on the pulseaudio project’s bug site:

While it’s not precisely the same, it’s similar enough that I took a shot at the laziest possible solution listed (exporting SDL_AUDIODRIVER=“pulse”) and thus far it seems to have worked. I was able to play the Q4 demo long enough to get killed, which isn’t THAT impressive, but at least sound never stopped until I’d shut down the game.

Oh, I forgot to mention that before I did that, I also tried adding my user to the audio group. I figured I might be able to allow the game to access the card directly, but since it didn’t work, I imagine I would have to prevent Q4 from using pulse regardless and I’m not even sure where to start with that.

I’m going to continue to try games, but there’s at least one thing that it happened to that I don’t see being affected by SDL. Yesterday, I had a playlist going in Amarok. As it played, I was browsing and chatting in aMSN. aMSN was, of course, making an alert sound when I got a message and it was behind the browser, but this didn’t interrupt Amarok. However, at some point, there was SOME system sound that DID interrupt Amarok, which went silent. It locked up when I hit the pause/play button, so I killed it. When I restarted it, it worked fine again. I don’t know what the sound that interrupted it was; I had a vague idea at the time that it was some notification from a KDE app, but I was startled enough by the cessation of music that I didn’t pay enough attention to say. It could even have been another aMSN sound.

At this point, I have to wonder if there’s a problem with the pulseaudio buffer. I also wonder if I need to install (or maybe remove) some 32bit libraries. I’m new to the 64 bit stuff (my previous CPU was an Athlon XP), so I only have a vague recollection of discussions about that among other users.

Actually, one of the reasons I’m sticking with my Audigy is because this is not the case. The hardware mixer made things much better for me even way back in the days of artsd.

You mean it’s not the case in your case. It would be the case for many though (including me) who don’t have the necessary hardware to do it.

Anyway, thanks for posting back the results of your research. It could help another hopeful gamer. :slight_smile:

I totally dig. That’s why I always suggest Audigy (and even Live!) to Linux gamers, lol. There might be other awesome cards/chipsets out there, but it’s nearly impossible to figure out that information. I’ve even thought about making my own simplified list of what works and what doesn’t in audio cards with alsa, but I get so ****ed confused looking at any of the available information that I fear even beginning.

This and only this is the reason I’m stubbornly trying to stick to pulseaudio. There are some things I’ll probably always despise about it (in particular, this: #480 (PulseAudio doesn’t allow me to adjust any sound properties of card other than volume)]( ), but it does seem to be going in a smart direction. That, and as it becomes more ubiquitous, I’m guessing that it’s going to become necessary, as well.

Anyway, thanks for posting back the results of your research. It could help another hopeful gamer. :slight_smile:

I hope so.