Amarok

Hi!
when i open amarok and install mp3 support i get the following error from yast

YaST2 conflicts list - generated 2010-08-22 06:55:47

libxine1-codecs-1.1.19-1.pm.44.3.i586 requires libxine1 = 1.1.19, but this requirement cannot be provided
uninstallable providers: libxine1-1.1.19-1.pm.44.3.i586[packman]
] do not install libxine1-codecs-1.1.19-1.pm.44.3.i586

 ] Following actions will be done:

install libxine1-1.1.19-1.pm.44.3.i586 (with vendor change)
openSUSE → PackMan :: Startseite
install libxine1-pulse-1.1.19-1.pm.44.3.i586 (with vendor change)
openSUSE → PackMan :: Startseite
install libxine1-gnome-vfs-1.1.19-1.pm.44.3.i586 (with vendor change)
openSUSE → PackMan :: Startseite
] break libxine1-codecs by ignoring some of its dependencies

YaST2 conflicts list END

Any help wud b appreciated :slight_smile:

Hello sworoopmahapatra,

The easiest way forward is to use the Yast2 software management tool. Filter by repository and choose packman. In the right hand pain, about in the middle, will be a button that roughly reads “replace installed packages with packages from this repository”. You will probably want to ensure the following packages are installed:

amarok-xine
libavcodec52
libdvdnav4
libdvdplay0
libdvdread4
libavdevice52
ffmpeg
libquicktime0
libxine1
libxine1-codecs
libxvidcore4
smplayer (for video playback of various restricted formats)
vlc
w32codec-all
xine-ui
xvidcore

You may get some pop-ups asking you to resolve conflicts; just resolve them such that everything is being installed from packman.

Enjoy!

oxala

This is the answer

X] Following actions will be done:
install libxine1-1.1.19-1.pm.44.3.i586 (with vendor change)
openSUSE → PackMan :: Startseite
install libxine1-pulse-1.1.19-1.pm.44.3.i586 (with vendor change)
openSUSE → PackMan :: Startseite
install libxine1-gnome-vfs-1.1.19-1.pm.44.3.i586 (with vendor change)
openSUSE → PackMan :: Startseite

@caf4926 It worked :slight_smile:
thanks again :slight_smile:

Again. I’m getting good at this.
Well done friend!