Amarok / yauap not playing .ogg files or streams

I can’t play ogg vorbis files or streams using yauap or Amarok on my openSUSE 11.1 system. Is it possible to force yauap to load the required plugins?

The files play fine using:

gst-launch -v filesrc location=Track\ 01.ogg ! oggdemux ! vorbisdec ! audioconvert ! audioresample ! pulsesink

And streams with:

gst-launch -v souphttpsrc location= ! oggdemux ! vorbisdec ! audioconvert ! audioresample ! pulsesink

So I think I’ve got all the right gstreamer plugins in place

kind regards, Wouter Koersen

Yikes! I hope .ogg files would at least play in SUSE out of the box. They seem to work here. Can you give an example of some streams that are not working? Here is a list of them for you to try:

VorbisStreams - XiphWiki

Also, are you using 64-bit or the old 32-bit? Default KDE 11.1 installation, right?

Hi Craig,

I’m glad to see you are concerned about this.

I reinstalled my two systems using the 32 bit live CD, only preserving /home. I think they share this problem, but I’ll run the test on the page you sent.

By the way, I have to say that, after almost three weeks, I like openSUSE 11.1 very much. I did not like KDE4 in 11.0 (desktop effects would not work), but now it’s fine.

kind regards, wouter…

Amarok Packman with Amarok xine seems much better to me.

Thanks for pointing me to that page, I will probably find some more stations to listen to there.

In my previous posts I forgot to mention that mp3 streams and mp3 files and wav files play just fine. AAC+ streams don’t play, but they give an error message: MPEG Audio decoder missing on the status bar.
I ran some tests. First I created a new user, using useradd -m. This caused the .ogg welcome message to show up in the playlist. The welcome message plays just fine, It also plays when I use the normal user account.

All other .ogg streams, and the .ogg file I created using the audiocd service in Konqueror don’t play. That is, now that I took a closer look, they do appear as if they are playing. The play button is blue and there’s a triangle in the playlist. The status message in the lower left corner says Playing: but there is no sound and the elapsed time stays at 0:00.

Streams I tried:

These all work in VLC.

I’ve the same problem when Amarok playing ogg files. It seems that Amarok is playing ogg file but no chance to hear the voice. Have to mention that file’s converted with Konqueror from mp3 to ogg and this problem appeared in openSUSE 11.1, kde 3.5.

I have the same problem. MP3’s play fine with Amarok on OpenSuse 11.1, but Ogg Vorbis files will not initiate. They appear to be running, but no sound occurs and the count down timer does not run.
This worked fine under OpenSuse 11.0.