Amarok won't play songs

I’ve been having some intermittent problems with Amarok. When I select an album to play, Amarok flys through all the songs on the album without playing them. The message “Playlist finished” appears and at the bottom of the window it says, “Could not get/set settings from/on resource”. This is when I use the Yauap engine.

If I use the xine engine, the same thing happens but the message at the bottom of the screen is different. It now gives me “Audio output unavailable, the device is busy. xine parameters:”.

It doesn’t do this all the time. I’m running version on 11RC1. Anyone have any ideas what could be going on here? I’d really like to get this going. I miss my Amarok :frowning:

I also have Rhythmbox installed and that seems to work ok.

Could you tell us a bit more about which versions of amarok and xine you have installed?

Please, type the following in an xterm/terminal/konsole (what ever you use) and copy and paste to here the output:

rpm -qa grep | xine
rpm -qa grep | amarok
rpm -q mad

I want to see if you used the Novell/openSUSE packaged versions of these apps (which are crippled for most proprietary multimedia), or if you are using packman or videolan packaged versions.

Yauap engine is working with gstreamer if I’m not mistaken which has mp3 support natively through fluendo iirc.

It is more likely to be related to porting of amarok to kde4. I know when I was trying amarok was constantly coming up as problem software, and was added at a later date.

As here Restricted Formats - openSUSE

When I try:
rpm -qa grep | xine - I get

bash: xine: command not found

with rpm -qa grep | amarok it launches the program. I’m not sure if that’s what you wanted or not. But one thing it did show me is the following messages when I try to play some songs.

gumper@linux-4ezw:~> *** PULSEAUDIO: Unable to create stream.
QString::arg(): Argument missing: <p>Audio output unavailable; the device is busy.<p>xine parameters: <i></i>, file:///home/gumper/Music/Casting Crowns - The Altar and The Door/01 - What This World Needs.ogg
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.

Maybe it’s something related to Pulseaudio. I think I’ll remove the packages for it and install Esound to see if that helps.

With rpm q mad I get

package mad is not installed

In my original message I said that Rhythmbox was working fine. That’s incorrect. It doesn’t zip through the playlist like Amarok, but I can’t get it to play any sound. My sound is working cause I get the noises when I minimize windows.

Thanks for the help.

It is because that command are wrong. That pipe is on bad position. It should be

rpm -qa | grep xine
rpm -qa | grep amarok
rpm -q mad

But, have you Packman added? There are packages with multimedia support. I have 11.0 and packages forom packman and it works for me.

m4r3k is correct. My apologies, as I typed those commands in a hurry when tired. Please try again, with his correction:
rpm -qa | grep xine
rpm -qa | grep amarok
rpm -q mad

alternatively, for the first two commands, you could type:
rpm -qa ‘xine
rpm -qa 'amarok

I didn’t type that originally, as I was afraid the single quotation before/after the asterix would be hard to see.

You are using 11.0 RC1 which have an issue with pulseaudio. I will see if i can find the solution in the factory mailinglist.

You can just use 1-click-install to get all of the necessary codecs in openSUSE 11.0. See the restricted formats page, as linked to above: Restricted Formats/11.0 - openSUSE-Community

Try pulseaudio -D on the konsole.

If that does not help try to comment out the following line:

/etc/asound‑pulse.conf from the file /usr/share/alsa/alsa.conf

then it should work.

I ended up just removing PulseAudio and so far Amarok is working fine. I’ll report back if thing go south again.

Thanks for all the help:)

Congratulation on sorting this, and thanks for sharing your solution.

… having stated that, as was pointed out to me recently on IRC #suse, pulse audio will be here in 11.0 and it is likely here to stay for a while. Hence I am keen on learning how to deal with such problems without removing pulse audio.

I’ll be MOST interested if anyone has tried KunzeS’s recommendations, and how it worked out.

I can see this sort of thing ultimately needing some sort of tips-and-trick, or how-to guide.

I tried this and these are my results

jonw@jons-laptop:~> pulseaudio -D
W: core-util.c: setpriority(): Permission denied

Then I commented out the code in alsa.conf, restarted, and fired up Amarok. Amarok worked well. I then decided to give it the ultimate test by starting Gizmo5 VOIP software which does not like to hardware mix. Beleive it or not, it works fine. On a side note PulseAudio Manager still says that the connection is refused to the PulseAudio sound server. I still have pulseaudio packages installed. If anyone wants more information, please let me know.

Thanks KunzeS for you suggestion

Concerning the pulseaudio -D - can it be that you were not logged in as root. Forgot to mention that.

Should have mentioned I tried both ways. Here is the output

JonsWorkstation:/home/jonw # pulseaudio -D
W: main.c: This program is not intended to be run as root (unless --system is specified).

In case you notice, it is a different computer, but gives the same output. I’m not sure if I should run it like pulseaudio -D --system. I will try that later, on the original computer and let you know what happens. After all it is the RC1 and if it messes everything up, oh well.

Very similar problem here, but the cause might be slightly different.

Install RC1 & Install stuff from Packman and everything works fine (using amarok(xine) and everything else). Then upgrading to KDE 4.0.81 from the KDE:Unstable repository and sounds starts to mess up.

Everything using Phonon works fine (both audio and video and several applications at once, using the only availible engine - xine), but any seperate audio using application (amarok 1.4, mplayer and similar) you get a ‘device busy’ error no matter what you do. Workaround so far is to log out and then log in again and then play something using mplayer or to run everything from a KDE 3 session (not a single problem there) …

Tried the pulseaudio -D option, but it didn’t work. Have yet to try the change in the alsa config file.

PS: Another trick when amarok+xine doesn’t work right is to delete the xine.rc file in the amarok subdirectory, so that it re-reads the defaults and so picks up some option which might have changed.

I removed .pulse and the .pulse-cookie in the user home dir and then amarok started working again. There was no reference to pulse in my also config.