Amarok won't play mp3

Hi peoples

first time i’ve had this issue in Opensuse… Its only been happening since opensuse 11.1…

Mp3’s won’t work in amarok… neither in kde 4.2, or kde 3.5…
Sometimes it plays… but most of the time it doesn’t, and i havn’t got a clue why…

I have All the codecs and everything I need… so i don’t see what the problem is…

I have installed the restricted codecs from the 1 click install (kde) I have gstreamer, the phonon-backend-gstreamer, I have libxine1, w32, I got em All! And 90% of the time, Amarok won’t play my mp3’s… it just does nothing… but it plays .ogg files just fine… as I said… I never had this problem in opensuse 11.0, Any ideas???

I have a similiar problem with flash… sometimes it works… sometimes it don’t… but i’ll focus on the amarok problem for now…


and yes i have tried the packman versions.

Open Yast - Software Management
Filter by repo (Make sure you do NOT have the VLC repo enabled)
Select Packman

Make sure you amarok-packman
delete amarok-yauap

From packages tab at top of screen
select update all in this list unconditionally


In amarok make sure you use the xine engine

Multi-media and Restricted Format Installation Guide - openSUSE Forums

I already have the packages you suggested from the packman repo…
I updated those packages…
and now it works…

hopefully the kde4 version of amarok will work now :slight_smile:

hmmmmm. and now it don’t work again…it seems to work well for a little while, but a day or so later… its as if it forgets that i have the codecs and refuses to play… :o
so i have to keep installing the kde restricted codecs… what the hell… never had this happen in suse 11… weird.

Check your packages against this
(Just one update to the link “libavcodec51 should be libavcodec52”)

Multi-media and Restricted Format Installation Guide - openSUSE Forums

Try the 10 steps check ref’d in there too