Amarok Will Not Play

Amarok 1 and 2 both do not play using the default installed engines. (Yauap and Gstreamer Phonon). I tried both the DVD of 11.1 and the KDE Respin.

I can install the Xine backend for Amarok KDE3 and get sound output, though I have to remove the Alsa pulse plugin.

Amarok for KDE4 does not work at all. It simply says ‘too many playlist errors’. My music is all verified OGG Vorbis and FLAC files, they work by default using Gstreamer in Banshee.

My main issue is this machine does not have the internet, so an update is impossible, unless I download all of the packages manually.

I would thank you all for any assistance, I would like to use OpenSUSE as my distro of choice. :wink:

I think an easier way (than removing the alsa pulse plugin) is to just go to amarok’s configuration setup, and tell it to use alsa and not pulse. That way one can keep the alsa pulse plugin.

I use KDE-3.5.10, so I can not help with KDE4.

Please note this post in our stickie: openSUSE Forums - View Single Post - NEWBIES - Suse-11.1 Pre-installation – PLEASE READ

Pulseaudio does not work very well, so I disable it anyway. I mean the yauap engine does not play my files. I think setting the Xine Phonon engine should fix the KDE4 one, yet I am wondering why gstreamer does not work.

Do you have the packman packaged gstreamer installed?

Anyway, I don’t use gstreamer so I can’t help there. I use the xine sound engine (as packaged by Packman packagers).

My Lenovo using factory kde4’s amarok, xine backend and amazingly: Pulse

It’s good.

Amarok for KDE4 does not work at all.
Umm… Don’t agree there. Check you are getting all your multi-media from Packman.
Multi-media and Restricted Format Installation Guide - openSUSE Forums