Amarok will not play some mp3's!

I’m having trouble playing some mp3’s through Amarok, all other media players are fine with the mp3’s in question. Tested on VLC and Audacious. Most other mp3’s play through Amarok though. Why this problem. I’m using the gstreamer backend. I tried changing it to xine but then nothing would play. I really like Amarok and want to use it as my main player, so this issue is a little irritating.

Does anyone have any ideas on this rather bizarre problem?

openSUSE 11.4 64bit with KDE.

Should this post be in Multimedia??? If so, mods can you move it. The question still stands.

I’ll move it

I’ll PM you with a email address to send one of the files

Thanks for the file
It works OK

Well I tried to install the codecs you suggested no joy. I’ll just have to put up with it and use a different player.

Have you tried this:
MMCHECK - Version 2.35 - Check Your Multimedia in 16 Steps - Bash Script File - Blogs - openSUSE Forums

No I have not. I’m on my Android device now. I’ll try that when I get home. Thanks.