Amarok - which version to use?

I am not having any luck with the ‘out-of-the-box’ version of Amarok on 11.2. It is missing a lot of features (syncing with my fuze most notably). So I figured that I would go to the latest version, but the one-click install from backports (2.2.2-4.1) reported that it could not install amarok-xine and amarok-libvisual. It installed anyway, but was not stable at all. I thought that that install process was supposed to do the updates for me. I went back to the 2.1.1 version, but it still crashes pretty frequently. Trying banshee right now.

Anyway, the big question is… do I go up, down, or off for Amarok? I have a Sansa Fuze and would love to sync music with it, but Amarok is not getting the job done right now. I have read of people going back to 1.4, but after my attempt to install 2.2.2, I’m not so sure that I’m doing it right. Should what I did have worked?

If the answer is off, any ideas on what a good player is? I’d like to find one that will get album art and transfer it to my fuze as well (folder.jpg is what seems to make it the happiest).


I find that banshee can fulfill your requirements. Make sure to download all the needed gstreamer plugins as banshee uses gstreamer instead of xine.

Here’s my list for what I have installed for Gstreamer. I made the packages you’ll definitely want in Bold. The rest might be pulled in or I just added them just in case.

rpm -qa --last "*gstreamer*"     Mon 01 Feb 2010 03:28:11 AM EST
****          Mon 01 Feb 2010 03:27:34 AM EST
****     Mon 01 Feb 2010 03:26:01 AM EST Wed 20 Jan 2010 02:34:56 AM EST
**** Wed 20 Jan 2010 02:34:55 AM EST Wed 20 Jan 2010 02:34:52 AM EST Wed 20 Jan 2010 02:34:51 AM EST
**** Wed 20 Jan 2010 02:34:50 AM EST
**** Wed 20 Jan 2010 02:34:46 AM EST
****    Wed 20 Jan 2010 02:34:45 AM EST   Wed 20 Jan 2010 02:34:40 AM EST
gstreamer-0_10-plugins-farsight-0.12.11-2.3   Wed 20 Jan 2010 02:34:39 AM EST
**** Wed 20 Jan 2010 02:34:35 AM EST
**** Wed 20 Jan 2010 02:34:34 AM EST
**** Wed 20 Jan 2010 02:34:32 AM EST            Wed 20 Jan 2010 02:34:24 AM EST Wed 20 Jan 2010 02:34:06 AM EST
banshee-1-backend-engine-gstreamer-1.5.1-1.1.4 Wed 20 Jan 2010 01:19:18 AM EST
gstreamer-0_10-libnice-0.0.9-2.5              Sat 26 Dec 2009 12:57:45 PM EST

Here’s my list for what I have installed with Banshee. I made the packages you’ll definitely want in Bold. I don’t remember if it makes you download some of the other ones.

rpm -qa --last "*banshee*"
banshee-1-backend-platform-gnome-1.5.1-1.1.4  Wed 20 Jan 2010 01:19:35 AM EST
**banshee-1-dmp-ipod-1.5.1-1.1.4**                Wed 20 Jan 2010 01:19:34 AM EST
**banshee-1-dmp-mtp-1.5.1-1.1.4**                 Wed 20 Jan 2010 01:19:31 AM EST
banshee-1-dmp-1.5.1-1.1.4                     Wed 20 Jan 2010 01:19:29 AM EST
banshee-1-extensions-boo-1.5.1-1.1.4          Wed 20 Jan 2010 01:19:27 AM EST
**banshee-1-extensions-default-1.5.1-1.1.4 **     Wed 20 Jan 2010 01:19:23 AM EST
**banshee-1-1.5.1-1.1.4**                         Wed 20 Jan 2010 01:19:20 AM EST
**banshee-1-backend-engine-gstreamer-1.5.1-1.1.4 Wed 20 Jan 2010** 01:19:18 AM EST
banshee-1-backend-platform-unix-1.5.1-1.1.4   Wed 20 Jan 2010 01:19:14 AM EST
banshee-1-client-classic-1.5.1-1.1.4          Wed 20 Jan 2010 01:19:12 AM EST
banshee-1-core-1.5.1-1.1.4                    Wed 20 Jan 2010 01:19:10 AM EST

Take Care,


I had similar problems and downgraded to Amarok 1.4. Check out my post, it got fixed and I am now running Amarok 1.4 on 11.2.

11.2 with Amarok 2 - openSUSE Forums

I suggest, you try to get things solved in the new Amarok. In my house, some Creative’s, an iPod, some exotic players, Amarok sees them all, handles collections and so on.
So instead of rolling back to older software, rather try fixing what’s going wrong.

Thanks for the info folks. I installed some of the banshee plugins for MTP. Some of those deps (and further tinkering) got Amarok to detect my player using MTP as well. I’d still like to go with MSC mode (I use video4fuze to push video as well, no need to mount things twice), but I still have to play around with pod casts and other items like that before I decide. Have to try and get the .is_audio_player solution working in either Amarok or Banshee.

My current task is album art. Amarok and Banshee both will pull album art, but will either write it back into the file as part of the id3 tag. Particularly using v2.3 (which my player understands) instead of v2.4 (which I believe it does not). Right now I’m playing with ‘mp3 diags’ which seems like a nice tool, but I’m still investigating.

I’ll give the Amarok upgrade another shot. Maybe tomorrow when I have more time (and patience).

Also, just a quick side note for any Sansa Fuze users out there… video4fuze is a nice way to put video on your fuze. And… if you have not updated your firmware, give it a shot (check out the sansa forums). I had been trying to dump folder.jpg files for album art, but after the upgrade, it can read the art from the id3 tag. If you don’t have a fuze, check it out. Nice player that is expandable with miroSD that comes in pretty cheap compared to that other player (you know, the one with the ‘i’). Not bashing the iPods mind you, I just think the fuze is overlooked (not as much hype).

Hi. My Amarok is not working well, I can’t listen music. If I start, it run over the playlist (in 2-3 seconds/track) and stoped. It write that too many erors are made. This is in KDE and Gnome too. In Gnome Banshee works very well. What can be the problem with Amarok?
My config: Suse 11.2, Amarok 2.1, Soundcard SB Live 5.1, xine, gstreamer.

I also had problems with Amarok 2.1 in 11.2. I got the music playing by installing “Restricted formats”, but still had problems with podcast-streaming.
I read that podcast was better in Amarok 2.2, but how could I get it upgraded?
Somehow I think that Amarok 2.2 was connected to newer version of KDE. I crashed me KDE trying to upgrade KDE 4.3.1 from 11.2 to a higher level!
Then I trying the new 11.3 M1 (be carefull and use another PC if you can!). This way I got the new Amarok 2.2 together with new KDE 4.4, and installed most of the libs that are mentioned in “Restricted Format”. If you dont install them Amarok will just roll through your mp3-music without beeing able to play it!
Now I have the Amarok 2.2 which also can play podcast-streaming from Danish Boardcast station.


I was able to pull Amarok 2.2.1 from the KDE backports repo. I did this by enabling the repo and selecting the package by hand(the one-click install did not go so well). The app runs well enough. It did crash after importing a large collection, but it did the job first. It also crashes every time I try to configure the audio backend (just trying to see my options). Surely some of these are dep/version issues, but I don’t want to go too far and destabilize my machine.

That version will detect MTP devices well and MSC devices with .is_audio_player (use ‘audio_folder’ in the file, not ‘audio_folders’). But, do be careful with space on the device. I ran out of room and ended up with 152 pop-up warnings (one for each failed file) that froze my KDE desktop until I killed the amarok proc. But again, it did the job before it bailed.

Jury is still out I guess. I’m a developer myself, so I know how it is starting over on an app, but being patient can be difficult. Steady progress though.