Amarok unable to play MP3 files

I’ve tried to search through this forum a couple of times to understand this problem, but no posts to date (that I’ve found) quite address it. Simply put, I am unable to get amarok to play mp3 files, which represent a large portion of my music collection.

Every time I start the program, a window pops up advising me that amarok cannot play mp3 files, and it asks if I wish to install that support. Every time I click yes, it announces that the system has successfully done so, except that I might have to restart the program for the change to take effect. Every time I restart the program the same sequence happens. At no time does it ever play mp3 files.

I’ve tried to install every mp3 codec library I can find, none of this makes any difference. There was a time when amarok handled all this with absolutely no problem and behaved like a really good music manager, but that capability evidently was blown away by some software update that I probably wouldn’t have run if I’d known what would happen.

Does anyone know how to solve this? (Yes, I’ve tried using mmcheck. Does no good. This is openSUSE 11.3 for x86_64. Amarok Version 2.3.0 Using KDE 4.4.4 (KDE 4.4.4) “release 2”



Have you consulted this excellent and necessary tutorial : Multi-media and Restricted Format Installation Guide ?

Yeah, a couple of times, thanks DaaX. I was just firing up the page to cancel this request, as it is now reasonably solved. I realized two things nearly simultaneously:

  1. Because amarok doesn’t display the file extensions too much, I was inadvertently testing it on music that was actually in m4a format (got a mix of formats in my collection) and that was what was failing. Doh!
  2. I was trusting amarok when it said it couldn’t play mp3 files, when in fact it was Lying Like a Rug. Doh!

So, long story short, if I ignore the start-up warning amarok will play mp3 albums apparently fine, and after I hunted down and installed gstream-ffmpeg, it also seems to handle m4a. Happy, happy. No idea why I still get the warning, however.

tanks vermilion,


Funny, there is some days like that we should stay in bed. :wink:

Ok, can you tell us what is the warning you have?

Well, unfortunately the last time it came up, I clicked the little “don’t bother me about this again” box, so now I can’t reproduce it. :\

But basically it’s a yes/no question box that says (approx.) “Amarok cannot currently play mp3 files. Do you wish to install support for mp3 files?”.

As it turns out, however, it does play them, even if you answer No to the question, so at some point I’d guess it’s making an error in detecting installed libraries.


Install Phonon VLC Backend (phonon-backend-vlc)
If Amarok is running during the install - restart it.
and Amarok will play :slight_smile:

Best Regards

Hello, this is a thread from 2010!

Do you realy think that people are still running the version they used in 2010 and are still waiting for a solution?

This thread is CLOSED.