Amarok problem

I’m getting no sound from amarok. I been trying different things like mp3’s and internet radio, updating packages, even choosing gstreamer (xine by default) but no go.

Assuming you have sound otherwise

Try this as su -

rcalsasound restart

Ignore/cancel any messages about sound devices that may appear in kde

try amarok again

I’ve tried resetting but it didn’t work, Internet radio stays at 0:00, maybe lyrics fetching have something to do with it? I don’t know do they have to load first? I never used amarok before, I get sound from everything but amarok. What’s the next step?

First, before I advise something else. Reboot and conform the situation.

Ok done, now what sir? just to be sure I clicked on no.

KDE detected that one or more internal sound devices were removed.
Do you want KDE to permanently forget about these devices?
This is the list of devices KDE thinks can be removed:
Capture: HDA Intel (ALC861-VD Analog)
Output: HDA Intel (ALC861-VD Analog)

If you still have no sound in amarok

Please let me see your repo list by doing this in a terminal:

zypper lr -d

post the result

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

–±------------------------------------±------------------------------------±--------±--------±---------±-------±----------------------------------------------------------------±-------
1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
2 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
3 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
4 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
5 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
6 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss |

Please follow this guide carefully
Multi-media and Restricted Format Installation Guide

After add the repo’s and installing the packages, viola it’s working!

                                                                            thanks abunch!

no problem - happy to help