Amarok (Packman) & Xine

Have Amarok from packman installed along with amarok xine also form packman. (have the metapackage handler for packman amarok enabled)

Have been using Amarok without problem since installing Opensuse 11.0
Decided I wanted to use the EQ on Amarok while listening to some music so had to go and switch to the xine engine.
The problem I have now is that Amarok will play absoltely nothing (zilch)
Any kind of audio file I try to load (mp3, CD etc) I get the message in the playlist window “some media could not be loaded (not playable)”
Have tried fiddling in xine settings (sound on auto detect, Alsa etc) without any luck.
Changing back to yauap engine everything works again - but of course I have no EQ.

Anybody got any ideas on this one?

It would help if you provided specific version information so we could do a quality check on what you believe is installed … ie type:

rpm -q amarok libxine1 mad
and post the output here.

If mad (from packman) is not installed, please install it.

output of
rpm -q amarok libxine1 mad

Like I said above - I have the Amarok-Packman metapackage handler installed. The function of this metapackage is to make sure everything to do with Amarok is installed from packman rpos only and that all dependencies are taken care of.

output of
rpm -q amarok libxine1 mad

I have absolutely NO idea what you mean when you state that.

Do you also have “amarok-xine” installed?

I’ve never used that, and I have absolutely no idea what it is. And I simply do not have problems with amarok for playing media with the xine engine.

Are you referring to the 1-click installer (codecs-kde.ymp) here? If not I recommend it. In the advanced options it allows you to install Packman Amarok and all dependencies…Mplayer too. Just a hunch…have you installed w32codecs-all ??

If you do a search for Amarok in Yast 2 you will see a package called amarok-packman
here is the description from that package.

*amarok-packman - Metapackage to install Amarok from the Packman repository

A metapackage that explicitly requires and installs the Packman builds of Amarok, that are uncrippled and contain MySQL as well as PostgreSQL as collection databases.
It also installs the uncrippled Xine package from Packman, that supports all codecs and formats.

This however is completely unrelated to my issue because I only started playing with this package in looking for a solution to my problem.

Yes, have amarok-xine installed.
I too, in the past (with 10.3) had no issues with the xine engine in amarok.
That is why I am so confused by this - this time round.

To be honest - it’s not that big a deal - I am perfectly happy with the yauap engine - but would be nice to find a solution all the same.

Is there any particular reason to install the codecs-kde package.
The point of amarok from packman is that it is uncrippled and does not require separate codec packages - it uses an uncrippled xine engine that should support mp3 and many other restricted formats.


You don’t need that package. I recommend you remove it.*

Not completely correct, I believe. The point of the packman amarok is that it is not crippled, NOT that it comes with all necessary codecs. There IS a difference.

The Packman packaged amarok does require mad.

Upon further reflection, I dont’ have the patience to debate the fine points of this. The fact is my amarok works. I have “mad” installed. And I don’t have amarok-packman installed.

I know what I have in place works.

I think you want to spend some time figuring out how to get packman to work with xine without “mad”, and get it to work with “amarok-packman” installed. Thats great! and all the more to you. But I have a more pragmatic view with much less patience. I’ll leave you to this thread with others who have the inclination to help with the fine details of a Packman packaged amarok with no “mad” and with “amarok-packman”.

Again, I know what I have in place works.

He has mad installed, the correct version. He showed it in the “rpm -q amarok libxine1 mad” output.

About the original problem… I have no idea.
Other xine-based players (kaffeine…) can play those files? If no, I would try to remove/move ~/.xine to see if there is any problem with xine config.
If other player can play the files I would do the same with amarok config: ~/.kde/share/config/amarokrc and ~/.kde/share/apps/amarok.

True, I’m bad.

Still, I see no reason for amarok-packman and amarok, with both from Packman (at least I think he has both installed, or have I made a mistake there too)?

Good suggestions, but if he has both amarok-packman and amarok installed, will that help?

$ rpm -ql amarok-packman
(contains no files)
$ rpm -qR amarok-packman
amarok =
amarok-lang =
amarok-libvisual =
amarok-xine =
rpmlib(VersionedDependencies) <= 3.0.3-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadIsLzma) <= 4.4.2-1

amarok-packman isn’t a real package. It’s an empty package, without a single file that just requires the real packages. It’s a “pattern” made the old way, before patterns existed.
Its only objective is that people doesn’t mix “amarok” from OSS with “amarok-xine” from Packman and “amarok-libvisual” from updates. If you “install” amarok-packman it will force you to install the correct packman versions of “amarok”, “amarok-lang”, “amarok-libvisual” and “amarok-xine” since it “requires” them.

To have amarok-packman or not makes no difference. Your filesystem will be exactly the same, the only place where you will note that amarok-packman is installed will be in the RPM database itself. You can remove it and nothing will happen, it will just be removed from the RPM database.

Thanks for that explanation.

farcusnz did you try RedDwarf’s suggestion? Quoted here:

I don’t mind telling you I am completely stumped on this one.

Files play fine in kaffeine.

I uninstalled Amarok and all associated packages including mad and libxine etc. Deleted all leftover config files, directories etc.
Reinstalled Amarok (& assoc packages) from packman (without the metapackage).

Fired up Amarok. Went into settings and changed to the xine engine.

Tried adding a file and got the “some media could not be loaded (not playable)” message.

Obviously there is something particular to my system causing this - just not sure where to look next.

not sure if this adds to the mystery or helps.

If I switch to the xine engine and do not close amarok down then Amarok will play using the xine engine.
In only refuses to load the files after a restart of Amarok.

One thing I have noticed this time (and before the reinstall).
I have the small player windows loaded. If I click the EQ button it does not load - but if I then click the playlist button the EQ and the playlist then load.

If I then close the play list and then try to close the EQ - the EQ will not close… The playlist window must be open.

Something is corrupt here . . . but where?

Do you use Gnome/PulseAudio?
Amarok xine engine configuration?

No - don’t use Gnome or PulseAudio
Using KDE

What exactly would I be looking for in Amarok Xine config.
From within settings in Amarok there is not a lot that can be changed.

I have tried setting to “auto detect audio” and also to Alsa.

Should I go and look for something in the config file itself?

Might also be worth mentioning here that I tried switching all amarok files to the kde backports versions instead of packman but had exactly the same issue with that so switched back to packman as it is the version that seems most recommended.

But would I be correct in assuming that this package codecs-kde.ymp is not needed for Amarok.

I do have the W32codecs-all package installed - but again - I believe that Amarok does not use this package. Correct?

I don’t know, just trying to get info.
If you have set “alsa” with “default” output I don’t know what can be wrong.

If you can reproduce the problem trying to play /opt/kde3/share/apps/amarok/data/Amarok_1.4_Welcome.ogg with official (no Packman) packages (both amarok and xine) open a bug report: