Amarok opens and crashes immediately

I have Suse 11.3 KDE and every time I opened an mp3 file, Amarok opened and closed immediately reporting a new bug everytime. So I followed this thread Amarok Not Launching

I have uninstalled Amarok through Install/ Remove software.
But I am not able to find this folder to delete, as mentioned in above post:
Delete the directory ~/.kde/share/apps/amarok

Please help me. Thanks in advance.

It’s kde4

This folder: .kde4/share/apps/amarok

These files:


Of course we don’t know what version you are using or your repos, which may be important

I am not able to see any such folder named ‘amarok’ in .kde4/share/config

If your PC is a 32-bit openSUSE-11.3 (not a 64-bit) with KDE-4.4.4, then after amarok is re-installed, rather than clicking on an mp3 file to play, start amarok with:

strace amarok 

and it should start.

Its possible you encountered this bug:

On Sat, 08 Jan 2011 23:36:02 +0530, babloo75
<> wrote:
> I am not able to see any such folder named ‘amarok’ in
> .kde4/share/config

in ~/.kde4/share/config there isn’t any folder, but config. files from


you find the folder here: ~/.kde4/share/apps/amarok


On Sat, 08 Jan 2011 23:50:05 +0530, phanisvara <>

> On Sat, 08 Jan 2011 23:36:02 +0530, babloo75
> <> wrote:
>> I am not able to see any such folder named ‘amarok’ in
>> .kde4/share/config
> in ~/.kde4/share/config there isn’t any folder, but config. files from
> amarok:
> amarok_appletsrc
> amarok_homerc
> amarok_rc
> you find the folder here: ~/.kde4/share/apps/amarok

sorry, spelling slightly incorrect; that’s


or, if that’s different in your version, just delete all *rc files
starting with “amarok”.


Thank you.
I 'll do as explained.

This is what I have on 11.3

That has happened to me as well. The other day I had an automatic kernel update, and after that all hell broke loose. No graphic login, so I had to replace xorg.conf with backup. Then I had to find and install the right nvidia driver. Then Amarok crashed and won’t work anymore. Now I can’t write to DVD+ anymore. It looks like the driver for DVD+ is missing. I’ve tried re-installing with no success. Now I’m using Juk for music, and I can’t burn the stack of DVDs I have. I’ve been converting all of my home movies and putting them on DVDs for security. Talk about frustrating.

I assume you are a 32-bit openSUSE KDE user ? Try starting amarok from a terminal with:

strace amarok 

There is a known bug on KDE causing this. Bug has yet to be fixed.

check the config driectory in the program you are using. If it is wrong in the config setup, then re-installing does not help because it just reuses the previous config which is NOT deleted when you reinstall the app. This is pretty much the case for all Linux distributions and not just openSUSE.

Reference your graphic driver, this is pretty much the case for all distributions, where a new kernel update will break a proprietary driver install. And in the case of some users with Intel graphic hardware all distributions (and not just openSUSE) are suffering from recent kernels causing problems the intel graphic driver on their PC.

Now NONE of the above may apply to you, but given the lack of details its pretty hard to guess exactly what you encountered.

I have this problem too. I’m using openSUSE KDE 32-bit and running starce amarok can launch amarok without crash.
Hope this bug can get fixed soon.

Ok, some details:
Wodim -v -checkdrive shows all capabilities including DVD+RW, DVD+R, so that indicates I can write to a DVD+. If I insert a blank dvd into the drive, the device indicator shows blank DVD+R inserted. K3B does not see the blank disk. This happened to me quite a long time ago, and I can’t remember what I did to correct it. I have been burning disks regularly over the last couple of weeks, and I haven’t changed anything, to my recollection, to interfere with the program.

here is the output from wodim -atip:

Detected CD-R drive: /dev/cdrw
Using /dev/cdrom of unknown capabilities
Device type : Removable CD-ROM
Version : 5
Response Format: 2
Capabilities :
Vendor_info : ‘HL-DT-ST’
Identification : 'DVDRAM GSA-U10N ’
Revision : ‘1.05’
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Supported modes: PACKET SAO

You could try removing/renaming your K3B configuration and restarting K3B from scratch.

Try this: with k3b closed (ie NOT running), if you are a KDE user, with dolphin navigate to ~/.kde4/share/conf and rename k3brc to k3brc-oldversion and also go to ~/.kde4/share/apps and rename the directory “k3b” to “k3b-oldversion”.

Then restart k3b and see if you have the same problem.

Yeah I tried that already and it didn’t help. If I open the Device/Media Info panel, it shows the dvd information. It indicates the dvd is empty and writeable, but when I open the burn panel, it doesn’t let me burn the dvd. It keeps asking for an empty dvd to be inserted.

Ok, I got it fixed. I had to re-set the device permissions. The funny thing is, I didn’t change them, I only confirmed the defaults. Eh, go figure. Thanks for the advice.

Ok I start from the begining. I opened Dolphin File manager- Super user mode. Clicked Red colored root icon.Then view hidden files. and opened .kde4 folder. within this are two folders:
1st: share and 2nd: tmp-linux-o26a
Now I opened share. It has one folder viz. config and a file viz. .directory.
And once I open config, it is empty.

In your user home directory not in root!

Yes, Now I found them all but the one file is still hidden from my eyes amarok_homerc. Its not present in the specified folder.
Thanks a lot.

If it’s not there OK
Once you have removed what are there. Try amarok again