Amarok is truncating output

I listen to some voice mail messages over the web. Firefox downloads the message as a “.wav” file, and then invokes amarok to play it.

What I have been noticing, is that amarok seems to cut the message short.

As an additional test, today after playing a message on amarok, I tried playing the same message with kaffeine. There was significantly more to the message when played on kaffeine. The particular message ended with the phone number I should call back (if I wanted to). None of that ending sentence showed in the amarok playback.

Is there a setting that would fix this problem? Or is it an amarok bug?

In Amarok, go to Settings / Configure Amarok / Playback (on the left) / General and un-select “Fadeout on stop”. See if that helps by chance.

Thank You,

That was already unselected. I think I had unselected that a few days ago to see if it would help.

As another experiment, I just reselected that, then changed the fadeout duration to the minimum (400 ms). That didn’t help either. Then I again unselected fadeout. Still no noticeable effect of that change.

I would play a regular MP3 song. Press start & stop and make sure sound stops at once. Then play a whole song through and see if you are losing the last part of your MP3 files. What version of Amarok are you using? Perhaps it is a problem with that version.

Thank You,

I don’t actually have any MP3 files - I’m not in the habit of listening to music on the computer.

I appear to be using version 2.3.0 of Amarok, under KDE 4.4.4 “release 2” - at least that’s what “about” tells me. I am using opensuse 11.3, and just using whatever installed.

So I am using Amarok version 2.4, but it is a pre-release version and I never had any problems with 2.3 either. I am thinking you will want to try a different player, even kaffeine if it works fine for you as you say.

Thank You,


I managed to find an mp3 file online. It played that to the end.

The “.wav” file stops at about 15 seconds from the end according to the play indicator. Playing voice mail from a different location (different voice mail software, still a “.wav” file), it typically stops at around 11 seconds before the end.

I’ll see if I can work out how to configure it to use kaffeine in future, at least for “.wav” files.

Just for testing, convert the “wav” file to MP3 and then play it in Amarok and see what happens.

How do I convert a wav file to mp3 (or are you just talking of renaming)?

You must install lame, for this example to work:

Use one of the following encoders:
Lame usage:

lame prefix-of-music-file_01.wav song.mp3 - Fixed 128kbs stereo encoding
lame -h prefix-of-music-file_01.wav song.mp3 - High quality
lame -f prefix-of-music-file_01.wav song.mp3 - Fast and low quality
lame -b 112 prefix-of-music-file_01.wav song.mp3 - Encode at a bit rate of 112 kbs
Just open YaST / Software Management and search on lame. If it is not there, you must add the packman repository located at:

Thank You,

Thanks. It turns out that “lame” was already installed. Incidently, I just used “which lame” to check for that.

I used the “-h” option to convert. It plays all the way through as an mp3 file (unlike what happened with the wav file).

So, mp3 files play properly while wav files do not. At least you learned a new commend with lame. You could always report a bug to the writers of Amarok to see what they have to say.

Thank You,