Amarok, hangs after about 6100 songs

I have a large music collection, over the last fifty years i have collected a few, and have worked to put all on my computer.

Now when I am using amarok it hangs after abut 6100 songs, just never completes scanning the collection. left it running over night, and it got to about 2 % farther, it just got slower and slower as the collection grew…

Any ideas, using KDE3

Are you using the default Amarok that came with SuSE?

When I install SuSE, the first thing I usally do is add the repositories, get media codecs and update Amarok. I have a 25,000+ song collection, and though when I scanned it it had to run over night, it was done the next morning.

  • ercoupeflyer,

check file permissions/ownership on the media files.


Hi Thanks, for your responses,

I check all permissions, and they are set to allow me full access as a member of the ‘media’ group., read only for everybody and full for owner(in this case user ‘Media’)

The total number of tracks for me are 24000, I don’t understand why it gets progressively slower. And left it for two days now, and its at 51%

Have a system core 2 with 2gig of memory… and amarok is the only app running on my desktop.

The problem too is that if I stop it, half way, nothing is in the collection at all. It needs to start from the beginning again!

Where do I point to to get the latest amarok, 2.0. Not sure how to do that…


Open amarok from a terminal window (just type amarok) - then add the songs.

I had the same problem with a corrupted MP3 that for some reason “hung” amarok back in the day - as opening it from a terminal reports all activity (debug) there, you can spot which file is causing the hang.

got the exact same problem here

Tried many different ways like delete the collection.db/scan files/log or re-installing amarok, or enabled MySQL.

It scans all mp3’s in my /home folder (on a Sata drive) but it hangs at about 46% when access my storage drive (120G fat formatted)

had some success when i manually check folders one by one and re-scan entire collection but that also fails after it scans 60-70%.(

I’m gonna switch fat for a Sata one,mount the drive,move my files there and rescan
Some ppl solve the prob just by re-installing.
Thats not my case. Rhythmbox scans the entire collection with no prob at about 5 min.

Hi, I tried to run from a terminal window, but the scan show 6% and nothing is displayed in the terminal window…

OK, where do I get the debug version of this thing?