Amarok error towards end of song


When playing songs in Amarok, I have an error towards the end of song. This is the error I have …

/usr/bin/gst-install-plugins-helper requires an additional plugin for this operation
file protocol source

Can someone know how to resolve this error ?

Thank You very much


Have you followed


I used the openSUSE Community 1-click install (as one of the option mentionned at your link). So the repos are configured

I already did a : zypper ref, zypper up, and zypper inr to be sure everything was up to date.

So nothing changed, same problem. Any other idea ? Can you direct me to a log file I can see what’s happening ?



I noticed that the message was appearing toward the end of the playlist, not a song. Just a clarification.

Thank You


I started Amarok from the command line and this is what I got …

QMap((“album”, “The Road Less Travelled”)(“albumArtist”, “Triosphere”)(“artist”, “Triosphere”)(“chosenByUser”, “1”)(“context”, “”)(“duration”, “291”)(“method”, “Track.scrobble”)(“timestamp”, “1391842552”)(“track”, “Echoes”))
** Message: PackageKit: xid = 44040445
** Message: PackageKit: Codec nice name: FILE protocol source
** Message: PackageKit: non-structure: gstreamer(null)(urisource-file)()(64bit)
" <lfm status=“ok”>
<scrobbles ignored=“0” accepted=“1”>
<track corrected=“0”>Echoes</track>
<artist corrected=“0”>Triosphere</artist>
<album corrected=“0”>The Road Less Travelled</album>
<albumArtist corrected=“0”>Triosphere</albumArtist>
<ignoredMessage code=“0”/>
Calling appendChild() on a null node does nothing.
QMap((“method”, “track.removeNowPlaying”))

By the way, I also got a lot of this error before …

QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted

That’s strange because the “file protocol source” should be included in the standard packages obviously. No need to install anything for that.

Maybe your package versions do not work together well?
Try to switch all your packages to Packman, see here:

Try to remove the gstreamer plugins cache by deleting the directory ~/.gstreamer-0.10/ .

If nothing helps, you can of course just switch to the VLC backend. You may need to install “phonon-backend-vlc” (included in the standard repos, so just search for it in YaST->Software Management). Then enter “Configure Desktop”->Multimedia->Audio and Video Settings (or click on “Configure Phonon” in Amarok’s settings->“Playback”). On the “Backend” tab move VLC to the top.
You should already have the necessary codecs for VLC, if not install the package “vlc-codecs”.


Removing the gstreamer cache (~.gstreamer-0.10\registry.x86_64.bin) did the trick, no more error messages towards the end of the playlist.

Do you have any idea why it happened ?

Thank you very much for your help


No, sorry.
And I never had to remove the cache ever myself.