Amarok doesnt play mpeg-4 aac

I am in the dark as to which codec to install to fix this
11.4 kde
Thanks a lot


SDB:Problem with MPEG-4 AAC plugin for gstreamer - openSUSE



You refer to this solution


There are conflict in packages versions. If you have added VLC and Packman repositories, they contains different versions of some gstreamer plugins. Zypper/YaST installs by default the newest one, but in this case it installs different version of gstreamer and it’s plugins.

I recommend you to do this:

  • disable all VLC repositories using YAST

  • add a Packman repository (

  • go to Software manager, click on left-top menu and select Repositaries. Then Click PackMan repository and finally on “Switch installed packages to the version in this repository”

  • Click on apply and wait few minutes. It should work now (after restarting Totem/Banshee player).

“Switch installed packages to the version in this repository”

I can find this option nowhere! What to do?
Thanks, I appreciate your help!


Yast -> install/remove software

Use the repositories tab and select the one for packman…
The, above the list of all files in that repository, you can find this switch.

(I’m presuming you use the KDE version of Yast).



I re-worked that wiki page since it looks like it was written in a hurry, and contained an incorrect instruction (adding the Packman repo using a URL which only works for 11.3).

The instructions should make more sense now: SDB:Problem with MPEG-4 AAC plugin for gstreamer - openSUSE

Thanks but inder the Community Repositories there is NOT a Packman repo!

What now?

YaST > Software > Reositories > Add
select "Community Repositories
> Next
select “Packman Repository”
> OK > OK

Multimedia in One Click

Some more detail can be seen here
Multi-media and Restricted Format Installation Guide

Switching pics can be seen here
KDE Yast:
Gnome Yast:

Both links under:

Additional Repositories You will need:

are for the 11.3 repositories.


I did this and now I have somehow swithced to xfce how do I get kde back?

**** you SUSE! I will win in the end!!!


At the login screen (auto login must be disabled)
Select kde-plasmaworkspace as the session

Perhaps you better show us your repo list

zypper lr -d


I made a mistake (again!!!) it is not xfce but I think ice wm or some such thing!

Also at the login there is no option to choose another shell
I get to suse wuki or some such thing!

I am posting this via windows as all the option in ice wm dissapeared when clicking on SUSE WIll go and try again!


PS I ran the zypper command but in xterm there seems to be no way to copy the output neither control+A, C etc works after selecting the text with the mouse Also tried a print screen!


thanks we will get there!

It sounds rather messed up to me.
I can see your inexperienced position leading to a re-install.

If you can boot to IceWM and start Yast (You use right click in IceWM to get a menu)
Check and see if you have the Pattern kde-base and kde-desktop installed

You can click the check box to re-install if necessary

Thanks Caf
Followed your one click solution and it seems to work!

Lesson learned