Amarok collection problem

Whenever I try to scan for my music collection, it scans all my files, but the local collection just displays counting. I know this is a mysql error so I reinstalled that and it still doesn’t work. If I go into my amarok data folder it has my collection file in it and it does indeed list all the files in my collection. I even went as far as installing mysql from the build service, still nothing.

why did you install mysql from the build service? It is known to have problems and changes which further can complicate things. Have you tried completely dumping your Amarok DBs and then starting the collection process all over again?

I get thisproblem, and I have changed nothing in amarok2. I cannot complete the building of a modest collection, it always gives up at around 60% of the scan. I have a feeling this is similar to a problem with amarok and collection build in M1. It wouldn’t be the first time the devs have brought back an old bug in a later release.

If you run M4 then just install amarok from the 11.1 repo. From the Factory KDE repo mine was showing counting all the time. Installing mysql won’t work.

BBR, or wait for all of M5 (i.e. the director’s cut) ;), unless you are using it for your daily fix :).