amarok 2 under 11.2 M5 64bit dosen't play mp3

I find out some posts regarding to 11.1 telling me I have to install libxine1-codecs from packman to solve this problem, but I can’t resolve dependices (

I’ve got installed:

Amarok play format another than mp3. Another programs e.g. SMPlayer plays mp3, but amarok don’t :frowning:

Anybody know how to solve it?


Packman’s libxine1-codecs is the solution. If there are dependency problems you’ll have to keep on using SMPlayer.

The thing to know is how the different pieces of software are related. SMPlayer is a front-end for MPlayer, which has its own built-in codecs. Amarok relies on KDE Phonon back-ends. There are two back-ends so far, Xine & GStreamer. If those back-ends lack the codecs, every piece of software that relies on them will lack codecs.

So as it stands right now, every proper KDE4 app on your desktop will lack the ability to play certain files. Either wait for the 11.2 Packman repo to start or continue using SMPlayer (I’m using VLC myself, they already have a 11.2 repo).

I removed mplayer+smplayer and install VLC instead, but it still returns the same error.

No one package provide which is required by
And the only solution I have to select is: do not install libxine1-codecs. So I guess that there is no problem kind of one package interferes to another one but problem with providing package dependence.

I search in yast for libcdio and I only found libcdio10, not 7.

I don’t like to use GStreamer because it always makes problems. Xine always works perfect for me.

Perhaps I wasn’t clear enough in my explanation.

As far as codecs goes, Amarok is totally separate from VLC and MPlayer. It doesn’t matter if you have MPlayer, VLC or both installed - they will not change anything concerning Amarok.

The dependency chain for codecs in Amarok 2 is like this:
Amarok -> Phonon -> Xine (or GStreamer)

If Xine lacks the codecs, Amarok will not be able to play the file.
If GStreamer lacks the codecs, Amarok will not be able to play the file.

That dependency chain is the same for any proper KDE 4 application. That means JuK will not be able to play MP3 files either.

Since you cannot install the codecs for Xine, your options are:
A) Go without MP3 files
B) Use GStreamer and get the appropriate codecs for it
C) Use a different program that comes with its own codecs to play MP3 files

If you select C, your options are MPlayer or VLC. No matter which one you choose (MPlayer or VLC), Amarok will not gain any codecs. The idea here is replacing Amarok, not finding a way to enhance its abilities (which is what the libxine1-codecs package would do).

Sorry @ReferenceSeete I wrong understand what you said, my mistake.

A) My intent is to use 11.2 M5 as primary OS so I have to be able to play mp3 files.
B) Well, before I created this thread I try to play mp3 via GStreamer (I put GStreamer over xine in Phonon playback chain) and it dosen’t work.
C) Amarok is my favorite one. I wolud like to use it if that is possible. So far Im using SMplayer/VLC instead of Amarok.

Have I got any other option to make GStreamer works or satysfied Xine dependence, to be able to use Amarok?

Thanks for help

If you want to try GStreamer with Amarok, then you’ll need the following packages:

[Make sure you get the Packman versions of the 'gstreamer-0_10-plugins-**** packages]

You’ll also need to change the settings for Phonon’s backend.
Open System Settings (called “Personal Settings” in the menu).
Select “Multimedia”
Select the “Backend” tab
Make sure that “GStreamer” is preferred over “Xine”

Your preference for Xine over GStreamer is well-founded if you are a KDE user, however this is the best chance for MP3 support in Amarok if libxine1-codecs cannot install for you.

I hope this solution works for you.

Same problem here, cannot upgrade libxine1 or install gstreamer plugins from packman.

nothing provides needed by
nothing provides needed by

Mplayer runs everything so I don’t mind.
This will probably get fixed once packman builds a 11.2 repo.

If I try to install gstreamer-0_10-plugins-ugly from packman yast throw me the same error as like for libxine1-codecs - missing As for gstreamer-0_10-plugins-bad (also from packman) there is missing

YaST don’t throw any errors if Im install versions from openSUSE-11.2 repo. However it dosen’t works :frowning: I don’t forget to set GStreamer over Xine.

@finders I see you’ve got i586 OS, You may try to install gstreamer-0_10-plugins-* from openSUSE-11.2 repo instead packman and see what happen on i586.

That fixed the sound in amarok, cheers.

only in i586, unfortunately not in 64bit OS.

Here’s a real solution:
Leave all as it should be, i.e. codecs etc, except for Amarok itself, replace that by the version available for 11.1 (something wrong with MySql )
The way this all is done, will come back to you, for instance when you want to install another 64-bit mediaplayer, with 64-bit depencies.

If I would downgrade to amarok2 from 11.1 repo then also have to downgrade kdebase and lots of diffrent packages.

The option is to use amarok 1.4

The solution is to add temporarily 11.1 repo that contains that package. Check what is the difference between the same package in 11.2 OSS and 11.1 . Try to install the 11.1 package to install the rest from Packman (libxine-codecs), after that upgrade the package you installed from 11.1 and create a symlink to the updated version and call it properly.

Im give up with amarok 2.

I installed amarok 1.4 from 11.1 repo and xine supprot from packman and it works great for me.

I manually installed the following packages on my x86_64 Factory installation:

after that, i was able to install xine-codecs from packman - so mp3s are playing fine now in amarok… rotfl!

Anyone with a decent solution for this with milestone 7?

The plugins ugly/bad from opensuse (instead of packman, as the packman ones wont install) do not work.
And not having much luck with alternatives as it wont let me install Audacious either. (missing

There are two in fact.

  1. Wait until packman offers packages for 11.2

  2. Rebuild the respective src.rpms from packman against your M7 (and hope they will compile)

“Wait until packman offers packages for 11.2”

packman 11.2 repos are available now: Index of /suse/factory

Here is the solution to various codecs problems with Amarok 2 (for 11.2, I guess the same exists for other opensuse’s versions):

Restricted formats for 11.2

Worked for me!