Amarok 2 dependenses

Hi ! lol!

I’ve added to my repositories the updated stable sources for KDE4 :

Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.0

It permit to install Amarok 2 in its final version.

But when I select kde4-amarok, 2.0-1.4

I have the following error message :

kdebase4-workspace-4.0.4-24.6.i586 requiert kdebase4-runtime < 4.0.60, mais cette dépendance ne peut pas être fournie
fournisseurs non installables: kdebase4-runtime-4.0.4-20.1.i586[http://download.opensuse.org/distribution/11.0/repo/oss/suse]
kdebase4-runtime-4.0.4-20.1.i586[repo-oss]
kdebase4-runtime-4.0.4-20.1.i586[openSUSE-DVD 11.0]
] ne pas installer kde4-amarok-2.0-1.4.i586
] désinstallation de compiz-kde4-0.7.4-31.2.i586
Ignorer des dépendances de kdebase4-workspace

Do I need to uninstall compiz-kde4 to install this softwate?

And why the error message is talking about kdebase4-workspace-4.0.4-24.6.i586 ?

Thanks for your responses.

Go to Yast -Software Management
filter by repo
select kde4 stable desktop
check to see if there are red or blue coloured packages.

If there are do update all in this list unconditionally.

The repo you are using is now kde4.1.3 and the package you quote is 4.0.4 (old) needs updating.

Thank you for your response.

I have updated kdebase4-workspace-4.0.4-24.6.i586 and installed amarok 2.

Since the installation, auto updater says that fileshareset is not up to date, (kdebase3: Collective Update)
but i can’t update it and the package kdebase3 isn’t installed.

can i keep amarok 2 and update my system?

Don’t use the auto updater. And there is a bug that causes that fileshareset update.

Use Yast - Software - Software Management
Filter by Repo
and work through each repo and update

Ok I’ll wait for the problem to be solve. Thanks.

Cendre_55