amarok 2.5 issues

I just installed the new amarok 2.5 from kde updated apps repository. I have 2 issues with it:

  1. fetch fonts is broken. It seems that after the install, there was no longer a script installed to fetch the fonts. I then tried to install the ultimate lyrics script, and now amarok is trying to fetch the lyrics during playback. But it never finds any, and my mp3 tags are filled in ok. This was no problem in amarok 2.4
  2. video applet is still broken. When I click on a youtube video it goes straight to the next song in my playlist. The video itself never plays, even when I select it again in my playlist.This has been broken at least since amarok 2.2. Am I doing something wrong since I do not understand how a plugin can be broken over 3 new major updates… Do I need to install something?

Well, I too have the same issue with Amarok 2.4.3, KDE 4.7.4 :-/ But I never noticed 'cause I don’t like music videos a lot :wink:

Somehow they wiped the scripts from the Amarok package. The only way to fix this is to download the source package here and copy the contents of src/scripts to /usr/share/kde4/apps/amarok/scripts.

No, no, no, forget that; it won’t work. The issue is that they dropped qt4-qtscript from the dependencies list and, as a result, scripts are disabled. You’ll have to re-build the RPM with qt4-qtscript installed to have scripts working again.

Ok I understand. But I don’t think it is my responsibility to rebuild the rpm. The maintainer of the KDE-updated APPS should do this…

And what about the video applet? Does it work for anyone?

Well, it’s the only solution for now. You can try and report a bug against the package in Build Service.

The amarok package there is inherited from KDE:Distro:Factory, which uses a newer version of Qt and where qt4-qtscript is unavailable.

I don’t use the video applet, but if the only impediment for it to work is the absence of scripting support, it might work after rebuilding.

You might try the packman built version of AmaroK 2.5, though I don’t know if it will make any difference. Why did you upgrade initially by the way?

Hi, just jumping in as I have got the same issue with the Packman build as well

rpm -q -i amarok


Name        : amarok                                                                                                                              
Version     : 2.5.0                                                                                                                               
Release     : 18.1                                                                                                                                
Architecture: x86_64                                                                                                                              
Install Date: Sa 21 Jan 2012 08:10:18 CET                                                                                                         
Group       : Productivity/Multimedia/Sound/Players                                                                                               
Size        : 33662880                                                                                                                            
License     : GPL-2.0+                                                                                                                            
Signature   : RSA/SHA1, Di 17 Jan 2012 22:25:10 CET, Key ID 45a1d0671abd1afb                                                                      
Source RPM  : amarok-2.5.0-18.1.src.rpm                                                                                                           
Build Date  : Di 17 Jan 2012 22:05:15 CET                                                                                                         
Build Host  : ccbpm2                                                                                                                              
Relocations : (not relocatable)                                                                                                                   
Packager    :                                                                                                              
Vendor      :
URL         :
Summary     : Media Player for KDE
Description :
Amarok is a media player for all kinds of media. This includes MP3, Ogg
Vorbis, audio CDs, podcasts and streams. Play lists can be stored in
.m3u or .pls files.
Distribution: Essentials / openSUSE_12.1

None of the scripts seams to work. Only the the “Radio Germany” gives an error message that QPixmap variable cannot be found. Lyrics, recordstream etc. dont give any message but dont work. was used to see settings entries in 2.4.3 but none of the scripts will show up in “Extras” and “Settings”.

Maybe this is a generic bug then and not necessarily related to the openSUSE builds.

EDIT: Just in parallel found an entry in KDE forum which should clarify…

I have the same issue, I rolled back to 2.4.3 (it’s in the openSUSE updates repo) and locked the package so it’s not updated. It’s not a real solution but at least for now I have the scripts back. Maybe it’s fixed in KDE 4.8, I haven’t tried it. Has anybody filed a bug report?
About the video applet I have never tried it.

Video app works fine in 2.4.3

Great! Now can you give more details on what you have installed/configured to have this working? From what repo did you get this working version? I tried 2.4.3 from packman repo but doesn’t work.

What phonon backend are you using? If gstreamer, did you install a special plugin?

On the kde forum: it seems that many others have issues with this applet for a long time, and still it has not been fixed. :frowning: Very strange it works for you then :wink:

Hello, I’m sorry I lost this.

I haven’t done anything in particular, I believe the script (videotab) is installed alongside AmaroK by default on OpenSuSE. I am running OS 12.1 with the default KDE and AmaroK from the default oss (or rather the update) repo.

I did a check playing youtube videos but that script, which I installed manually with the script manager, did not work for me either, however, the video applet works with local videos.

I use xine, by the way, but I suppose it was the youtube script which was important not the video-tab itself:)