Amarok 2.2.1

What happened???
I used Amarok before and I loved it, now IT TELLS ME I have no Bob Dylan, and even when I take it by the hand and show it where the Bob Dylan is, it refuses to play it. Instead it presents lyrics to songs I am not interested in. Did the Amarok people all decide to take drugs at the same time?:open_mouth:

Are there any specific differences in file type of Bob D?

Hei,

I actually have a similar problem. I have songs in my collection which do not play in the new Amarok but played fine in 1.4xx. The one file(song) I tested has not been destroyed as I tested it with kaffeine which played it nicely. Though, I have to say, Kaffeine is another application which is far worse in kde4 than in kde3. I hope it will improve, I really liked Kaffeine.

I am not at home now, but shall try to look into it later. I know the file I tested was .ogg, but I rather think it has to do with something else than that.

Except for them being by Bob Dylan, no! I have more or less the complete works, Amarok cannot find a single track, even when gently guided to where they are.
(Don’t waste any valuable brain time on this CAf, I need to do some serious hammer work on Amarok, it is not just Dylan, but most music which is fubarred ATM, I will post a proper query if (when) I need help :slight_smile:

I am also having some serious problems with Amarok under 11.2 x64.

Firstly, it seems to randomly put some songs under various artists. Even when I select to not have them displayed under various artists, it will eventually put them back there, probably when it next auto-scans the library.

More seriously, when I use Amarok to organise my collection, it causes irreversible damage to the files. I’ve raised a bug at

http://bugzilla.novell.com/show_bug.cgi?id=559016

I still need to do some testing - I’m at work at the moment - but I need to check whether it is actually corrupting the tags in the mp3s. What it definitely IS doing is removing the file extension for non-mp3s. When you have a library of a few thousand tracks originally created in iTunes, this is a major flaw.

The effect is that my library looks much smaller in Amarok than it really is. As all the m4a’s are not listed. I’m not sure if this is also the case with ogg files.

I like the direction that Amarok 2 is going, but this version (at least on my system) is very flaky.

Hmm, I just fired it up again. it still can’t find Bob Dylan. Also it had muted itself, not in Kmix or any other accessible way, but inside Amarok. Muted, no sound nada. I am a patient man, and I LOVED amarok under 11.1 (1.4.1) but this is hopeless, rubbish, broken and should never have been shipped as working software.>:(

and now it won’t stop. I stopped a track, went out out of the room, it was playing again. (Not a track I had chosen, or wanted to hear, just a track Amarok had decided to play…)
I then decided to close the progam, right click on panel icon, quit…
Nope, still there, try again, no response at all from panel icon.
I have to KILL from a console…
As I say, hopeless, broken, should never have been bundled as default with KDE.

And the fade in/out function only works now and again.:wink:

I managed to have Amarok play one of the files it previously refused. I am not precisely sure what was the solution, I both re-taged and changed the name of the file. I tried to rescan (music library) after every change, however, there was no luck before i restarted Amarok. Then it was fine.

I did not have any similar issues with Amarok on kde3, so if you haven’t got Amarok playing your Bob Dylan collection yet, maybe you could try clean up possible bad tags or names.

Add 11.2 KDE 3.5 repo, install Amarok 1.4. Rejoice.

Yes, I saw that packman had an Amarok repo for kde3 as well.

On Tue, 01 Dec 2009 10:16:01 GMT, F Sauce
<F_Sauce@no-mx.forums.opensuse.org> wrote:

>
>Hei,
>
>I actually have a similar problem. I have songs in my collection which
>do not play in the new Amarok but played fine in 1.4xx. The one
>file(song) I tested has not been destroyed as I tested it with kaffeine
>which played it nicely. Though, I have to say, Kaffeine is another
>application which is far worse in kde4 than in kde3. I hope it will
>improve, I really liked Kaffeine.

Well Hell. I used to bitch that OpenSuse 11.X was not ready. As time
want by i realized that KDE4 on OS11.X was not ready and changed my
tune. Currently KDE4 on OS11.2 is nearly there, I can see that
SLED/SLES 11 will be really nice. But there is about 6 months to go.
And accordingly terminating support for OS10.3 is about 6 months
premature.

i use amarok a long years ago
i have a very old amplifier Sansui AU6900 with roister phones
it is the first time that i hate amarok >:(
the new version 2.2.1 is not ready to use the voice is so bad, not
libvisual,not equalaizer

;)an easy way to install again amarok 1.4
open YaST2
first remove from list the amarok 2.2.1
then
go to Package Search (webpin)
to Search Expression write amarok 1.4 find it
then you find all version check only that version 1.4
install it
you finish
you have again the best audio!!!:wink:

Just got mp3 play back working in Amarok 2.1.1, what a pain that was. After a collection scan none of my albums have cover art. Not using the Amazon interface my art is included in each track.

I also notcied that the Wikipedia lookups fail because Amarok is adding (band) to the search. Go to wiki and search for bob rivers and you get his page. Search on bob rivers (band) and you get a what do you want page.

I have seen a few complaints about KDE4 in the forum. I think the KDE team has either removed or moved functionality to make it look pretty, kinda of like what MS did with Vista.

Dave

I have tried both Amarok & Kaffine and neither work for my mp3’s on my windows partition. On the other hand, to my surprise, VLC plays everything fine and was set as the default player after installation. I really liked Amarok before, I hope someone can figure a fix.

dwestf <dwestf@no-mx.forums.opensuse.org> writes:

> Just got mp3 play back working in Amarok 2.1.1, what a pain that was.
> After a collection scan none of my albums have cover art. Not using the
> Amazon interface my art is included in each track.
>
> I also notcied that the Wikipedia lookups fail because Amarok is adding
> (band) to the search. Go to wiki and search for bob rivers and you get
> his page. Search on bob rivers (band) and you get a what do you want
> page.
>
> I have seen a few complaints about KDE4 in the forum. I think the KDE
> team has either removed or moved functionality to make it look pretty,
> kinda of like what MS did with Vista.
>
> Dave

Thats a shame, I was looking forward to the new Amarok, I like the old
version, but it does look a bit dated.

Still, I’m not installing for a few weeks, so maybe it’ll be working by then.


Regards,
Barry Nichols

Kaffiene and amarok both use xine for the backend.You need to install libxine1 from packman. See this article: Restricted Formats/11.2 - openSUSE-Community


Thank you for the reply but it would not install libxine1-codecs and gave me no alternatives. It does no different than before with the rest of the install even if I copy an mp3 to my home folder.

You need to follow this Carefully!

Multi-media and Restricted Format Installation Guide - openSUSE Forums

Take note of this:
ImageBam - Fast, Free Image Hosting and Photo Sharing