Amarok 2.0 needs MySQL for collection

I have had to install MySQL in order for Amarok 2 to have its collection and playlists function properly has anyone one else noticed this!!

Read this: “In the beginning” - Amarok 2.0 released | Amarok](
and search for ‘MySQL’ in it.

Perhaps you have misunderstood my point. Something is missing in the install, so that the playlists are not working untill you install MySQL.

The problem is that I needed to install something else before the programm functions.

libmysqlclient was installed but something was missing.

You mean the dependancies were not correct.

That may be worth a bug report with Amarok or KDE.

Your question was: has anyone one else noticed this.
I can not tell, because I am not anyone. Personaly I did not, because I did not install Amarok2.
I could not read from your post if you had to install MySQL because of YaST asked you to confirm installing it due to dependancies, or of you had to find out by yourself.
What I read behind your very short post was a bit of amazement and I tried to help you by referring to the place where Amarok tries to explain what is going on. This because I remembered to have read about it in their release anouncement.

My fault I have a tendency towards short posts, which has its origins in my poor typing skills and three small children who are currently at home…

There you go a real bug! The solution is simple enough though.

I tried to contact people responsible for building amarok 2 from KDE:KDE4:STABLE repository but no one answered and the person that answered says he is not responsible for software but the community. And i agree about the solution although it’s as simple as marking additional dependency in Amarok which is plain simple.

Yes, you are not on your own. I hope this is solved in the near future before the 11.1 hype starts :wink:

Your “solution” is a work-around but not the right fix for an update.

You have obviously have some strange kind of expectation seeing your bombarding of random people with messages during week-end.

First, it’s not just for me
Second how come this is a workaround? (Amarok should have mysqle inside it?)