always need two attempts to run online update

Hi

when I run online update, opensuse 12.3, I get a ‘server inaccessible’ message, but it works OK when I click ‘Retry’. This happens for each repository. If I try later in the same session after this, it will connect at the first attempt.

The same happens for Thunderbird email but not in a web browser.

This happens with both wireless and wired connections, so I guess it is a system setting but I don’t know what. Any advice gratefully received.

Thanks very much.

On 2013-09-01 19:46, hehebe wrote:

> The same happens for Thunderbird email but not in a web browser.
>
> This happens with both wireless and wired connections, so I guess it is
> a system setting but I don’t know what. Any advice gratefully received.

What sort of network are you on? Business, college, any corporate thing,
perchance?

Another wild guess: you have two DNS defined, and one does not work.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

What type of internet connection are you using? Do you have a static IP address or are you using one assigned by DHCP? You might need to increase the “Time to Live” for your packets. Just a guess without further info.

Are you using ifup or Networkmanager?

I have had this happen with ipv6 enabled in the past so could be worth trying.

Go to YAST - Network Devices - Network Settings

This will bring up your networks cards. Select the one used for the internet - usually eth0 if you have more than one and click edit… You will see a drop down button that offers DHCP 4 only DHCP versions 4 and 6 and DHCP version 6 only. Select DHCP 4 only and then next etc.

If you are using google ipv6 dns services change it - try the auto one from your isp. Most routers offer that option. Or set one of the free ones if that one proves to be a bit slow at times. At one point I used my isp’s dns service that was provided specifically for gamers. Another option to try if there is one available.

IPV6 can be a bit of a nightmare for “home” users. Last time I looked into the subject that level of ISP had no intention of offering it. However they may have started to offer something that goes by the name of IPV6 tunnelling. This allows IPV6 to travel over IPV4 networks and probably allows it to work. Obviously though it’s likely to be slower than a normal connection and might not even be there.

Out of interest pre window 7 and 8 they appeared to look to see which was best and set it accordingly. They may do that now every time a machine is connected but it would slow things down if they do.

Personally I am not happy about this area on 12.3. I am now fully IPV6 capable and find that my zeroconf set up offers ipv6 versions of everything and my printer will use it directly as well. The printer is another problem but there doesn’t seem to be a single way of ensuring the system never uses ipv6.

:|At least the current 12.3 set up is better than it was. This goes back to even suse.de pre Novell when they set it as the default and expected all isp’s to offer the service so most people found that yast woudn’t work at all or did and didn’t etc. I managed one update with the suse.de release. Shear luck I suspect. My isp has since been bought up by one of the bigger companies.

Taking another quick look re “home” isp’s sounds like little has changed - notice new subscribers is mentioned at times. One problem for them is that the larger address space takes up more bandwidth = less users unless they add more equipment.

UPD UK ISPs Respond to Readiness Fears on World IPv6 Launch Day - ISPreview UK

I have read that this site will only use IPV6 so could be used for testing

http://loopsofzen.co.uk/

I just tried it with ipv4 or 6 enabled and just get a browser error. Konq gives the best error message - connection refused.

John