alt+f2 or ctrl+alt+f* keys not working

Hi all

I’ve got the latest everything on OpenSuse, been away so haven’t used it since i updated it

On today and I noticed straightaway that alt+f2 isn’t working, when i try to alt+f10 i notice that nothing attached to these f keys are working

Has anyone seen this as well?

Works fine here: Alt+F2 opens krunner, Ctrl+Alt+F2 switches to VT2.

I suppose you mean switching between the VTs with Ctrl+Alt+Fn doesn’t work.
When did you do the last update?
I have seen this before under certain circumstances, but the plymouth update released last Monday should fix that.

Or do your F-Keys not work at all?

last update was on starting up today

reckon the F keys mightn’t work at all, just tried refreshing with F5 and nothing

Try running “xev” in a terminal window, do you get any output when you press a function key?

Maybe a hardware issue?
Or some keyboards have a “Fn” key which you have to press to activate the function keys…

I get output but a bit dodgy, pressing ‘e’ then ‘f1’ in the snippet below, is the lookupstring relevant?

KeyRelease event, serial 42, synthetic NO, window 0x4200001,    root 0x291, subw 0x0, time 3504193, (595,866), root:(600,892),
    state 0x10, keycode 26 (keysym 0x65, e), same_screen YES,
    XLookupString gives 1 bytes: (65) "e"
    XFilterEvent returns: False


KeyPress event, serial 42, synthetic NO, window 0x4200001,
    root 0x291, subw 0x0, time 3506233, (592,866), root:(597,892),
    state 0x10, keycode 146 (keysym 0xff6a, Help), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

edit: yeah it’s always worked with this keyboard though unless an update killed it, it’s some microsoft keyboard with the kinda multimedia keys no one ever uses but the basic stuff has always been fine

So it’s recognized as “Help” key instead of F10.
Especially with Microsoft keyboards I have seen the Fn key which you have to press to switch the F-Keys to their F-function.
Look for a key labelled “Fn” and press it, your F-keys should then be recognized as F1-F12 (maybe a LED on the keyboard will switch on or off then like for Caps-Lock).

Sorry, the key is called “F-Lock”.
See also: F-Lock - Wikipedia, the free encyclopedia

Did I miss something. On what openSUSE version and what desktop environment are the posts i n this discussion based? :stuck_out_tongue:

Well, if it is indeed because of the F-Lock key (and I really think so because his F1 key is recognized as Help), it doesn’t matter and would be the same in any operating system and DE (even on the BIOS screen):wink:

But at least he did say:

Although that’s not very concrete…

got the latest everything on OpenSuse

It indeed isn’t concrete. Some people could argue that this means 13.1 MS3 at this moment in time.
In any case this is a very bewildering remark for somebody reading this, say, next year.

I always wonder why people take the trouble to type such useless expressions where the simple truth: 12.2 is much shorter, clearer and ready for the future.

And even when the problem is independet from a desktop, the OP did not post he did this outside a desktop. And when he did it inside, he should have told us, All pieces of information that are obvious to provide help in a quick and correct bug resolving process.

Karma to wolfi, I’ve never even noticed that button before, cat must’ve hit it!

and hcvv, point taken, you don’t have to labour it. That last bit is demonstrated by the bit under my name saying “Newcomer”. i know now, ok?

on this forum i usually find the sense of community and nu-friendliness from linux is constantly let down by someone with “mod” somewhere near their name

We not only try to be friendly, but we also try to make these forums as usefull as posible for everyone that visits, member or not (often landing by e.g. a Google search). And that means that technical threads should be consistent, precise and exact, contain all that is needed and hopefully have a solution that does not only work, but where it is also logical that this is a correct solution (and not a by-pass).

It is not a case of: when the OP is satisfied, that is all there is folks. Also an OP should contribute to making a thread usefull for others. We are a community.

And when you want to talk about other things, not technical, there are some sub-forums in Community and Fun for that.

if you look at my previous threads you’ll see i always post what the problem and solution was, even if i solve it myself, it’s just manners

say a contractor manages to get a government firm to use linux, do we expect all these windows users to be goggling the version or the symptom? same for any windows user who their son/tech support guy combo manages to get them to run

(i do use HP-UX at work btw and therefore linux is still a bit alien to me and obv i never use fn keys in unix. yes i forgot the version but i assumed that such an issue would be big enough. also i was possibly drunk)

and FYI, as a rule i’m going to say it might be safe to assume that “latest version” by a newcomer means “latest available to joe public on standard respositories”

thanks for that completely irrelevant information! why don’t you tell me the unladen airspeed of a swallow next

Let me warn once: as per T&C personal attacks are not allowed. And will not be allowed.

Thanks again wolfi

On 2013-06-23 21:36, TheBloodyNine wrote:
>
> Jesus fine.

They just want you to state clearly what openSUSE version you use, and
what desktop, that’s all. Just say it and don’t argue, it is not a state
secret, is it? :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)