Alt+F2 not working with Emerald decorator

Hi,

The shortcut Alt+F2 will not bring up a run dialog since I set Emerald as my window decorator. I’ve tried the following but to no avail:

In ccsm -> General Options -> Key bindings I made sure that Run Dialog shortcut is enabled and set to Alt+F2. Also, in KDE Control center -> Keyboard & Mouse -> Keyboard Shortcuts, the Run Command is binded to ALT-F2 so that can’t be the problem.

So I tried this instead:
In ccsm -> General Options -> Commands, I set commandline0 to “dcop kdesktop KDesktopIface popupExecuteCommand”
Then I set its key binding to Alt+F2. Then disabled the Run Command shortcut mentioned above. Still to no avail.

I’d really appreciate any suggestions on how to solve this.

Regards,

sabatier

sorry to bring up an old thread, but i have the same problem here. any fixes?

Hi,

In the CCSM under General (compiz 0.7) There’s a tab that says commands. For command line 0 type
krunner

then click the keybindings tab and set Run Command 0 as alt+f2

if you already have the Run Dialog enabled there will be a conflict so you just click Disable run Dialog.

For compiz 0.8, in the CCSM under Commands set Command Line 0 as
krunner

You’ll also have to set up ksnapshot so set Command Line 1 as
ksnapshot --current

Then click the keybindings tab and set Run Command 0 as alt+f2 and set Run Command 1 as your print screen button.

Hope this helps!

Ian

I have the same problem now on openSUSE 11.2. In gtk-window-decorator alt+f2 works fine (with compiz) but not in emerald. Since I have gnome, I don’t have krunner. So, how to fix this in gnome?

Sorry, but I have to say: BUMP.

What is Alt+F2 supposed to do? I’m a KDE user and there it opens a dialogue
that lets you type in the name of a program you’d like to run. If it’s
supposed to do the same thing in GNOME it may be possible to configure it
manually in the Gnome equivalent of kcontrol (or whatever they’re calling
it now in KDE4) :).

I know, not really helpful, but at least another bump for the issue. :slight_smile:


kev.

I also don’t know what is the command for gnome run dialog, but maybe gnome-do will fit you? Or gmrun.

Thanks for the answer! Yes, it is supposed to open gnome run dialog, which opens with gtk-window-manager or metacity window manager, but not kde. My gnome hotkeys have alt+f2 to run dialog and compiz settings have alt+f2 for run… gnome-do doesn’t work properly for me, and I don’t like it either. Gmrun is not a recognizible package.

Any thoughts? I have yet not figured this out. Bump.

I have waited too long for answer. Maybe I should give up and use gtk-window-decorator for now on…NOT! BUMP.

Sorry, I’m not a Gnome user but I’ll try to help.

Could you please open a terminal and provide the output of:

rpm -qa --last "*compiz*"

Take Care,

Ian


[22:20:30] rolle@peikko:~$ rpm -qa --last "*compiz*"
compizconfig-settings-manager-0.7.8-7.1       to 12. marraskuuta 2009 22.39.43
python-compizconfig-0.7.8-2.1                 to 12. marraskuuta 2009 22.39.42
libcompizconfig-0.7.8-8.1                     to 12. marraskuuta 2009 22.38.42
compiz-manager-0.0.1_git080201-60.2           to 12. marraskuuta 2009 22.38.42
compiz-fusion-plugins-main-0.7.8-14.1         to 12. marraskuuta 2009 22.38.28
compiz-0.7.8-43.44.1                          to 12. marraskuuta 2009 22.33.23
compiz-gnome-0.7.8-43.44.1                    to 12. marraskuuta 2009 22.27.49
compiz-branding-openSUSE-0.7.8-43.44.1        to 12. marraskuuta 2009 21.46.33
compiz-plugins-unsupported-0.8.2-100.11       pe  6. marraskuuta 2009 01.33.11
compiz-plugins-dmx-0.1.0-8.9                  pe  6. marraskuuta 2009 01.33.09
compiz-emerald-devel-0.8.2-2.8                pe  6. marraskuuta 2009 01.04.15
compiz-emerald-0.8.2-2.8                      pe  6. marraskuuta 2009 01.04.11
compiz-plugins-extra-0.8.2-102.7              pe  6. marraskuuta 2009 01.00.11
compiz-plugins-main-0.8.2-100.13              pe  6. marraskuuta 2009 01.00.04
compiz-bcop-0.8.2-2.1                         pe  6. marraskuuta 2009 00.02.15

Well, first off you have a mix of packages, which would account for some functionality missing.

I would remove all of your compiz packages and any compiz repositories you may have added. Then follow this how-to guide for installing the newest compiz.

Installing and Configuring Compiz - openSUSE Forums

And remember, if it gives you any conflicts, you always want to go with the option that chooses to install the most up to date compiz (i.e. install compiz 0.8.2, or do not install compiz 0.7.8)

Take Care,

Ian

Hello,

Thank you very very much! It works now. First I removed and killed everything with name compiz, and then installed it with your tutorial. I installed it also before from official opensuse compiz-site but I don’t know what went wrong.

Thanks, you are a lifesaver.

Rolle

Glad it worked for you! Sorry it’s taken so long to give you an answer.

Take Care,

Ian

Hey I have found another way to fix this, perhaps it will help someone …

I simply went to CCSM and in the General section I checked off the Gnome Compatibility icon and boom it works, you may note that if you click on it there are 2 options in it and one is … yep … alt/F2 … yeah!

I ran into the problem again and thought a re-install of compiz would clean up my messy repository install, and sure enough …

…alt+f2 works fine (in KDE at least)