Alsa-update repo changes (temporary?)

In case anyone else is directed to, or has previously (my case) used the following instructions: Alsa-update - openSUSE

You’ll notice instructions containing repo’s like this (openSUSE 11.1 example)

# zypper ar multimedia
# zypper install alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse
# zypper rr multimedia

It seems that right now, and possibly later(?), the repo URL for these packages has changed to include a ‘snapshot’ suffix:

Again you will need to make changes for your openSUSE version. The easiest way to check the repo is to search for the package names using the openSUSE Software search facility:

The kernel repo’s currently listed on Alsa-update - openSUSE worked for me but these may, or may not change too. You best check them too before proceeding.

I hope that helps somone else from scratching their head trying to work out why what worked before no longer works :slight_smile:
This should help you avoid being told you obviously did not following the instructions on Alsa-update - openSUSE :open_mouth:

Well, I’m scratching my head over this, … while there is a NEW “snapshot” directory, it IS new and the old URLs still do work.

So I do not understand the point of your post “as worded”.

Specifically, I just checked, and the URLs in Alsa-update - openSUSE still work, and there is no need from what I can see to specify a a “snapshot” directory.

Still, I will make a note to check with the alsa dev (who creates the directories), to see if they plan to remove the link to the current directories (which do function), and keep only the snapshot, but as near as I can tell, the guide is still good.

Also, if my memory is correct, the comment about NOT following the guide was related to installing multiple alsa-driver-kmp and not the URL that was specified (although that is a mute point).

A point of clarification, I now note:

Nominal repos for update of alsa apps which is still there and is called up by the guide:

Repos for updating driver “kmp” packages:

New Snapshot directory, which was not there before, and its purpose is NOT clear to me.

I have always maintained one should not use a repos that one is not familiar with, and I am NOT familiar with this new “snapshot”. I’ll see what I can find out, but for now I stick by my recommendation (which is NOT to use “snapshot” ).

Yep the repo is there. However, the second command where you are supposed to install some alsa-* packages will just indicate nothing to install or some such message. In my case, where I had used these instructions (repos) before, the command was update and I got (zypper install -f ... gave ‘not found in repositories, cannot reinstall.’ which gave me a clue):

# zypper update -r multimedia alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins
Loading repository data...
Reading installed packages...
No update candidate for 'alsa-utils'.
No update candidate for 'alsa-tools'.
No update candidate for 'alsa-firmware'.
No update candidate for 'alsa-oss'.
No update candidate for 'alsa-plugins'.
Resolving package dependencies...
Nothing to do.


I’ve also reread the alsa-update page and frankyl it is ambiguous about whether you can install more than one set of kernel modules. It clearly indicates to install the modules for the kernel you use, but does not warn you cannot have more than one kernel installed and have the alsa sound modules installed for all of them.

I thought you could safely have multiple kernels installed on opensuse (default, pae, trace), and switch between them as you need to - perhaps not?
If the use of alsa kernel modules means you can’t have more than one kernel installed, or you can but just not have the alsa-modules, it’d be nice to know this authoritatively and explictly.

Well the repo is there but it doesn’t hold the packages the page mentions, in some sense that is working - I suspect this is just one of those moments of flux, but it could be a permenent change in repos?

See comments above and below the packages needed are not there.

Would be great to get some idea of whether is a temp or permanent change.

Fine, but I did read that page carefully and if using alsa kernel modules means you cannot install more than one kernel on your machine then, AFAIU, that is a change of the usual case where you can install multiple kernels and boot into the one you want. The page is clear about installing modules for the kernel you have. But it does not address the case where poeple have multiple kernels installed, and really does not say that installing modules for multiple kernels is guaranteed to break you sound.

I’m not at a Linux PC right now, so it will be easier to check when I get home, and can examine my notes and rpm versions.

Hmmm… IMHO this is Windows thinking, where one installs multiple drivers in the hope one will work. Its typical in Linux that one should only install one driver.

Installing multiple drivers is a receipe for problems.

While I note your point, to me that is like saying one should not install every piece of software in the book … doing so is really contrary to Linux philosophy. One can only put so much basic Linux aspects into a guide.

Still, it won’t hurt to put the word “only” in selected places in the guide, and I will do so.

I do note the guide does state this:

Its important to send the third zypper command to remove the repository, as the rpms in that repository are cutting edge, and once one's sound functions, its best not to keep updating alsa, as one of the updates could inadvertently break one's audio.

from my perspective that points out that one should not install MORE than the basic rpms that the guide recommends.

No. Try that with a graphic driver. It will result in no graphics. No X. No GUI. Only comamnd line.

Try that with a web cam driver. It will result in no web cam functionality.

Try that with a wireless driver (ie try installing multple drivers (such as multiple madwifi) for different kernels). It will result in no wireless functionality. No wireless internet.

Sound drivers are no different. The same philosophy applies.

Its basic to Linux. … < sigh > … Maybe I have been doing this too long, I no longer can see the approach that ex-windows users try to bring to the table.

IMHO that goes beyond the guide. I will put in a caution.

OK, alsa-update guide has been updated with caution.

Now that I am back at home and have had a chance to look at this, it does appear you are correct that the directory structure of the “multimedia” repository/directories for alsa updates has changed. I sent the openSUSE/alsa-dev an email to determine their plans, and I suspect (per your view) that an update to the openSUSE alsa-update wiki will be necessary.

Caution is good, but is it really needed in this case?

I looked, via yast gui, at the file list of the alsa kernel modules package I have installed (I uninstalled all the others per your earlier advice).
It really does seem that the kernel module package installs all files in kernel specifc path:


Is it not the case that the pae kernel should never go loading files from the default kernel, etc.
In which case I should be able to install the alsa kernel module packages for each kernel I have installed on my system, secure in the knowledge that I’m no longer dealing with windows where specifc drivers can be and often are installed in general path locations.

It would be good if the alsa dev could comment explicitly on this.

My understanding is that this is one of Linux’s design points - to allow the flexibility where by you can boot up into a different kernel, do your stuff and boot into another kernel when you need to. This is one of the many things that attracted me to Linux from Windows.

So installing different kernels and then taking care to install kernel specific modules is definitely not baggage I carrried from windows - exactly the opposite. I had to learn to take care to install kernel specific pakages for each kernel I intended to use :slight_smile:

Of course if a kernel specific module is built and packaged as if it is not kernel specific then you will have trouble - perhaps these are the dirvers you refer to? But isin’t that an issue/bug with that driver’s build/packaging process?

My experience, based on helping dozens of users, is that installing more than just the one kmp will often break one’s sound. I’ve lost track of the number of cases where a user had more than just the alsa-driver-kmp for their kernel installed where their sound did not work, and then by reverting to the one alsa-driver-kmp (associated with their kernel) their sound started working.

I’ve also seen this with video driver rpms, madwifi wireless rpms, and webcam rpms.

I don’t dispute that experience. The questions is. Is that correct behavior or a bug that should be reported?
There is no point in reporting bugs the dev’s don’t want to know about.
Perhaps the alsa dev can say when you are next in contact with them?

I obtained a reply from the openSUSE alsa packager (who is also an alsa developer) and I’m puzzling a bit over the response.

They noted that the previous repository at Index of /repositories/multimedia:/audio has been moved to multimedia:libs repo due to the recent reorganization of multimedia repositories. (ie to here: Index of /repositories/multimedia:/libs/openSUSE_11.1 ).

Then in reply to my noting the Snapshot (which you drew my attention to):

and to the existing KMP:

They noted these are correct repositories. I was told these are essentially daily (or momentary) snapshot packages from the upstream GIT trees.

And the alsa dev agreed to my updating the contents in the alsa wiki.

But they were not more explicit that that !!

So if I read the very short response correctly, they do not want me updating to the new “libs” but rather want me updating to the new “snapshot”. :stuck_out_tongue:

… anyway, this evening I’m going to update the alsa-update wiki to point to the snapshot (the daily build) and then ask the openSUSE alsa packager (tiwai) if they concur with my updates … I don’t plan to reference the “lib” unless they recommend I also include that (I’m puzzling as to what the “lib” means? is it the 1.0.20 with no daily builds incorporated ? ).

Update to wiki is now done: Alsa-update - openSUSE

Thanks for pointing out the change to “snapshot”

Hmm, I inspected the libs repo and it seems to contain the most recent version of alsa:

# zypper rr multimedia
# zypper ar multimedia
# zypper se --details -r multimedia|grep -i alsa
  | alsa                                   | srcpackage | 1.0.20-30.1            | noarch | multimedia
v | alsa                                   | package    | 1.0.20-30.1            | i586   | multimedia
i | alsa                                   | package    | 1.0.20.git20090714-1.1 | i586   | (System Packages)
  | alsa-devel                             | package    | 1.0.20-30.1            | i586   | multimedia
  | alsa-docs                              | package    | 1.0.20-30.1            | i586   | multimedia

If snapshot is ‘daily (or momentary) snapshot packages from the upstream GIT trees’ that sounds very fragile - it sounds like it hasn’t been adapted to any openSUSE specifics?
I’d be inclined to include both but quote the dev on the snapshot repo and let users decide?

Yes it has the 1.20 version - at the moment :slight_smile:

Thanks for your efforts.

Just a note people

Regarding unsupported audio chips, also keep your kernels up to date folks. Newer Alsa libs themselves won’t give you support for an unsupported chip. A newer kernel possibly can as it has its own Alsa built inside which provides the actual drivers. The Alsa stuff one installs from yast are just libs and control/config software :wink:

However the snapshot repo does have all the packages the wiki page mentions:

# zypper se --details -r audio|grep -i alsa
  | alsa                    | srcpackage | 1.0.20.git20090714-1.1  | noarch | audio
i | alsa                    | package    | 1.0.20.git20090714-1.1  | i586   | audio
  | alsa-devel              | package    | 1.0.20.git20090714-1.1  | i586   | audio
  | alsa-docs               | package    | 1.0.20.git20090714-1.1  | i586   | audio
i | alsa-firmware           | package    | 1.0.20.git20090507-2.1  | noarch | audio
  | alsa-firmware           | srcpackage | 1.0.20.git20090507-2.1  | noarch | audio
  | alsa-oss                | srcpackage | 1.0.17.git20080715-1.17 | noarch | audio
i | alsa-oss                | package    | 1.0.17.git20080715-1.17 | i586   | audio
  | alsa-plugins            | srcpackage | 1.0.20.git20090619-1.14 | noarch | audio
i | alsa-plugins            | package    | 1.0.20.git20090619-1.14 | i586   | audio
  | alsa-plugins-jack       | package    | 1.0.20.git20090619-1.14 | i586   | audio
  | alsa-plugins-maemo      | package    | 1.0.20.git20090619-1.14 | i586   | audio
  | alsa-plugins-pulse      | package    | 1.0.20.git20090619-1.14 | i586   | audio
  | alsa-plugins-samplerate | package    | 1.0.20.git20090619-1.14 | i586   | audio
  | alsa-plugins-speex      | package    | 1.0.20.git20090619-1.14 | i586   | audio
  | alsa-tools              | srcpackage | 1.0.20.git20090702-1.7  | noarch | audio
i | alsa-tools              | package    | 1.0.20.git20090702-1.7  | i586   | audio
  | alsa-tools-devel        | package    | 1.0.20.git20090702-1.7  | i586   | audio
  | alsa-tools-gui          | package    | 1.0.20.git20090702-1.7  | i586   | audio
  | alsa-utils              | srcpackage | 1.0.20.git20090620-1.9  | noarch | audio
i | alsa-utils              | package    | 1.0.20.git20090620-1.9  | i586   | audio

So I think you are right about the snapshot being preferred - but I am very nervous about it just being a snapshot of upstream

… but it only has a subset of the packages the wiki page mentions so I think you might be right about referencing the snapshot on wiki page - just nervous about its fragility given the description of what it is :frowning:

Yes, I think the snapshot is relatively “fragile”.

But don’t forget the openSUSE packager (tiwai) of this daily snapshot is one of the major alsa developers, and as such in openSUSE we are very fortunately to have access to such cutting edge updates as rpms. I believe as such it has been optimized to openSUSE specifics. And with such cutting edge updates bugs can be introduced, and then fixed shortly (days or a week or two) later. Hence thats why in the troubleshooting guide I had the repository remove command, so that once sound is working, users don’t have it broken again by a cutting edge update.

I suspect the multimedia:lib directory may be the latest stable alsa (currently version 1.0.20) without the cutting edge updates. I asked the openSUSE packager (tiwai) what the multimedia:lib were wrt to snapshot and KMP but have not received a reply as of yet.

It appears I should have referenced the multimedia:lib (which replace the older multimedia:audio) instead of the multimedia:audio:snapshot.

I’ve been told that:

multimedia:libs contain all alsa-* packages that have been in
multimedia:audio before (although they aren’t libraries)
and that
multimedia:audio is obsoleted now.
Only some sub-projects exist.
I’m assuming for the moment that one needs both the packages in the multimedia:libs and the multimedia:audio:KMP, although I’m not 100% certain. I’m going to clarify that now (I feel like a bit of a “nag” having to go back and ask these questions all the time). :slight_smile:

The clarification I obtained reference multimedia:libs and multimedia:audio:KMP was that

multimedia:libs contain only user-space stuff, not ALSA drivers. They are basically independent. In some cases, only upgrading the user-space stuff suffices, and in some cases, vice versa.

But usually it shouldn’t hurt even if you upgrade to the newer version of ALSA user-space stuff. They should be backward compatible.

I also asked if I was correct that users who wish to try a more recent “daily snapshot” should use BOTH the multimedia:audio:snapshot and the multimedia:audio:kmp directories/repositories? I was told that is correct.

So for the timebeing, I created two wiki for alsa-update that reference each other. One for the multimedia:libs Alsa-update - openSUSE and one for the multimedia:audio:snapshot Alsa-update-snapshot - openSUSE

They link internally to each other, with a brief explanation.

I’m hoping if I made a mistake that Takashi will let me know.