Alsa resets speaker volume on boot

Every time I boot into my laptop, there is no sound. Going to alsamixer in a terminal shows that the “Speaker” volume is constantly getting reset to 0, and bringing it back up fixes the problem. How can I get Alsa to remember to keep the speaker volume above 0?

There was a time, if one set the volume level to exactly how they wanted, and then with root permissions ran:

alsactl store

that would work.

However audio has changed much since then and that may longer be the case.

I tried that, and it didn’t work. The odd thing is that it’s only the speaker volume setting that isn’t saved. I muted the PC Beep, and that setting stayed, but speaker volume keeps getting reset.

I had the same problem…

I had to disable the pulse audio in yast–> sound
i set the volume to max and restarted the pc.
problem byebye