Alsa-plugin-pulse package

An arcade emulator Retroarch has no sound:

In its log it says can’t open “/usr/lib64/alsa-lib/libasound_module_pcm_pulse.so”

I couldn’t find this “libasound_module_pcm_pulse.so” either in the directory.

I googled and found it should be included in the Alsa-plugin-pulse package.

However I find I have this package already installed. Then how do I get the required file?

I tried installing the 32 bit version of the package it still doesn’t work.

Thanks.

Have you rebooted since those updates?

Just to do a qa check of some of what you noted. Please run the following in a terminal and provide the output here:


find /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so
rpm -qa '*alsa-plugins*'
rpm -ql alsa-plugins-pulse | grep pcm

Thank you. These are the result:

:~>find: `/usr/lib64/alsa-lib/libasound_module_pcm_pulse.so': No such file or directory
~> rpm -qa '*alsa-plugin*'
alsa-plugins-pulse-1.0.26-1.1.2.x86_64
alsa-plugins-1.0.26-1.1.2.x86_64
:~> rpm -ql alsa-plugins-pulse | grep pcm
/usr/lib64/alsa-lib/libasound_module_pcm_pulse.so

Excuse me, but what do you mean by update? I didn’t update nothing. All required package were installed before I tried to find them.
It’s only the “libasound_module_pcm_pulse.so” is still missing

This looks like a bad install of alsa-plugins-pulse.

If you look at :


:~> rpm -ql alsa-plugins-pulse | grep pcm
/usr/lib64/alsa-lib/libasound_module_pcm_pulse.so

it tells you that the package /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so is included with alsa-plugins-pulse on your PC, like you note.

If you look at


:~>find: `/usr/lib64/alsa-lib/libasound_module_pcm_pulse.so': No such file or directory

it tells you that GNU/Linux can not find `/usr/lib64/alsa-lib/libasound_module_pcm_pulse.so’ .

Clearly those are contradictory, as on one hand the list says its there, and on the other hand the find says its not there.

Try forcing a re-install of alsa-plugins-pulse and then restart and test.

Also, I’m curious to see what your repositories may be, in case that caused this. Please, what is the output of:


zypper lr -d

and put the output between code tags, like you have been doing thus far.

Force reinstalled the package now it’s ok. Much thanks.

Excellent news! Thanks for sharing your solution.

oldcpu wrote:
>
> bonedriven;2593517 Wrote:
>> Force reinstalled the package now it’s ok. Much thanks.
>
> Excellent news! Thanks for sharing your solution.
>
>
Sorry to break in but is is there a way/option to force -install the
dependencies too in YaST or zypper?


GNOME 3.6.2
openSUSE Release 12.3 (Dartmouth) 64-bit
Kernel Linux 3.7.10-1.16-desktop

Not that I am aware of.
But you could do it with something like this I guess:

sudo zypper in -f `rpm -q --requires *packagename*`

This calls “rpm -q --requires packagename” which lists all requirements of the package, and feeds the list as command line to “zypper in -f”.