ALSA noise on 12.1 (Intel HDA)

This is not a hardware problem because it works fine on SLED11sp1 and 11.4 (same machine)
There’s a problem with snd_hda_intel driver or libpulse0 that seems to be forced on 12.1

Sound pops when the sound card is activated or deactivated, every time flash video or mp3 is played or stopped.
Used to have similar sound popping on boot, but this was a long time ago, can’t remember how it was solved.
Clicking sound test in yast/systemsettings also pops but then I also hear terrible noise from the speakers.
Running speaker-test in konsole doesn’t make the noise but still pops when activated or stopped.

So far I’ve tried power_save=0 and model=auto in 50-sound.conf, didn’t help.
Installing pulseaudio is just making things worse, I’ve tried it on 11.1, 11.2 and 11.4, it never worked for me.

These images are from 12.1 yast : Hardware info and Sound configuration
These are from SLED : Hardware info and Sound configuration
Note that ALSA on snd_hda_intel works perfectly in SLED and 11.4 without any pulseaudio so this looks like a regression.

Forgot to mention I’m using a non-standard adapter to connect 5.1 speakers, something like this.
Got these outputs as well, /usr/sbin/alsa-info.sh and rpm -qa

Did a clean 12.1 install yesterday, there was no popping sound on a default user account.
Switching from default stereo to 5.1 caused it to appear again, kmix/phonon static noise on startup also came back.

Removed alsa, used only pulseaudio = no sound
Removed pulseaudio, using alsamixer = popping sound

Removed kde47/kmix/phonon/alsa/pulseaudio and all config files, installed kde35/xfce/alsa/pulseaudio/pavucontrol/pulseaudio-equalizer-gtk
At this point sound started working properly with some tweaks @ /etc/pulse/daemon.conf

flat-volumes = no
enable-lfe-remixing = yes
default-sample-channels = 6
default-channel-map = front-left,front-right,rear-left,rear-right,front-center,subwoofer

And /etc/pulse/default.pa

set-default-sink output sink_name=alsa_output.pci-0000_00_14.2.analog-surround-51

It works fine now, please correct me if I did something wrong with these config files.
Haven’t rebooted yet so I’m not sure it won’t reset back to default.

update 4

Pulseaudio works for mplayer but wine still needs alsa and winecfg sound test makes the same noise as before.
Setting driver to “pulse” in q4wine doesn’t work. Pasuspender works but noise is still there.

Removed all pulseaudio packages, including libpulse0 and libpulse-mainloop-glib0 + config files
Removed all alsa packages including libasound2 + config files
Downgraded kernel to 2.6.37.6-0.9-default (x86_64)
Pulled these from 11.4 repos :

alsa-utils-1.0.24.2-3.1.x86_64
libasound2-1.0.24.1-3.1.x86_64
libasound2-32bit-1.0.24.1-3.1.x86_64

Wine sound test now works, noise is gone.
If any settings are changed in alsamixer or kde3 kmix, it starts all over again.
If however, I leave the mixers alone and use the remote to change volume, sound works perfectly.

update 5 - solved

After couple of hours of testing different packages and settings I’ve identified the root of this problem.
Even though I’ve never used a mic on this machine, there’s a “front mic” setting in alsamixer that should NOT be muted.
If muted, it will produce noise and speakers will pop every time the sound is started or stopped.

If true, reads like a bug to me. I would recommend writing a bug report on that. There is guidance here: openSUSE:Submitting bug reports - openSUSE and you can use your openSUSE forum user name and password to log on to bugzilla. Write the bug report against component ‘sound’. Attach to the bug report the text file alsa-info.txt you get from running:


/usr/sbin/alsa-info.sh --no-upload

ensure your bug report is complete as the SuSE-GmbH packager (who is also an alsa sound driver developer) will not read a forum thread. Monitor the bug report every couple of days, and if you see a NEED INFO flag then reply to the SuSE-GmbH packagers questions, and after you answer the query be certain to CLEAR the NEED INFO flag. Thats important, else the packager will miss the fact you replied to the question.

Reported this bug, fix included in 3.1.10-1.9-desktop, thanks.

Thanks for contributing here. My understanding this is the bug that was fixed in this latest kernel release: https://bugzilla.novell.com/show_bug.cgi?id=741128