ALSA intel 82801G VT1708B problem

Hi, I’m having a problem with my brand new motherboard, it’s an ASUS P5KPL-AM and the sound subsystem.

It has an Intel 82801G and the alsa-info.sh output can be found in
http://www.alsa-project.org/db/?f=c34c046e5e0aab0d33a8c0ae967ea369dc97dcc5

I’ve already read some post in this forums and made some updates and tests but the sound is still dead. :frowning:

I know it works because of my XP-Pro installation.

Can you help me?

More info:

#rpm -qa | grep alsa
alsa-plugins-pulse-1.0.18-6.13
tsalsa-20080914-0.pm.1
alsa-plugins-1.0.18-6.13
alsa-firmware-1.0.17-1.42
alsa-utils-1.0.19.git20090319-1.1
alsa-1.0.18-8.9
alsa-tools-gui-1.0.19.git20090320-1.1
alsa-driver-kmp-default-1.0.19.20090321_2.6.27.19_3.2-1.1
alsa-tools-1.0.19.git20090320-1.1
alsaplayer-0.99.80-5.31
alsa-oss-1.0.17-1.43
alsa-oss-32bit-1.0.17-1.37
java-1_6_0-sun-alsa-1.6.0.u12-1.2.1

rpm -qa |grep pulse

libpulse0-0.9.12-9.5
alsa-plugins-pulse-1.0.18-6.13
libpulse-browse0-0.9.12-9.5
pulseaudio-utils-0.9.12-9.5
pulseaudio-module-x11-0.9.12-9.5
pulseaudio-module-lirc-0.9.12-9.5
libpulse-mainloop-glib0-0.9.12-9.5
pulseaudio-0.9.12-9.5
pulseaudio-module-zeroconf-0.9.12-9.5
pulseaudio-module-jack-0.9.12-9.5
libpulse0-32bit-0.9.12-9.6
libpulsecore4-0.9.12-9.5
libxine1-pulse-1.1.15-20.8
pulseaudio-module-bluetooth-0.9.12-9.5
pulseaudio-esound-compat-0.9.12-9.5

rpm -q libasound2

libasound2-1.0.18-8.9

uname -a

Linux home 2.6.27.19-3.2-default #1 SMP 2009-02-25 15:40:44 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Best regards,
Ernesto.

I see your PC has a VIA VT1708B hardware audio codec. I have no experience with that. I note this alsa web page when searching on this codec: Search results - AlsaProject

So it appears it should be supported.

With my knowing nothing about this specific hardware audio codec, my observations are:

  1. your alsa update is incomplete. Update them all to git versions, where git versions area available. In particular “alsa” and “libasound2”. There is some guidance (with links to the repos) here: Alsa-update - openSUSE

  2. your mixer has surround sound and digital audio ON. Should they be ON ? Does switching them OFF help? Also, your volume scale may not be linear.

  3. What are you using for a sound test? I recommend you try the speaker-tests here: SDB:AudioTroubleshooting - openSUSE

Sorry, I have to run to work and can not give more detail (no time). If the above suggestions confuse you , post and advise, in 10 hours or so, I’ll take another look at this and perhaps give you some specific suggestions. But I have no specific answers, as this hardware audio codec is new to me.

I’ve updated to the git version all alsa packages, (I think). When I log into the KDE session the typical sound is played, but it ends abruptly.
Later on I tried to play with the KDE notifications and for a minute or so some of them worked but suddenly a pop-up appeared saying that the Intel… sound card had a problem and that it was falling back to “default”.

Here is my new alsa-info.sh data

http://www.alsa-project.org/db/?f=f9656d7082dd4424f157b2d2c0929bb78d12e5f9

And here goes my rpms versions.

rpm -qa |grep alsa

alsa-plugins-pulse-1.0.18-6.13
tsalsa-20080914-0.pm.1
alsa-1.0.19.git20090304-3.1
alsa-utils-1.0.19.git20090319-1.1
alsa-plugins-1.0.19.git20090303-1.10
alsa-tools-gui-1.0.19.git20090320-1.1
alsa-oss-1.0.17.git20080715-2.24
alsa-driver-kmp-default-1.0.19.20090324_2.6.27.19_3.2-1.1
alsa-tools-1.0.19.git20090320-1.1
alsaplayer-0.99.80-5.31
java-1_6_0-sun-alsa-1.6.0.u12-1.2.1
alsa-firmware-1.0.19.git20090317-1.1

rpm -qa |grep libasou

libasound2-32bit-1.0.19.git20090304-3.1
libasound2-1.0.19.git20090304-3.1

I’ve played a little with the kmix volume controls and muting some channels, but no sound at all.

I’ve also tried the sound test you suggested but nothing happened.

Any ideas?

Finally, I want to thank you very much for your help.

I can only try things at night (GMT -3) and I have no rush at all.

Best regards,
Ernesto.

That suggests basic sound works. The abrupt end is IMHO another problem.

That also suggests basic sound works, … the fall back is another problem.

Did you try both? ie

A simple test to see if your sound works, is to open a konsole or xterm, and type (it may be easier to copy and paste this into your konsole/xterm):speaker-test -Dplug:front -c2 -l5 -twavNote Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 75%. Note the test for surround sound is different.

If that test yields errors, try instead this more simple test:speaker-test -c2 -l5 -twavIf there is no sound from either test when using a konsole (or xterm) as a regular user, try as user root. ie type “su” (no quotes, and enter root password when prompted) and then try the test line. If you get sound with root permissions, but you got no sound as a regular user, then you probably have a permissions problem.

Ideally you should hear a ladies voice saying ‘FRONT RIGHT’,‘FRONT LEFT’ five times.

Its not uncommon for only 1 of those two tests to work, where 1 does not work. Thats typical, and not an indication of a problem with “basic” sound functionality.

In a couple of days I’m leaving on vacation for just less than a week and I won’t have internet access when away.

Hi oldcpu,
thanks for your help and sorry for not answering earlier, I’ve been very busy and I didn’t turned on my computer at home.

I’m stuck, I still have no sound. I’m a software engineer and an experienced Linux user (10+ years) and I feel I’m loosing this battle :slight_smile:

As I mentioned before I followed all the tests I found on Internet but nothing happens. May be I must stand still for a while and wait for an upgrade of the alsa subsystem.

Regards,
Ernesto.

This IMHO illustrates that basic sound works. The fact that speaker-tests provide no sound could be related to mixer settings or other cause.

Note that that settings on a mixer are not always linear, and for some hardware, sound is only produced at the upper end of the volume scale.

!!Amixer output
!!-------------
!!-------Mixer controls for card 0 [Intel]
Card hw:0 ‘Intel’/‘HDA Intel at 0xfea78000 irq 16’
Mixer name : ‘VIA VT1708B 8-Ch’
Simple mixer control ‘Master Front’,0
Front Left: Playback 22 [71%] -1.75dB] [on]
Front Right: Playback 20 [65%] -5.25dB] [on]
Simple mixer control ‘Side’,0
Front Left: Playback 0 [0%] -47.25dB] [on]
Front Right: Playback 0 [0%] -47.25dB] [on]
Simple mixer control ‘Line’,0
Front Left: Playback 0 [0%] -40.25dB] [on]
Front Right: Playback 0 [0%] -40.25dB] [on]
Simple mixer control ‘IEC958’,0
Mono: Playback [off]
Simple mixer control ‘IEC958 Default PCM’,0
Mono: Playback [on]
Simple mixer control ‘Independent HP’,0
Capabilities: enum
Items: ‘OFF’ ‘ON’
Item0: ‘ON’
Simple mixer control ‘Input Source’,0
Items: ‘Stereo Mixer’ ‘Mic’ ‘Front Mic’ ‘Line’ ‘CD’
Item0: 'Stereo Mixer’I highlighted some settings in your mixer that I do not understand. My view if a item is ON, then its volume control should be moved UP. Else it should be switched OFF. … Also, given volume control is not always linear, I recommend you move up your master volume, until sound is established reliably, then back off to avoid distortion. I don’t understand some other settings at the end that may or may not be important.

Did you also try those two speaker tests with root permissions ? (to confirm there is no permissions problem).

Did you also try those two speaker test with a headset plugged in. Sometimes headset sound functions when speaker sound does not.

In case the reason for the speaker tests not functioning is something different from basic sound functionality, did you try setting up your audio codecs and multimedia apps, in case sound is functioning with them?

To do so, please set up your software package manager with 4 repositories and only 4 repositories. Those 4 repositories are OSS, non-OSS, Update and Packman. Just those 4. After you learn how to recognize problems from conflicting repositories, and how to solve them, more can be added. But not until then. So for now, just those 4. In particular do NOT add videolan, as it is known to conflict with Packman. There is guidance here for adding those 4: Repositories/11.1 - openSUSE-Community

Once those 4 are added, you can go to YaST > Software > Software Management and change “filter” to “search” and search for and install the Packman packaged versions of amarok, amarok-xine, amarok-packman, libxine1, xine-ui, smplayer, mplayerplug-in, vlc, libffmpeg0, w32codec-all, xvidcore, libxvidcore4. … That should get you started with smplayer, vlc, xine and amarok. You will need to change amarok to use the xine engine. Note you can tell the packman packaged versions by the “pm” in the version number. The Novell/SuSE-GmbH versions are known to be broken for the majority of codecs.

Let us know if that approach works.

If you still have a problem, then the approach to get this fixed in the next alsa update is to proactively write a bug report. Just waiting IMHO does not always work for Linux. There is guidance on bug reporting writing for openSUSE here: Submitting Bug Reports - openSUSE