alsa: cannot record sound


I’ve got some audio issues I’m hoping somebody can help me resolve.

I’ve got sound - I hear all the system sounds, I can play sound files, CDs, etc. But I have not been able to record and play back anything with success.

Originally, when I would record (either with arecord or with audacity) I would get extremely low quality sound, with lots of noise and crackling, and my recorded voice was barely audible (even with volume turned up to max). I played with alsamixer for hours without being able to improve matters.

Things are worse now. I tried installing alsa-firmware, as indicated at SDB:Audio troubleshooting - openSUSE. I also tried updating alsa following instructions given at SDB:Alsa-update - openSUSE. I’m not sure which of these changes did it, but the result is that I can no longer record ANYTHING at all. I get absolutely nothing, not even the low quality noise and crackling I was getting before. It’s as if there is no audio input at all.

Uninstalling alsa-firmware and reverting back to the older alsa version (1.0.20) didn’t change a thing.

I’m running openSUSE 11.2, kernel, alsa 1.0.20. My sound card is a Creative X-Fi (by the way, yast cannot detect my card, another problem I have never solved).

Any suggestions?

Weird. In alsamixer, muting the Digital-IO channel fixed my recording issue. I can now record my voice with adequate volume and only a tiny bit of static.

Support for the Creative X-Fi has never been good because for the longest time

  1. Creative provided limited to no technical details on the device to the open source community, and
  2. Creative provided a mostly non-functional Linux driver, and
  3. the Linux community were not able to reverse engineer a driver.

Eventually, Creative released the code for their non-functional driver, and the Linux community were able to take that and patch together a partial driver (but having to do that still without all the information on the Creative X-Fi) and hence its not the greatest driver from what I have read.

In openSUSE-11.2, YaST definitely does NOT support that driver. If one gets the X-Fi working and then tries to run YaST > hardware > sound , YaST WILL likely break the sound configuration.

To get it functioning one needs to be certain they do NOT use YaST, and the /etc/modprobe.d/50-sound.conf (or maybe it is sound.conf) needs to be removed. Do NOT leave any backups in the /etc/modprobe.d directory, as older versions of openSUSE would treat all files in that directory (including backups) as operational files.

One’s best bet may be to update alsa per the guide: SDB:Alsa-update - openSUSE which you claim you have, but I would like to do a quality check of that update as it is my experience that many users simply mess up in their efforts to do that.

So, what is the output of:

rpm -qa *alsa*
rpm -q libasound2
uname -a

and with the PC connected to the Internet what is the output website/url given by running the diagnostic script:


being certain to select the SHARE/UPLOAD option.

Also, give me a list of all the files in the /etc/modprobe.d/ directory.

Again, YasT > hardware > sound does NOT support that driver and it likely WILL break any driver configuration that YaST functionality is run.

i have a similar problem.

i am running opensuse 64 bit - lxde.

At first , i could not get sound from youtube or from playing mp3s. i tried installing pulseaudio but no go. I finaly got it working by adding the user to the ‘audio’ group. Now sound (playback ) is working.

But not for recording.

i cant record anything. tried selecting all mic1 , mic2 , line in Pulse Volume Control but no luck. Also checked alsa mixer to check the mic levels there as well. but no luck.

You could provide the information that I asked user dspathis to provide.

will do. 19,899 posts ? awesome … :slight_smile:


rpm -qa alsa**


rpm -qa pulse


# rpm -q libasound2


# uname -a
Linux localhost #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux

Output of
/usr/sbin/ has been uploaded/shared.

It gave loads of info.Its at

Thanks. The first thing I note is your hardware has a VIA VT1708S hardware audio codec which is almost certainly different from user dspathis’s X-Fi and hence it is likely your problem (with similar symptoms) is a different problem. In the case of your PC, I note 1 64-bit openSUSE-11.3 with the kernel and the (driver) / 1.0.23 (utilities) alsa versions with the VIA VT1708S hardware audio codec.

In your mixer I note reference to a ‘mic’ and a ‘front mic’ suggesting your PC may have more than one mic correction. You need to tell me WHAT mic are you trying to record from ? An internal mic ? (I don’t think the case). An external mic (not USB) plugged in to the back of the PC ? The front/side of the PC ? A USB mic ?

Further, in the mixer I note:

**!!Amixer output**

!!-------Mixer controls for card 0 [SB]

**Card hw:0 'SB'/'HDA ATI SB at 0xfbdf4000 irq 16'**
  Mixer name	: 'VIA VT1708S'
**Simple mixer control 'Front Mic Boost',0**
  Front Left: Capture 0 **[0%]** [0.00dB]
  Front Right: Capture 0 **[0%]** [0.00dB]
**Simple mixer control 'Mic',0**
  Front Left: Playback 20 [65%] -4.50dB] [on]
  Front Right: Playback 20 [65%] -4.50dB] [on]
**Simple mixer control 'Mic Boost',0**
  Front Left: Capture 3 [100%] [30.75dB]
  Front Right: Capture 3 [100%] [30.75dB]
**Simple mixer control 'Capture',0**
  Front Left: Capture 31 [100%] [30.00dB] [on]
  Front Right: Capture 31 [100%] [30.00dB] [on]
**Simple mixer control 'Capture',1**
  Front Left: Capture 0 **[0%]** -16.50dB] [on]
  Front Right: Capture 0 **[0%]** -16.50dB] [on]
**Simple mixer control 'Independent HP',0**
  Items: 'OFF' 'ON'
  Item0: 'OFF'
**Simple mixer control 'Input Source',0**
  Items: 'Stereo Mixer' 'Mic' 'Front Mic' 'Line'
  Item0: 'Mic'
**Simple mixer control 'Smart 5.1',0**
  Mono: Playback [on]

Your mixer has the ‘mic’ selected (and not front mic) and I note the ‘front mic’ boost capture at 0%. Have you selected the correct mic ??

What are you doing for a record test? What app are you using ?

I recommend something simple, like:

arecord -f cd test.wav

and then replay test.wav and see if you get sound.

I also note you have pulse audio running and a large number of alsa rpms installed, suggesting to me that you have a Gnome desktop ? In openSUSE-11.4 I found installing ‘pauvcontrol’ was useful for pulse (and then running ‘pavucontrol’ from a terminal) and it may be the same for Gnome in 11.3 (I don’t know here - I’m a KDE/LXDE user). Else the program ‘alsamixer’ may be useful for tuning your mic.

> You need to tell me WHAT mic are you trying to record from ?

An external mic. I am running opensuse 64 bits lxde , not gnome

> The front/side of the PC ?

At the back of the pc. The cound card has only one mic input. It also has a line in 9 i have tried putting the mic in both )

> Your mixer has the ‘mic’ selected (and not front mic) and I note the ‘front mic’ boost capture at 0%. Have you selected the correct mic ??

i didnt see that. Surprised to see it actually. i have run 'alsamixer ’ many times but did not see that. F4 helped.

> arecord -f cd test.wav

i will try this.

Is there any commandline setting ( with amixer ) that i can use to just set my mic and set the recording volume to max?

There is, but I don’t know the syntax.

Hi. I’m having mic problems too. I have done a fresh install of the new Opensuse 11.4 (32bit) with the Gnome desktop and the mic won’t work with anything I try.
I am using an ACER Extensa 5220 laptop with built-in mic.
I have with Skype, Cheese (Webcam App), and the Sound Preferences/Input shows no microphone activity.

Here are the outputs you requested from the others in this thread:
garth@garthlinux:~> rpm -qa alsa
garth@garthlinux:~> rpm -q libasound2
garth@garthlinux:~> uname -a
Linux #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 i686 i686 i386 GNU/Linux

Your ALSA information is located at


From the diagnostic script, I note your Acer Extensa 5220 has the 32-bit openSUSE-11.4 kernel installed, with alsa driver version 1.0.23 and alsa utilities version The hardware audio codec of your PC is reported to be an ALC268.

I note the following in your mixer:


**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: ALC268 Analog [ALC268 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

which suggests a device 0 and a device 2 to record. There being no device 1 to record is somewhat puzzling, and its possibly related to either a webcam or some other USB device you had plugged in for a while ? I assume device 0 and device 2 correspond to an external mic jack, and an internal mic. But if you have 2 external mic jacks in addition to the internal mic, that is important to know, as my assumptions could be wrong and hence my recommendation wrong.

I’m not in front of your PC, so things you take for granted when tuning/configuring the mics, I need to try to deduce from the script, and that is not always so easy.

Lets now look at your mixer settings:

**!!Amixer output**!!-------------

**!!-------Mixer controls for card 0 [Intel]**
Card hw:0 'Intel'/'HDA Intel at 0xfc300000 irq 41'
  Mixer name	: 'Realtek ALC268'
**Simple mixer control 'Mic Boost',0**
  Front Left: 2 [100%]
  Front Right: 2 [100%]
**Simple mixer control 'Capture',0**
  Front Left: Capture 31 [100%] [30.00dB] [on]
  Front Right: Capture 31 [100%] [30.00dB] [on]
**Simple mixer control 'Capture',1**
  Front Left: Capture 1 **3%**] -15.00dB] [on]
  Front Right: Capture 1 **3%**] -15.00dB] [on]
**Simple mixer control 'Input Source',0**
  Items: 'Mic' 'Internal Mic' 'Line'
  Item0: '**Mic**'
**Simple mixer control 'Input Source',1**
  Items: 'Mic' 'Internal Mic' 'Line'
  Item0: '**Mic**'
**Simple mixer control 'Internal Mic Boost',1**
  Front Left: 2 [100%]
  Front Right: 2 [100%]

I hope its clear from what I highlighted, that you have NOT selected the internal mic. Hence the internal mic will NOT record. The internal mic must be selected. Give that a try.

Now when testing, use a simple program and NOT the ones you noted. Instead use the simple ‘arecord’ command. ie:

arecord -f cd test.wav

I had thought I made that clear previous in this thread, but I see now I failed. If you use a different application to test the record capability, you introduce additional unknowns which could be preventing the record. So keep it simple and solve this one step at a time.

And finally a request :slight_smile: … In the future, PLEASE start your own thread. We have 3 users asking for help in this thread and I find that highly confusing, as typically users assume one will read their previouis posts and not get confused with the posts of others. Well I find the posts of others HIGHLY confusing when mixed in the same thread, as I am constantly scratching my head trying to figure out what (if anything) is relevant to the other persons problem. 95% of the time there is no relevance, and forcing one to scroll up and down is a waste of everyone’s time. Thanks for listening to my grumpy discertation, and BEST WISHES in your efforts to solve this. I hope together we can get this working.

Thanks Oldcpu
Sorry for not beginning a new thread - will do next time.
My laptop has a built in mic on the screen next to the webcam and it has a 2nd mic socket on the side.
I have tried the arecord command and it creates a wave file that is just flat-line (as tested with Audacity). VLC player just gives a click at the start and another click at the end.
I have switched the Sound Preference Input from mic 1 to mic 2 and back and I still get no input.
Then I have plugged a mic into the other mic socket and run the same tests. Now I do get a very distorted recording (certainly can’t make out words) on mic 1 of Sound Preferences and mic 2 also records distorted but at a lower volume. (that’s crazy !! ). Seems like it doesn’t even know there is a built in mic.
Ok, so where do we go from here?

We could start by you showing me your mixer settings where you believe they are set properly to record. You can do that again by setting up your INTERNAL mic to record, and then run the diagnostic script:


and select the share/upload post here the website address / URL where the alsa information was uploaded.

Then set up your mixer DIFFERENTLY such that you think the INTERNAL mic should be recording and once again run the diagnostic script and post here the web address / URL where the alsa information was uploaded.

That way I can check your mixer settings !

Note IF you are getting distorted sound, you can back off on the boost and the record/capture levels, so as to tune to get better sound with out distortion.

Since you are using openSUSE-11.4, it might also help if you installed ‘pavucontrol’ and then run ‘pavucontrol’ and then check the ‘output devices’ tab and also the ‘recording’ tab while you are attempting to record with the ‘arecord’ command to ensure they are indicating things are setup properly.

Can I ask a quick question before running the tests suggested? You ask me to set up for the INTERNAL mic but I can’t find any reference to INTERNAL. Only mic1 and mic2. I am presuming that mic 1 is the default mic which should be the internal one (the same way that MS Windows picks it up as the default mic). That’s why I tried all the different variations in the last response I sent you. How can I be sure which mic I am activating?

The previous time (with different alsa installed) you ran the script it had this:

Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Mic' 'Internal Mic' 'Line'
  Item0: 'Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Mic' 'Internal Mic' 'Line'
  Item0: 'Mic'

I think it is pretty clear there that you had an Internal Mic selection that you did not select. You need to select that.

I do not see a Mic1 and a Mic2 in that output. If you are presented with a Mic1 and a Mic2 in your drop down selection, then simply select Mic1, run the script. It will tell you if you have ‘Mic’ or ‘Internal Mic’ selected. If you had ‘Mic’ selected then select ‘Mic2’ and run the script. It will tell you if you have ‘Mic’ or ‘Internal Mic’ selected. If neither then post and advise. YOU may KNOW the answer already to that, but I’m NOT in front of your PC and I NEED information to come up with good recommendations.

THAT way you can tell which is which from a software (not from a hardware) perspective.

Note I am not in front of your PC and I can only make recommendations on specific information you provided. IF I was in front of your PC this would likely be a LOT easier.

Did you install ‘pavucontrol’ like I suggested ? Did you check the ‘output devices’ tab and also the ‘recording’ tab while you are attempting to record with the ‘arecord’ command to ensure they are indicating things are setup properly.

Please do so.

Hi again
Ok, I have discovered that the mixer setup uses mic 2 for the internal mic. This I could only find out after running pavucontrol. Pavucontrol was installed but not running. As soon as I ran it and looked at the controls it gave I could see the mic activities and could determine that mic2 was the internal mic.
I can record now with arecord and the other recording programs loaded. I just need to play around with the sound quality by adjusting the mic volumes.
But, I guess pavucontrol now needs to be run at startup. How do we do that?

Do you change between internal and external mics often ?

Because I think pavucontrol is very good at retaining the previous settings and applying them. I confess I have not confirmed this to be the case for a Mic, but I have confirmed it to be the case for sound device selection when my PC has more than one audio device. However in the case of applications that output sound, I needed to tune pavucontrol for each application once - there after it would use the previous selected sound device for that application. I suspect the same may be true for your Mic.

If for any given application that uses your Mic, IF you select the pavucontrol equivalent of Mic2 (pavucontrol likely gives it a different name) then when ever you run that application, even WITH pavucontrol not running, that Mic should be used for that application automatically by pulse audio (as pavucontrol configured it in your previous session - and the settings are saved). Its only if you try a new application, or you wish to change the Mic selection for an existing configured application, that you should need to use pavucontrol. … At least in theory that is how I think it SHOULD work. Whether it does or not, I’m hoping you can confirm.

Best wishes and congratulations on getting this far.

Thanks for your help oldcpu,
No I don’t move between mics ever really. Maybe if I was experimenting with a normal mic but usually one uses what’s working.
As a user of Linux for some years now I have still to learn a lot more of the command prompts and facilities like pavucontrol ( I wouldn’t have even known it was in there somewhere). I have tried, as much as possible, through these years to use the tools provided in the GUI (like YAST) to get this going but LINUX isn’t there yet (much better these days but not there as per Apple Mac etc). It’s the only way I have been able to show the die-hard Windows users that Linux is good and easy to use.

So now, surely the running of pavucontrol, or the like, should be an initial setup of OpenSuse to ensure that this mic problem becomes a thing of the past as there seems to be a lot of puzzled users trying to get their mics going with pulse audio. What was the older audio driver used before pulse audio took over? That seemed to just work as I remember.

Anyway - I am working - Skype now works great and so do all the other apps like Audacity.
Thanks again for the help and hopefully this discussion has helped some other folk.