Alsa broken in 11RC1

The built-in sound card on my Asus P5B system will not work under Alsa in
RC1. The problem lies not in the card but in Alsa as it does work under


The built-in sound on my Abit IP35 is working fine - however, my USB audio (M-Audio Mobile Pre) is broken and I should probably start a thread on that…

Try to remove this package


I had a sound problems withe some apps, and after many testing and remove some packages, finally I find the problem is with alsa-plugins-pulse, after I removing it everything works fine.

PS: Is there any chance to make opensuse 11.0 works with esound? because I feel confuse with PulseAduio!

I’ve read of a number of cases where users have had some difficulty with their sound in RC1. Often it is a misconfiguration of pulseaudio.

For example:

Before removing pulse audio, you could try the suggestions from this post:
openSUSE Forums - View Single Post - Amarok won’t play songs

Failing that, then maybe remove pulse audio as noted. However pulse audio is likely here to stay in 11.0 and maybe later openSUSE versions, so it would be good for us to learn how to make it work.

I had the same problem with my Sound Blaster Live! 24Bit

Removing the package “alsa-plugins-pulse”, and “alsa-plugins-pulse-32bit” fixed the problem for me as well.

I posted a bug report about sound quitting working in opensuse 11rc1 on intel 8x0 chipsets…the “fix” was to either rename the asound-pulse.conf to or delete it but I chose to save it…maybe this would help with other sound issues.

I’d also just like to confirm that with my Audigy 2, I have had problems getting it to work.

I’m hoping that when my zypper dup command finally finishes, and I have the final Suse 11.0 all will be well.

I can confirm that this can be fixed by downloading the development release of alsa, and compiling new kernel modules.

Then everything worked grand. (Although I might have removed some pulse stuff also).


I didn’t remove any package.
I renamed /etc/asound-pulse.conf to /etc/alsa-pulse.conf and than restarted alsa with “rcalsasound restart”.
It worked for me.

No issues with Audigy 2 Platinum EX - however I do not have PulseAudio installed at all.

Reference the Audigy 2, I noted a number of users had their mixer setup wrong, which was muting their sound. The mixer setting problem that stumped many was they needed to activate the “Digital/Analog Output button”, as this appears to be set to “OFF” by default? < not sure >

Could be worse oldcpu, you won’t believe the amount of stabbing that was needed to get X-Fi drivers to cleanly compile on 11.0 - not to mention Creative pretty much screwed up and you need to manually stab the startup scripts too :wink:

I also noted this obscure comment re: the Asus P5E:

TroubleShooting - ALSA wiki - Asus P5E tidbit

hda-intel: no codecs found!

The error message “hda-intel: no codecs found!” can be experienced, when the snd-hda-intel module fails to find the codec chip of your sound device. This may for example happen if your PCIe 1x sound card is in the wrong slot. For example on ASUS P5E mainboards, the supplied sound card is supposed to be inserted in the top most PCIe 1x slot. This is the brown slot on the P5E.
I wonder if there is a similar constraint for the P5B ?