ALPS touchpad recognized as PS/2 Generic Mouse

Hello all!
Notebook HP Pavilion dm1-2050er
OpenSUSE 11.3 Linux #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 x86_64
GNOME 2.30.0

My ALPS touchpad is works, taps, double taps, except scrolling. I often work “on the field”, and without configured touchpad its not so easy sometimes.

I heard a lot of bad words about version 11.3, but for me its was all working as needed out of the box, I just downloaded proprietary codecs and ATI drivers via one click installs. Great work, thanks a lot!

Here all I know:

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
  N: Name="PS/2 Generic Mouse"
  P: Phys=isa0060/serio1/input0
  S: Sysfs=/devices/platform/i8042/serio1/input/input1
  U: Uniq=
  H: Handlers=mouse0 event1 
  B: EV=7
  B: KEY=70000 0 0 0 0
  B: REL=3

bus = 17, name = PS/2 Generic Mouse
  handlers = mouse0 event1
  key = 00000000000700000000000000000000000000000000000000000000000000000000000000000000
  rel = 0000000000000003
  mouse buttons = 3
  mouse wheels = 0

  P: /devices/platform/i8042/serio1
  E: DEVPATH=/devices/platform/i8042/serio1
  E: SUBSYSTEM=serio
  E: DRIVER=psmouse
  E: SERIO_ID=00
  E: MODALIAS=serio:ty01pr00id00ex00
  P: /devices/platform/i8042/serio1/input/input1
  E: DEVPATH=/devices/platform/i8042/serio1/input/input1
  E: SUBSYSTEM=input
  E: PRODUCT=11/2/1/0
  E: NAME="PS/2 Generic Mouse"
  E: PHYS="isa0060/serio1/input0"
  E: EV==7
  E: KEY==70000 0 0 0 0
  E: REL==3
  E: MODALIAS=input:b0011v0002p0001e0000-e0,1,2,k110,111,112,r0,1,amlsfw
  P: /devices/platform/i8042/serio1/input/input1/event1
  N: input/event1
  S: char/13:65
  S: input/by-path/platform-i8042-serio-1-event-mouse
  E: DEVPATH=/devices/platform/i8042/serio1/input/input1/event1
  E: SUBSYSTEM=input
  E: DEVNAME=input/event1
  E: ID_SERIAL=noserial
  E: ID_PATH=platform-i8042-serio-1
  E: DMI_VENDOR=Hewlett-Packard
  E: MAJOR=13
  E: MINOR=65
  E: DEVLINKS=/dev/char/13:65 /dev/input/by-path/platform-i8042-serio-1-event-mouse
  P: /devices/platform/i8042/serio1/input/input1/mouse0
  N: input/mouse0
  S: char/13:32
  S: input/by-path/platform-i8042-serio-1-mouse
  E: DEVPATH=/devices/platform/i8042/serio1/input/input1/mouse0
  E: SUBSYSTEM=input
  E: DEVNAME=input/mouse0
  E: ID_SERIAL=noserial
  E: ID_PATH=platform-i8042-serio-1
  E: MAJOR=13
  E: MINOR=32
  E: DEVLINKS=/dev/char/13:32 /dev/input/by-path/platform-i8042-serio-1-mouse

70: PS/2 00.0: 10500 PS/2 Mouse
  [Created at input.183]
  Unique ID: AH6Q.U5GX9Ignjc0
  Hardware Class: mouse
  Model: "PS/2 Generic Mouse"
  Vendor: 0x0002 
  Device: 0x0001 "PS/2 Generic Mouse"
  Compatible to: int 0x0210 0x0003
  Device File: /dev/input/mice (/dev/input/mouse0)
  Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event1, /dev/char/13:65, /dev/input/by-path/platform-i8042-serio-1-event-mouse, /dev/char/13:32, /dev/input/by-path/platform-i8042-serio-1-mouse, /dev/char/13:63
  Device Number: char 13:63 (char 13:32)
  Driver Info #0:
    Buttons: 3
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=no, avail=yes, need=no, active=unknown

Little update. :slight_smile:
I tried all she suggestions and manuals where people fights with similar problems, without success.
Now I tried modify file 20-synaptics.conf in xorg.conf.d directory.

Section "InputClass"
	Identifier "catchall touchpad"
	**MatchDevicePath "/dev/input/event1"**
	Driver	"synaptics"
	**MatchIsTouchpad	"off"**
	Option	"HorizScrollDelta"	"0"
	Option "SHMConfig" "on"

and X session wont start with it. Started successfully after I changed MatchIsTouchpad “off” to “on” back. It’s a check, that target device is touchpad, right?
I’m very interested to solve this problem.

Good luck, I don’t think anybody in recent history has been able to fix this.

Hello Lanchardan,

I have a Pavilion DV7 with 11.3, this one has a large touchpad (called clickpad) and I am suffering it a lot! :confused: too.

I dont know exactly what is the problem you do have, can you explain it more?

For example, my touchpad also works fine, I can tap, double tap, left click and right click… but the “disable touchpad when typing” feature works VERY BAD, I mean… when I type “working on the field” I sometimes click with my palm somewhere else and its a mess.

Unfurtunately, the “disable touchapd when typing” sometimes just stops working (sometimes after hibernation or suspend…) I know that the program in charge of this feature is syndaemon…

It would be better if I could enable some kind of option like “palm detection” this works by default in m$window$ but cant get it working here.

Here is my 20-synaptics.conf (I also tried several options more, but no luck :frowning: it seems that there are only few people with this problem or just dont bother them too much)

Section "InputClass"
	Identifier "touchpad catchall"
	Driver "synaptics"
	MatchIsTouchpad "on"
	MatchDevicePath "/dev/input/event*"
	Option "SHMConfig" "true"
	Option "proto" "imps"
	Option "Buttons" "2"
	Option "Emulate3Buttons" "no"
	Option "TouchpadOff" "0"
	Option "LBCornerButton" "1"
	Option "RBCornerButton" "3"

I.E. This should disable the middle click button I think…
Option “Buttons” “2”
Option “Emulate3Buttons” “no”
But it does not :frowning: