Almost no sound after fresh installation of opensuse 11.3


Following some problems of kernel upgrade, I have resinstalled my system. I now have some issues with sound. CD are recognized and played but no sound is coming out of my speakers (tested with amarok and caffeine). Same thing on youtube: I see the video and get no sound.

However, I can hear the test sound form Configure Desktop / Multimedia

Any clue about what is going on?


Linux linux 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 i686 i686 i386 GNU/Linux

So I am not sure where in the setup process you might be. However, if you have not read this, then you need to do so.

Multi-media and Restricted Format Installation Guide

Thank You,

Thanks jdmcdaniel3,

I have followed the guide up to the installation of the gnome-mplayer and gecko-mediaplayer packages.

Still no sound coming out of any program (firefox, skype, amarok, vlc) except the system.

Silly question but did you check your volume controls?
Di you try to reconfigure your sound devices and check in the advanced tab?

I feel very stupid right now… I just had to increase the gain for PCM in the audio mixer and got my sound back. Sorry for the unnecessary use of your time.

I know I spent an hour in audio settings one time because that silly PCM slider was all the way down - LOL! Glad you got it.

pomchip says:

I feel very stupid right now… I just had to increase the gain for PCM in the audio mixer and got my sound back. Sorry for the unnecessary use of your time.
You know this has happened to us all. Good to hear you found the problem and all is well now.

Thank You,

hello guys! i am new to linux and especially opensuse. I installed today opensuse 11.3 kde and i am experiencing the same sound <<problems>>. I can hear system sounds and online radio stations (amarok), but i have no sound in youtube and kaffeine. I changed the priority list @ the personal settings for the audio devices, and i also added ,or at least tried, to add all the available channels for my audigy 2 ZS. I say tried because all the channels are more than 20 (not the exact number, bored to count) and kmix crashed twice when attempting that. Apart from that, PCM slider is on max, and also PCM capture slider. Also in my system exist some other audio devices :one from my ati hd4850 and the on-board 7.1. I need only my audigy, so i don’t have problem disabling the rest if you tell me how. Does anyone have any suggestions?

edit:visible + available =46 (7 visible)

After messing around a little bit with yast sound settings and personal settings, according to user zak89, i can enjoy simultaneously amarok, youtube and kaffeine :P.
First thing i did was to delete all soundcards from yast sound options.Rebooted, configured automatically only the soundcard of interest (SB Audigy 2 ZS). Rebooted again -don’t know if it was necessary, but some weird system behaviour persuaded me to do so - and through personal settings/sound options i sorted out the priority list after testing what is working and what not. Voila, works like a charm. Although i get a notification that something is not working but i can hear sound when pressing test…
Does not matter for me, i can enjoy my system from now on!
I forgot to mention that under personal settings / multimedia i applied the device list to everything.