All windows open in upper left corner?

I’m using KDE (Opensuse 11) and all my windows open in the upper left corner. Does anyone know how to change it? This didn’t happen on a previous install…

I’m running compiz, if that matters…

Thank you

In kde3
go to control centre - Desktop - Window Behavior
Look for placement
Change to Maximized or Smart (I think) Mine is smart

In kde4 it’s
Config Desktop - Window behavior

Thank you for the quick response, but I couldn’t find the setting under the KDE config. I’m using compiz, and did find the window placement setting under there, and it seems to have worked.

Thanks again.